English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   WinUAE 4.9.0 beta series (Was 4.5.0) (http://eab.abime.net/showthread.php?t=104099)

Mad-Matt 12 January 2021 13:09

1 Attachment(s)
Here it is.

White 12 January 2021 13:15

thanks now I try

White 12 January 2021 13:40

Same problem, after boot the screen remains black.

Installation speed is slow

during installation vga select it or deselect it?

If you have time make a video it would be useful I always try to learn, Thanks

Mad-Matt 12 January 2021 13:49

2 Attachment(s)
Are you at least getting the first screen? When the cd boots it should open on the voodoo screen. Perhaps make sure ppc firmware isnt booting the cd and overriding the floppy.

White 12 January 2021 14:03

you made me doubt,
surely it was overwritten as you say
i just replaced the grex .adf it now appears,

I try to redo the installation.
you are probably right

White 12 January 2021 14:13


you were right it works :)
now installation is also fast
surely the adf had been overwritten
but I've always used grex + uaegfx

Thanks again
excuse the question but the advantage of using 4000T
what's it about?

Mad-Matt 12 January 2021 14:17

just cosmetic :D

White 12 January 2021 14:17

how do i remove the blinking of the keyboard?
looks like a christmas tree :D

Mad-Matt 12 January 2021 14:18

Keyboard leds in WinUAE /Misc settings I guess?

White 12 January 2021 14:28

ok keybord no LED
(NumLock) (CapsLock) (ScroolLock)

Thanks I can finally resume installing the applications now I have to work on the 16 megs of the voodoo and optimize the graphics to completely replace it with uaegfx.

Thanks again :)

White 12 January 2021 14:30

one last thing MISC/FASTER RTG is disabled in your configuration why?

Mad-Matt 12 January 2021 14:35


Originally Posted by White (Post 1452960)
one last thing MISC/FASTER RTG is disabled in your configuration why?

I try to avoid any speed hacks. helps narrow down problems to amiga software instead of random uae settings.

White 12 January 2021 14:40

Thanks for the explanation :-)

White 12 January 2021 17:03

2 Attachment(s)
I added some applications (4.1 FE)
everything works fine,
2 crashes occurred I don't know the reasons
maybe dumps can be useful:


Toni Wilen 12 January 2021 19:17


Originally Posted by White (Post 1453032)
I added some applications (4.1 FE)
everything works fine,
2 crashes occurred I don't know the reasons
maybe dumps can be useful:

This is quite odd. Crash in same place as in your 32-bit crashes are but reason isn't exactly same. So there really appears to be some kind of bug that only triggers in some specific conditions.

Does it crash during normal OS 4.1 (or even when just leaving it running without doing anything) use or when you do some specific operations?

You also mentioned Faster RTG option. It can in theory affect this, what if you disable it?

White 12 January 2021 21:09

It happened that winuae exited without doing anything and without "dump" it simply exited.
I am currently configuring many applications
I deactivated "faster RTG" to try it seems at the moment there is no difference the speed seems the same but I am doing a lot of operations with directory exchange files etc.
stability is excellent, maybe the videos seem more responsive but it's too early to tell.

White 12 January 2021 21:19

It's probably not important,
a further "full-bodied hotfix" update is now out to fix update 2 on reboot everything works without correcting the startup-sequence and seems compatible with grex + voodoo :-)

White 14 January 2021 09:28

sorry what test I could do with FasterRTG to see the differences
currently the only inconvenience that occurs but I have not yet been able to understand it and that at boot the amigaos 4.1FE system very rarely goes into total block after booting in practice it freezes and I have to restart winuae.
It doesn't give me any dump I just have to quit winuae and restart it and only the 4.1FE system crashing instead winuae keeps running.
Thanks again.

White 15 January 2021 15:28

screen locked on boot

solution adopted:
when at boot the screen remains frozen
I press F12 and then again on "start" the screen resumes working normally this happens with "faster RTG" enabled and also on disabled.

Toni Wilen 23 January 2021 15:04


Beta 16:

- Hard reset leaked indirect mode allocated memory banks (outside of JIT compatible address range), for example Z3 RAM outside of partially outside of first ~2G of address space.
- GUI misc list powerled dims option never worked, option was always cleared. (Only manual config file editing worked)
- fi debugger command now accepts assembly syntax (for example "fi trap #0"). Only max first 3 words (if it is longer than 3 words) are used in breakpoint condition.
- CPU% OSD leading zero removed.
- "Blacker than black" display panel option did nothing in non-AGA modes.
- 68060 unimplemented integer instruction mode + unimplemented instruction with -(A7)/(A7)+ addressing mode in user mode: exception stack frame was created first, then -(A7)/(A7)+ modification was incorrectly restored using supervisor stack pointer.
- 68040/060 unimplemented FPU instructions also update FPIAR. Some invalid instructions don't but this seems to be undefined behavior. 6888x only update FPIAR if FPU exception(s) are enabled.
- 68040/060 unimplemented FPU mode arithmetic exception fixes, all 68060 FPSP test package tests now pass. (and when run using 68040 or 6888x: test errors will match real hardware 100%)
- Fixed FMOVEM.L #xxx,<more than one control register> disassembly.
- Windowed mode status bar height is correctly calculated when window is moved to different DPI monitor.
- Removed ROM scan expansion device result list. It is out of date and code was almost unmaintainable.
- Hopefully last blitter update related fix, copper blitter waits should work correcly again. (This is a hack. Copper emulation also needs an update.)

All times are GMT +2. The time now is 14:35.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.

Page generated in 0.11958 seconds with 11 queries