English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.FS-UAE (http://eab.abime.net/forumdisplay.php?f=122)
-   -   Amilator v 4.12-3 (http://eab.abime.net/showthread.php?t=91638)

malko 20 August 2021 18:11

Find this thread speaking as well about FS-UEA in Raspberry Pi :)

milyrouge 14 September 2021 15:57


Originally Posted by Methanoid (Post 1501966)
No FS-UAE for Arm so you may as well look at Amiberry or PiMiga

FS-UAE can be made to work for RPI, even including support for PPC emulation. I managed to get it working, though it's not exactly lighting fast!

razstore 17 October 2021 10:58

Amilator USB STICK joystick doesn't work

Originally Posted by MikeyG (Post 1403596)
So decided to take a baby step in working on this and just updating the debian 686 version before attempting to make a x64 ubuntu version.

I have updated it to Debian 10 buster which uses 4.19 kernel.
I have also updated FS-UAE from 2.8 to 3.0.5 as there have been some great improvements done to FS-UAE itself.
Have tested it on the machines I have here and looks good but would like people to test it out and give feedback good or negative.
My first attempt at this so learning as I go along but enjoying it so far :)


Thank you for your work
I am retired and am installing TinyLaucher with Amilator on USB STICK for my grandchildren
Everything works great, I have the keyboard but the joysticks do not work
I tried several game controllers (Xbox360 Wireless USB transmitter, Sony Dual Shock USB, Thrustmaster T mini wireless USB transmitter and a Thrumaster wired USB
I wanted to know which drivers are installed in Amilator?
Can we add more?
It would be nice if you could help me, I've been struggling with this problem for a week
Here is my configuration:
# FS-UAE configuration saved by FS-UAE Launcher
# Last saved: 2021-09-27 19:20:41

amiga_model = A1200/020
chip_memory = 2048
cpu = 68020
fast_memory = 4096
base_dir = /root/
theme = /amiga/themes/1084x_night_wall_white_1.0
hard_drive_0 = /amiga/harddirs/TinyLauncher
#joystick_port_0_mode = joystick
joystick_port_0 = xinput_controller
#joystick_port_1 = xinput_controller
kickstart_file = /amiga/roms/kick31.rom
keep_aspect = 1
floppy_drive_count = 2
mouse_speed = 75
jit_compiler = 0
fullscreen_mode = Fullscreen
line_doubling = 0
#shader = crt-easymode-halation
sound_card = toccata
uaem_write_flags = 0
screenshots_output_dir = /amiga/Screenshots
governor_warning = 0

Translated with www.DeepL.com/Translator (free version)

razstore 31 October 2021 13:18

Problems solved!!!
I had changed in the Amilator config "Fullscreen_mode = window " by "Fullscreen_mode = fullscreen or Fullscreen = 1"
But it doesn't work with the controllers
Why, I don't know?
Leave the original Amilator config
All my controllers (Sony, Xbox360, ThrustMaster, etc...) are now recognized

Hercules 24 March 2022 09:56


Originally Posted by Dunny (Post 1232429)
I was working on a version that loaded FS-UAE from outside the SquashFS archive, for easy updating. Never did finish it...

Isn't it pretty much a command line affair to disable JIT anyway? I do that for all WHDLoad games (but run at maximum speed).

Would be great if somebody could accomplish lhis, as it would make updating the emulator a hell of alot easier ?

vk3heg 29 March 2022 08:48


Originally Posted by Hercules (Post 1537447)
Would be great if somebody could accomplish lhis, as it would make updating the emulator a hell of alot easier ?

Amilator updated...


Methanoid 30 March 2022 11:58


Originally Posted by vk3heg (Post 1538140)

in 2018 ???? :nuts

vk3heg 03 April 2022 08:59


Originally Posted by Methanoid (Post 1538320)
in 2018 ???? :nuts

What do you mean 2018? I did this update *this* year.

Did you even read the thread? :spin

Methanoid 03 April 2022 11:42

No I didn't re-read whole thread, just your link which was kinda duff

All times are GMT +2. The time now is 21:01.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.07051 seconds with 11 queries