English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Trying to have portable configuration, relative paths relative to C:\Public\... ? (http://eab.abime.net/showthread.php?t=59824)

Turrican 24 June 2011 14:28

Trying to have portable configuration, relative paths relative to C:\Public\... ?
 
Hi,

I've WinUAE 2.3.2 and W7 Pro 64bit. I'm trying to make a "portable" configuration for an USB stick.

I figured already that creating an empty winuae.ini in the same dir the winuae.exe is uses that instead of the registry.

However, when I go to "Paths" and configure "use relative paths" they are always relative to C:\Users\Public\Documents\Amiga Files\WinUAE ; I'd rather expect them to be relative to the winuae.exe . That makes it hard to create a portable configuration. Or am I missing something?

Thanks for the clarification!

Toni Wilen 24 June 2011 14:39

Try "winuae -portable" command line parameter (delete winuae.ini first)

Paths panel should show all paths in ".\whatever_the_path" format.

Turrican 24 June 2011 14:48

Thanks, that seems to work!

I see that it changes PathMode from WinUAE_2 to WinUAE ; is this the flag to indicate that this is a "portable" configuration? So I don't need to care about always providing -portable to winuae.exe ?

I tried to find documentation about this but failed, I tried winuae.net and the downloaded ZIP; thanks

Toni Wilen 24 June 2011 16:33

Empty winuae.ini and -portable should do exact same thing. Obviously it does not, I am not sure why..

But I am 100% sure I don't any any documentation :)


All times are GMT +2. The time now is 03:45.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04025 seconds with 11 queries