English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   WinUAE 4.9.0 beta series (Was 4.5.0) (http://eab.abime.net/showthread.php?t=104099)

Zarnal 29 April 2021 14:27

Note : for Abyss-Curious, all is ok with 68010 ( full CE) or Quickstart A1200. Issue is only with 68000.

amilo3438 29 April 2021 16:39

Quote:

Originally Posted by amilo3438 (Post 1479679)
"Quarterline-TrRickDangerous" - broken from beta18

Rick Dangerous by Quaterline


Btw. No need to test until next beta! :)

Zarnal 29 April 2021 16:53

Quote:

Originally Posted by amilo3438 (Post 1480025)
Rick Dangerous by Quaterline


Btw. No need to test until next beta! :)


But Beta 19 was released yesterday evening.


We must wait for the b20 to continue the tests if I understand correctly ? :)

amilo3438 29 April 2021 16:56

Not in general, only for the one I mentioned above. (it is still broken in beta19) :)

EDIT:
But maybe would be wise to wait for the next version. (there are already enough test cases presents)
And I also completed with "Problematic Demos" topic test cases finding nothing new.

EDIT2:
Also, there are some new A500 OCS/ECS demos on pouet that I have never tested before... (so if you are interested)
https://www.pouet.net/prodlist.php?p...ga%20OCS%2FECS

Zarnal 29 April 2021 17:11

Quote:

Originally Posted by amilo3438 (Post 1480031)
[B]Not in general, only for the one I mentioned above. (it is still broken in beta19)

EDIT:
But maybe would be wise to wait for the next version. (there are already enough test cases presents)
And I also completed with "Problematic Demos" topic test cases finding nothing new.

EDIT2:
Also, there are some new A500 OCS/ECS demos on pouet that I have never tested before... (so if you are interested)
https://www.pouet.net/prodlist.php?p...ga%20OCS%2FECS




I understand better. :)

Note : there were also some improvements in AGA with few demos / intros that never worked properly before the new blitter emulation. Ozf-rendervous, FocusDesign-Methylate for example).

Edit : i will test the demos of your link soon. :)

Zarnal 29 April 2021 17:51

Quote:

Originally Posted by amilo3438 (Post 1480025)
Rick Dangerous by Quaterline


Btw. No need to test until next beta! :)


Here is the savestate.

amilo3438 29 April 2021 19:03

Quote:

Originally Posted by Zarnal (Post 1480034)
Edit : i will test the demos of your link soon. :)

Be also aware that those newer demos are probably coded on some of previous WinUAE versions, so don't expect to find too much!
Question would be are they working correctly on a real thing?
For us is relevant that demos were coded on a real machine so we can compare it with the emulator - and
these were coded before emulator existence or maybe a few yrs later.

EDIT:
Like for example this one coded 2011: Hotbleeps by Loonies
In WinUAE2410 it runs according to the pouet picture/video ... on newer WinUAE versions it runs different!

Unfortunately on latest WinUAE beta19 it does not run at all. :confused (but it runs if cpu=68010 - same as on the pouet picture/video - very interesting!)

Zarnal 29 April 2021 19:43

Quote:

Originally Posted by amilo3438 (Post 1480072)
Be also aware that those newer demos are probably coded on some of previous WinUAE versions, so don't expect to find too much!
Question would be are they working correctly on a real thing?
For us is relevant that demos were coded on a real machine so we can compare it with the emulator - and
these were coded before emulator existence or maybe a few yrs later.

EDIT:
Like for example this one coded 2011: Hotbleeps by Loonies
In WinUAE2410 it runs according to the pouet picture/video ... on newer WinUAE versions it runs different!

Unfortunately on latest WinUAE beta19 it does not run at all. :confused (but it runs if cpu=68010 - same as on the pouet picture/video - very interesting!)




It looks like the case of the intro "Tommyknockers". Toni explained that it was a known 68000 CPU bug that was appearing with the new blitter emulation. See #337.

amilo3438 29 April 2021 20:18

Quote:

Originally Posted by Zarnal (Post 1480086)
It looks like the case of the intro "Tommyknockers". Toni explained that it was a known 68000 CPU bug that was appearing with the new blitter emulation. See #337.

So we already have collected 4 test cases for this strange 68000 cpu problem that appears in latest betas:

"TOMMY-Bobs" - stops at 1st beginning (fine with 68010 cpu!)
"MAYHEM-Expiration" - glitches an cube rotation part with! (fine with 68010 cpu!)
"ABYSS-Curious" - nothing happens after text rotation part! (fine with 68010 cpu!)
"Hotbleeps by Loonies" - nothing happens! (fine with 68010 cpu!)

amilo3438 30 April 2021 14:04

Quote:

Originally Posted by amilo3438 (Post 1479434)
I see no problem with the performance ! (it seems to perform even better and much smoother than previous beta16 on one of my old quadcore E5450)

Well, on an A500 configuration it is not that noticeable but on A1200 it is a lot!
Hopefully, my old cpu is stil able to cope with this. (although very close to its limits)

Ps. I am talking about most demanding A1200 demos!

EDIT:
Also I noticed that this newer winuae versions does not have problem with framerate counter fluctuating at all (in comparison to winuae4400 latest official that jump like crazy).
If you run/open both versions with the same demo, you will noticed that old version lag during some period after the new beta version.

amilo3438 30 April 2021 20:30

Quote:

Originally Posted by amilo3438 (Post 1450919)
Psylteflesk by Ephidrena -> http://www.pouet.net/prod.php?which=50125
Picnicbass by Ephidrena -> http://ada.untergrund.net/?p=demo&i=671

Tested Configuration
-----------------------
WinUAE Quickstart
Model: A4000
Configuration: 68030, 3.1 ROM, 2MB Chip + 8MB fast

Drives:
DF0: "Workbench v3.1 rev 40.42"
DH0: "eph-psylteflesk.lha" (or "eph-picnicbass.lha")

NOTE: One of above demos is attached as archive via "CD & Hard drives / Add Directory or Archive... / Select Archive or Plain File"

Crashes at start on beta19! (but for example work fine on beta16)

Ps. Didn't test between versions!

EDIT:
lapsuus by Maturefurk -> https://www.pouet.net/prod.php?which=3284
Strange line appears on the bottom! (fine in beta16) (same config as above)

Toni Wilen 30 April 2021 21:44

Quote:

Originally Posted by Zarnal (Post 1480045)
Here is the savestate.

At least check with previous official version before uploading because this is useless statefile, it won't work with any version :)

Fixed but this statefile can't ever work.

Quote:

Originally Posted by amilo3438 (Post 1480072)

Fixed. Pouet screenshot is wrong.

(I never had any problems with 68000. Did you really have correct config?)

Quote:

Originally Posted by Rotareneg (Post 1479880)
The second and third paragraph at the very beginning of Desert Dreams is missing the first row of pixels on b18 and b19, A500 quickstart config.

Fixed.


And probably some others work now without glitches too.

--

I'll currently ignore anything that is not custom chipset related. 4.9-only not working with 68000 but working with 68010 most likely is problem with not-yet-update blitter internal RGA bus pipelining/CPU cycle allocation.

Also as usual, beta problems only!

amilo3438 30 April 2021 22:18

Quote:

Originally Posted by Toni Wilen (Post 1480380)
Fixed. Pouet screenshot is wrong.

(I never had any problems with 68000. Did you really have correct config?)

Fixed.

I have checked again and now it is working in beta19 with both 68000 and 68010. (acc. to pouet pic.)
I cant explain what was wrong before, as I use same qs A500 most common config in all cases.

Yes, in new test beta it is now working again as it was before. (i.e. different as is shown on the poet pic.)


Quote:

Originally Posted by amilo3438 (Post 1480025)

Confirmed to work in the latest test beta version.

Zarnal 01 May 2021 11:14

Quote:

Originally Posted by amilo3438 (Post 1480362)
Originally Posted by amilo3438 View Post
Psylteflesk by Ephidrena -> http://www.pouet.net/prod.php?which=50125
Picnicbass by Ephidrena -> http://ada.untergrund.net/?p=demo&i=671

Tested Configuration
-----------------------
WinUAE Quickstart
Model: A4000
Configuration: 68030, 3.1 ROM, 2MB Chip + 8MB fast


Confirmed.



Note : for ADF type


1 for PicNicBass : Freeze during first part. Since b18.

2 for Psyltefrek : Software Failure.Since b18.

Toni Wilen 01 May 2021 14:28

Quote:

1 for PicNicBass : Freeze during first part. Since b18.

2 for Psyltefrek : Software Failure.Since b18.
Fixed. Non-softfloat mode FPU FSINCOS was broken.

Zarnal 01 May 2021 15:09

Quote:

Originally Posted by amilo3438 (Post 1480362)

EDIT:
lapsuus by Maturefurk -> https://www.pouet.net/prod.php?which=3284
Strange line appears on the bottom! (fine in beta16) (same config as above)


Confirmed. Since b18.

Toni Wilen 01 May 2021 15:25

Quote:

Originally Posted by amilo3438 (Post 1480362)
lapsuus by Maturefurk

Fixed. (AGA bitplane scandoubling didn't work correctly)

Toni Wilen 01 May 2021 17:32

Quote:

Originally Posted by amilo3438 (Post 1480105)
"TOMMY-Bobs" - stops at 1st beginning (fine with 68010 cpu!)
"MAYHEM-Expiration" - glitches an cube rotation part with! (fine with 68010 cpu!)

Files/links?

amilo3438 01 May 2021 17:42

Demo Mix 5 intro (Intro) by Tommyknockers -> http://eab.abime.net/showpost.php?p=...&postcount=484

Expiration (Demo) by Mayhem -> http://eab.abime.net/showpost.php?p=...&postcount=429

Btw. All can be find at the previously "Problematic Demos" topic on the 1st page. (as I tested only them)


Quote:

Originally Posted by Toni Wilen (Post 1479042)
What to check:

- Old bug(s) reappearing (hack removed but missing edge case wasn't reimplemented properly)
- Other bugs.
- Really bad performance. (But buy a new PC if you have something like pre-Sandy Bridge era CPU). New emulation is more complex but also some previous "lazy evaluation" optimizations might not be fully working.

I think I finished rechecking old problems testing for now! (waiting until blitter vs 68000 problem is fixed)

Toni Wilen 01 May 2021 18:08

Quote:

Originally Posted by amilo3438 (Post 1480509)
Demo Mix 5 intro (Intro) by Tommyknockers -> http://eab.abime.net/showpost.php?p=...&postcount=484

Expiration (Demo) by Mayhem -> http://eab.abime.net/showpost.php?p=...&postcount=429

Btw. All can be find at the previously "Problematic Demos" topic on the 1st page. (as I tested only them)

I thought so but search didn't find anything. Please use same names next time :)


All times are GMT +2. The time now is 17:07.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.13085 seconds with 11 queries