English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   WinUAE 4.9.0 beta series (Was 4.5.0) (http://eab.abime.net/showthread.php?t=104099)

amilo3438 29 July 2021 21:11

Quote:

Originally Posted by Zarnal (Post 1498529)
I just tested in Windows 10 and it doesn't change anything.

There, i really do not understand what is going on. :confused

Beta 24 is ok but not b25 and b26 in same conditions. :)

Same, on my Win10 machine it shows the same problems as on Win7! (just tested)

Zarnal 29 July 2021 21:40

I have new information (for residual image of my two reports at least): this no longer happens if "subpixel display emulation" is activated ( but in principle this option is only for AGA only if I am not mistaken ).

It is probably because this option is enabled in your configuration that you are unable to reproduce the issues. :)

amilo3438 29 July 2021 21:54

Quote:

Originally Posted by Zarnal (Post 1498534)
this no longer happens if "subpixel display emulation" is activated

Yes, with this option enabled all my previous problems are gone! :)

bernd roesch 30 July 2021 12:43

i can not open the b25. windows defender show Trojan:Script/Oneeva.A!ml . b26 work

Ambermoon 30 July 2021 14:35

Native 'PAL:Hires Interlace' video mode is broken/garbled with AGA chipset for me since beta 18.

I have a default Workbench 3.1 setup that I use since almost forever. With the most recent beta versions its default video mode 'PAL:Hires Interlace' is either completely broken ot garbled while AGA is selected as graphics chip. Still working with OCS/ECS.

The issue occured the first time in beta 18 and is still there in the latest beta. Looks somewhat different now, but is still unusable.

BTW: Many thanks for the awesome improved G-Sync/VRR support, much better than 4.4.0. Got a G-Sync compatible monitor recently, which is why I checked the beta versions in the first place.

Toni Wilen 30 July 2021 14:39

Quote:

Originally Posted by bernd roesch (Post 1498614)
i can not open the b25. windows defender show Trojan:Script/Oneeva.A!ml . b26 work

It happens few times every beta series. There is nothing I can do. It is almost always WD only..

Quote:

Originally Posted by Ambermoon (Post 1498630)
Native 'PAL:Hires Interlace' video mode is broken/garbled with AGA chipset for me since beta 18.

Works for me. This is quite common mode so there must be some other variable(s). Do you have modified overscan settings for example? Does it work if you use defaults? If yes, attach your overscan.prefs file.

With or without "remove interlace artifacts"? (It isn't fully working).

Ambermoon 30 July 2021 14:50

Unchecking 'Remove interlace artifacts' does the trick.

OCS/ECS work with or without the option.
AGA only works when it's unchecked.

Toni Wilen 30 July 2021 21:30

winuae.7z should fix graphics corruption but there is always chance it breaks something else... (I am trying to remove as much as possible unneeded looking code and sometimes it is really needed, sometimes it is code that has been obsolete years ago)

Next beta tomorrow if confirmed.

Quote:

Originally Posted by Ambermoon (Post 1498632)
Unchecking 'Remove interlace artifacts' does the trick.

OCS/ECS work with or without the option.
AGA only works when it's unchecked.

I can't duplicate it with this option enabled. (If you really have b26. It is first beta where it works again)

Check overscan settings. Does it happen if you use standard 640x512 (if overscan was set to larger).

Which AmigaOS version?

rutra80 30 July 2021 22:20

Quote:

Originally Posted by Toni Wilen (Post 1498361)
FX11 moved to separate static library.

Is this why now on WinUAE launch I get "Install anyway" system window when I have enabled "Warn me before installing apps from outside the Store" Windows option?

Toni Wilen 30 July 2021 22:30

Quote:

Originally Posted by rutra80 (Post 1498682)
Is this why now on WinUAE launch I get "Install anyway" system window when I have enabled "Warn me before installing apps from outside the Store" Windows option?

No. I am not sure what this message is supposed to mean in this situation. winuae never tries to install anything. It sounds more like winuae tries to open something or load some dll etc and the external driver/dll shows this message.

Did you confirm it does not happen with previous official version? If it is some driver/etc update caused this side-effect.

FX11 is now statically linked = it is still embedded in winuae.exe. (For some unknown reason after some last year MSVC update, compiling FX11 resulted in hundreds of errors. I didn't want to debug this so I simply disabled it completely. Few days ago I noticed standalone FX11 does compile fine so I compiled it as a static library, removed FX11 sources from winuae tree and replaced it with static library)

Zarnal 30 July 2021 22:42

Quote:

Originally Posted by Toni Wilen (Post 1498677)
winuae.7z should fix graphics corruption but there is always chance it breaks something else... (I am trying to remove as much as possible unneeded looking code and sometimes it is really needed, sometimes it is code that has been obsolete years ago)

Next beta tomorrow if confirmed.


It's now ok for me ( Nevermind14, Blue Venture, Arc Ed, Crash Landing, Legalize It 2 and Hit the Road tested again ). :)

rutra80 31 July 2021 14:15

Quote:

Originally Posted by Toni Wilen (Post 1498684)
No. I am not sure what this message is supposed to mean in this situation. winuae never tries to install anything. It sounds more like winuae tries to open something or load some dll etc and the external driver/dll shows this message.

Did you confirm it does not happen with previous official version? If it is some driver/etc update caused this side-effect.

FX11 is now statically linked = it is still embedded in winuae.exe. (For some unknown reason after some last year MSVC update, compiling FX11 resulted in hundreds of errors. I didn't want to debug this so I simply disabled it completely. Few days ago I noticed standalone FX11 does compile fine so I compiled it as a static library, removed FX11 sources from winuae tree and replaced it with static library)

It happens with x64 build only - x86 build doesn't trigger the window, and the last x64 beta build I found (b17) doesn't trigger it either.
Lately I updated Radeon drivers to non-signed beta version...

amilo3438 31 July 2021 15:36

Quote:

Originally Posted by Toni Wilen (Post 1498677)
winuae.7z should fix graphics corruption but there is always chance it breaks something else...

No problem with this one! (so far works good)

BlackByte 01 August 2021 10:14

Hi Toni, my OS4.1 configuration crashes immediately when loading. (have tested all betas)

Viceroy 01 August 2021 12:25

1 Attachment(s)
Quote:

Originally Posted by BlackByte (Post 1498853)
Hi Toni, my OS4.1 configuration crashes immediately when loading. (have tested all betas)

Working fine here!

Zarnal 01 August 2021 12:49

For me too.

At least for Grex+Voodoo 3 or Mediator+Voodoo3.

@BlackByte

What exact version of OS4 are you using and what graphics card emulation ?

White 01 August 2021 13:40

@BlackByte
here too "uaegfx" and "voodoo" works well
only beta 24 crashed on boot
with beta 26 everything seems to work fine
with both versions of winuae 32 and 64bit for 4.1

BlackByte 01 August 2021 13:47

Version 4.1 Final Edition Update1 !

BlackByte 01 August 2021 14:03

Under Path, System Rom, Scan Subfolder enabled, all ROMs are no longer displayed.

BlackByte 01 August 2021 14:04

sorry, winuae 4.9 b26


All times are GMT +2. The time now is 13:12.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.13011 seconds with 11 queries