English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   Amitcp 3.02b STOPNET script not working with prism2 WIFI card (http://eab.abime.net/showthread.php?t=63516)

melbourneben! 15 March 2012 02:08

Amitcp 3.02b STOPNET script not working with prism2 WIFI card
 
Hi All,

Does anyone use amitcp 3.02b? I've been using it for some time with my WIFI PCMCIA (MA401) card using prism 2 drivers, it works great apart from one small niggle. I run startnet from the amitcp bin directory to start the tcp/ip stack but when I try and run stopnet to stop tcp/ip it just freezes on me...My only option is to then reboot.

I opened stopnet in a text editor and it looks like an AREXX command, as below:

rx "address AMITCP; KILL" ; Send "KILL" to AmiTCP

I've tried breaking the process manually and again my Amiga just freezes, so it doesn't appear to be the Stopnet script at fault.
Can anyone shed any light on this? Maybe I should I try a different version of Amitcp or a different stack. In the past I've tried version 4 but could never get it to work.
Cheers

Ben

mfilos 15 March 2012 07:11

IIRC it doesn't freeze when I use Miami but I'm not 100% sure.
I'll try that tonight when I get back from work and report back mate.

melbourneben! 15 March 2012 08:24

Mfilos: Thanks mate, would appreciate you testing. I may also try installing Miami. That way I can establish if its the stack I'm using or something else at fault.

melbourneben! 16 March 2012 10:44

mfilos: Did you get chance to test? I installed Miami and it still freezes when I go offline. I'm starting to think it might be the pcmcia card?

I'd be interested to know what version of Workbench you're running especially if you find your stack doesn't freeze? I'm running 3.0 but have 3.1 on order. Not that WB version should make any difference?

mfilos 16 March 2012 22:48

Yep sorry mate for not replying earlier.
Putting offline the stack didn't freeze my Amiga.
- I putted stack online then opened AWeb and then putted it offline and then Quit.
- Then I putted stack back online and opened AmIRC then closed AmIRC and putted it offline again and still no freeze.

I'm running a special customized version of ClassicWB 3.1 Full (you can check a video here: http://www.youtube.com/watch?v=kPMu1H3zeig) running on Kickstart 3.1.
Tbh I run a customized kickstart as well kicked via ACA630's MapROM feature but haven't putted anything important that has anything to do with the PCMCIA stuff.

Well 3.0 could be an issue as it has a different card.resource iirc so only checking it out would make it sure.
Also have you put CardReset and CardPatch early in your Startup-Sequence?

melbourneben! 17 March 2012 03:02

Mfilos: Thanks for testing mate. Can you confirm your using a netgear ma401 wifi card?

I'll be getting new 3.1 kickstart roms in the post early next week so it will be interesting to see if that makes a difference.

mfilos 17 March 2012 09:33

Yes mate. I'm using a NetGear MA401 WiFi card upgraded with Firmware/Station.

melbourneben! 18 March 2012 08:25

thanks mfilos, If I have no luck with kickstart 3.1 I might try upgrading the firmware, I saw a link on how to do this on your blog. BTW, your blog makes interesting reading :)

mfilos 18 March 2012 14:17

Hehe cheers mate. If you need anything just gimme a PM shout :)


All times are GMT +2. The time now is 16:52.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04442 seconds with 11 queries