English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Cadaver Save Disk (http://eab.abime.net/showthread.php?t=38308)

Toni Wilen 30 July 2008 15:57

Write routine is stupid, very stupid.

It waits for index sync. Starts write DMA. Waits for next index sync and immediately kills the DMA..

EDIT:

This has nothing to do with needing more space than standard floppy can hold. Game only needs about 11968 bytes per track but the way of killing the DMA is causing some error somewhere. This really seems to be emulation bug.

dlfrsilver 30 July 2008 16:07

Ok, but what is the track length defined in the routine ?
How much does it try to write ?

Toni Wilen 30 July 2008 16:16

Fixed. It was really simple and stupid bug but no other save routine ever did it this way..

Nothing was written to adf if write DMA was aborted before it ended :)

dlfrsilver 30 July 2008 16:27

then how i have been able to create correctly the save disk then ?

I should have been blocked like the guy no ?

Toni Wilen 30 July 2008 16:30

Quote:

Originally Posted by dlfrsilver (Post 438971)
then how i have been able to create correctly the save disk then ?

I should have been blocked like the guy no ?

Because your overly long track allowed DMA to finish before next indexsync..

dlfrsilver 30 July 2008 16:38

Ok thank you for your reply. However i will test with my cadaver v0.01 version on my real amiga :)

Toni Wilen 30 July 2008 16:43

It will work. Problem has nothing to do with write length.

Interceptor 30 July 2008 17:04

thanks for sorting that out :)

dlfrsilver 30 July 2008 17:33

yes one more problem solved :D !

Toni Wilen 30 July 2008 17:36

At least SSP cracked version uses same save format. I'd have expected save problem reports years ago..

dlfrsilver 30 July 2008 18:48

well i never heard about people having problems back in the day......
No one has posted here since that guy from Interceptor, and it's not even on
a real amiga but on emulator :| ?

Toni Wilen 30 July 2008 18:55

Ok, it seems there is still some confusion about this problem.

It is simple and stupid emulator bug: disk write DMA abort -> NOTHING is written to adf file. (data is totally lost) and this game aborts the DMA when enough data has been already written. (which is weird way to do but it does work)

It has NOTHING TO DO with disk rotation rate.

dlfrsilver 30 July 2008 19:22

thanks for this explanation :D !

zeGouky 24 May 2019 10:47

Hello,

sorry to revive this thread but it seems that the saving problem under winuae is still there and i was wondering if any one managed to get it working? I've dumped my own original disk and when i try to save Winuae says

---------------------------
WinUAE message
---------------------------
The software uses a non-standard floppy disk format. You may need to use a custom floppy disk image file instead of a standard one. This message will not appear again.
---------------------------
OK
---------------------------

So i've tried with a custom disk and while the message doesn't appear the save is corrupted when i try to load it.

The "fun" thing is that saving is also not working under fpga recreation (mister/fpgaarcade) so I was wondering if the problem could be related.

Any help would be great.

Thanks!

DamienD 24 May 2019 10:57

I just tested here and had the same issue.

...probably easier to use "Save States" for now ;)

zeGouky 24 May 2019 11:02

Sure but since Toni mention that he found a bug on the DMA abort , was it supposed to fix the issue on Cadaver? (and dfrsilver was able to get the save working with a custom disk)

Also if the bug is shared with fpga recreation that make it quite interesting

Mclane 24 May 2019 12:45

Its probably an accidental regression...There's quite a lot of code to organise :)

Toni Wilen 24 May 2019 18:20

It is writing related, this time writing is not stopped at index for some reason. (When did it stop working?)

This game saves quite strangely, first it waits for index, starts writing, stops writing at next index. If writing is not stopped, it overwrites part of previously written data. (Instead of doing it sanely..)

Zarnal 24 May 2019 20:05

Hello,

It's very curious.

If you use a blank extended adf HD in a DD 880k floppy, savegames works.

Why ? I don't understand.

Toni Wilen 24 May 2019 20:12

Track has more space (2x more) = partial overwrite (due to track "wrap around") won't happen. (Due to historic reasons HD in DD drive works that way, it can't happen in real world)


All times are GMT +2. The time now is 08:12.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04946 seconds with 11 queries