English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   WinUAE 4.9.0 beta series (Was 4.5.0) (http://eab.abime.net/showthread.php?t=104099)

Zarnal 16 May 2021 21:10

New issue with " Ephidrena-Psyltefrek " and only in FPU host mode (pic 1 )
It's ok with Softfloat mode ( pic 2 ).

The object is not displayed correctly and at the wrong time.

( type 2 in cli after boot ).

Toni Wilen 16 May 2021 22:08

Quote:

Originally Posted by Zarnal (Post 1484174)
These demos still have a problem with b20 :
UpToFront- CoolFridge :

Smooth Copper: This is fixed last (or not fixed until much much later, this does not really work in 4.4 or older, it simply has demo specific hack. Correct fix is really difficult.)

Quote:

scrolltext has a problem at the same time (pic 1). Since b12
Neither image is correct :)

EDIT: uses blitter line mode with all channels enabled!. It was supposed to be correct but some detail must be wrong.


Quote:

Originally Posted by Zarnal (Post 1484184)
New issue with " Ephidrena-Psyltefrek " and only in FPU host mode (pic 1 )
It's ok with Softfloat mode ( pic 2 ).

Native FSINCOS was sin and cos was swapped :)

ross 16 May 2021 23:05

Quote:

Originally Posted by Toni Wilen (Post 1484203)
EDIT: uses blitter line mode with all channels enabled!. It was supposed to be correct but some detail must be wrong.

WAIT, does this really mean what I think? :shocked
BLTBPT is used to fetch the pattern(s) and the DAT is 'spread' in memory to meet modulo needs?

msayed1977 17 May 2021 00:25

Great work, Toni.
When do you intend to make performance improvements?

amilo3438 17 May 2021 14:33

Blerkenwiegel by Scoopex --> https://www.pouet.net/prod.php?which=57097

Behaves different than is shown on pouet picture! (from WinUAE4900 Beta18)

amilo3438 17 May 2021 16:28

Quote:

Originally Posted by Zarnal (Post 1484174)
These demos still have a problem with b20 :

UpToFront- CoolFridge :

" Flexible-Zoom " : The effect is not correct (pic 2). Pic 3 shows how this effect should display normally.

Thanks. :)

Here is how it works on a real "Amiga 500 rev5 PAL OCS Agnus 512K KS1.2": (@23:00)
https://youtu.be/BhVsVjNIqSU?t=1367

So yeah, neither image is correct! :) (I am not sure if this ever worked correctly on any of previous WinUAE versions?)

Toni Wilen 17 May 2021 20:11

Quote:

Originally Posted by msayed1977 (Post 1484232)
Great work, Toni.
When do you intend to make performance improvements?

Is there some performance problems? So far no one has said anything.

Quote:

Originally Posted by ross (Post 1484212)
WAIT, does this really mean what I think? :shocked
BLTBPT is used to fetch the pattern(s) and the DAT is 'spread' in memory to meet modulo needs?

Fixed. (B DMA load didn't update line draw pattern variable). Currently cycle-exact only.

Probably the only program that does this?

Yes, B channel is used to load pattern. Quite a waste of DMA time because single drawn line pixel equals 2 B DMA reads from same address. (=total 32 times more than required)

Did original designers plan to have B as pattern channel but it was too late/would have been too complex? It looks like it is almost there..

(Yes, this is the first time it works correctly)

ross 17 May 2021 20:23

Quote:

Originally Posted by Toni Wilen (Post 1484446)
Probably the only program that does this?
--
Did original designers plan to have B as pattern channel but it was too late/would have been too complex? It looks like it is almost there..

Never seen before, this should go straight to undocumented features thread :)

If implemented properly it would have been very interesting!
Unfortunately this way it is very slow (and ..strange)..

Zarnal 17 May 2021 21:11

Quote:

Originally Posted by amilo3438 (Post 1484349)
Blerkenwiegel by Scoopex --> https://www.pouet.net/prod.php?which=57097

Behaves different than is shown on pouet picture! (from WinUAE4900 Beta18)


Exact.


Autobootable DK. :)

Toni Wilen 17 May 2021 21:54

Quote:

Originally Posted by amilo3438 (Post 1484349)
Blerkenwiegel by Scoopex --> https://www.pouet.net/prod.php?which=57097

Behaves different than is shown on pouet picture! (from WinUAE4900 Beta18)

Fixed.

msayed1977 18 May 2021 02:09

@Toni Wilen
You've mentioned before that you'll improve performance later. I am waiting for a better performance in your next betas.

Greyspirit 18 May 2021 16:58

Tried latest beta while troubleshooting this (hence why here) but I noticed that newer NPcap v1.10 doesn't work for A2065 emulation. doesn't seem to see it at all. Win10PCap, that I was using previously, did work fine. Had to replace it to do some wireshark stuff from host and found this not working.

Using it to host my BBS with full Genesis TCP stack.

Toni Wilen 18 May 2021 19:04

Batman Vuelve Slideshow II fixed.

Quote:

Originally Posted by msayed1977 (Post 1484528)
@Toni Wilen
You've mentioned before that you'll improve performance later. I am waiting for a better performance in your next betas.

Some optimizations were already added and some will be added later. No schedule.

Quote:

Originally Posted by Greyspirit (Post 1484646)
Tried latest beta while troubleshooting this (hence why here) but I noticed that newer NPcap v1.10 doesn't work for A2065 emulation. doesn't seem to see it at all. Win10PCap, that I was using previously, did work fine. Had to replace it to do some wireshark stuff from host and found this not working.

Using it to host my BBS with full Genesis TCP stack.

Standard reply: does it happen with 4.4 (last official version)? It it does, this is wrong thread. There is no network related changes in this beta (at least shouldn't be)

Zarnal 21 May 2021 16:38

Another strange case : Turnips-WorkForNothing

Note : This demo must be launched with " Rom Disabled " in " Advanced UAE expansion board " otherwise she's not starts. 1Mo chip required. Tested with OCS, ECS Agnus and ECS.

Some glitchs during this demo ( pic 1 ) but i have a doubt for pic 2. :)

Toni Wilen 21 May 2021 16:51

Quote:

Originally Posted by Zarnal (Post 1485669)
Note : This demo must be launched with " Rom Disabled " in " Advanced UAE expansion board " otherwise she's not starts.

If you need to do that: you don't have proper unexpended A500 config configured.

EDIT: and same happens with 4.4..

EDIT2: and same also happens on real A500. Both images. Never assume anything!

ross 21 May 2021 19:26

Quote:

Originally Posted by Zarnal (Post 1485669)
Another strange case : Turnips-WorkForNothing
...

It's the demo that's broken.
There is a working version available, into the Zone!

falken 21 May 2021 20:33

Has something changed in the handling of HDF discs? The same file works in Beta 17 and it does not in Beta 20. It is exactly the same!

Toni Wilen 21 May 2021 22:25

Quote:

Originally Posted by falken (Post 1485772)
Has something changed in the handling of HDF discs? The same file works in Beta 17 and it does not in Beta 20. It is exactly the same!

No? Can't really say anything else without more information. (You sure it wasn't open in other winuae and/or some other program. HDF won't open if it can't be opened in exclusive access mode)

falken 21 May 2021 22:45

Quote:

Originally Posted by Toni Wilen (Post 1485800)
No? Can't really say anything else without more information. (You sure it wasn't open in other winuae and/or some other program. HDF won't open if it can't be opened in exclusive access mode)

I have made a video that illustrates the problem. If you need any additional information, I can get it for you...

https://youtu.be/mv3-siLr4lU

Toni Wilen 21 May 2021 22:47

I always ignore videos. They are useless. Hard facts only: logs and config. (EDIT: tick logging misc panel option, make sure to also include winuaelog.txt. Or tick paths panel full logging option, load config, boot until nothing happens, click "Save all" and attach the zip)


All times are GMT +2. The time now is 22:43.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.

Page generated in 0.11133 seconds with 11 queries