English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Amix (http://eab.abime.net/forumdisplay.php?f=125)
-   -   OpenLook under X11R5 (http://eab.abime.net/showthread.php?t=103614)

KKR75 18 August 2020 13:56

OpenLook under X11R5
 
Hello gents,

I've been having a very hard time trying to get OL to work under X11R5.
Let me explain :

I am emulating in WinUAE, got Amix installed perfectly fine and patched as per the various guides on amigaunix and the likes.
X windows starts up fine in black and white both using olinit and xinit.

But I want to use the emulated Picasso 2+ to get a better looking X.

So again I followed the guides nicely and was able to get X11R5 setup, and it starts up perfectly fine using xinit (and twm as the standard window manager).

Where I am having a hard time, however, is to get openlook to work. In all the guides I have seen, basically you wipe out the /usr/X directory, which effectively wipes out OpenLook.

I tried to reinstall OpenLook from the amixpkg, and run it via xinit (after having added the xset fp+ line and also the olwsm line) and it did partially start. But it complained about missing libraries (Xol.xo and Xt.so), which I tried to create symbolic links for in /usr/lib.

But then, it gave me an error about an undefined XqTBoolean object.

So how did you all get to reinstall OpenLook after having installed X11R5 ?

Thanks

Toni Wilen 18 August 2020 21:13

I don't know any answers to your problem but what if you try using A2410 graphics board? Amix supports it natively.

KKR75 19 August 2020 20:43

Quote:

Originally Posted by Toni Wilen (Post 1421786)
I don't know any answers to your problem but what if you try using A2410 graphics board? Amix supports it natively.

As soon as I try to use the 2410 as RTG using the default WinUAE settings, the virtual machine comes to a crawl. One easy way to test this is say you insert a floppy (for example the amix boot) and try to boot, while having the floppy sound on so you can hear the floppy run. When there is no 2410 configured in the RTG section, the floppy makes normal sound and the system is fast. When I select the 2410, the system crawls and the floppy sounds gets staggered and jagged. If I select any other RTG card, it's fine.

Toni Wilen 20 August 2020 17:04

A2410 requires more CPU power because it has quite complex graphics chip that includes custom CPU.

But first check if it happens with more simple config (no MMU). And no vsync, it most likely won't work with that weird gfx board.

Also make sure CPU "more compatible" is not ticked (for some reason it is mentioned in guide), it will increase host CPU requirements noticeably and only makes Amix slower.

vintageBytes 14 September 2020 15:21

Amix doesn't work without an MMU.

I can check on my A3000T machine if OL is still running, but I think (believe?), that olinit starts the OL while startx (or xinit, don't remember) will start the basic X-Server with a terminal window only

Toni Wilen 14 September 2020 20:45

OP said whole system crawls (even before Amix enables MMU) so first step is narrow down if it is MMU emulation related or A2410 related or host CPU simply not being fast enough (both MMU and A2410 emulation can be quite heavy).

KKR75 15 September 2020 16:23

Sorry for the very delayed response, I was on a late vacation.

I have MMU set to MMU (not EC), CPU of course is 68030, and FPU to 68882, FPU More compatible is not checked (doesn't make a difference either way), and Unimplemented FPU Emu is checked.

I have tried on both my SurfaceBook2 and SurfacePro machines, with similar results (Intel i7 2.1GHz 16GB RAM).

I use now the Picasso II+ RTG card and it's fine. But I really wanted to try and emulate the default setup with A2410 (and possibly with the emulaged A2024 monitor too, once A2410 works good). Basically trying to replicate as best I can the authentic original A300UX full graphics experience without having to upgrade to X11R5.


All times are GMT +2. The time now is 15:48.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.05593 seconds with 12 queries