English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Amix (http://eab.abime.net/forumdisplay.php?f=125)
-   -   Amix in WinUAE (http://eab.abime.net/showthread.php?t=67210)

r4ge 25 January 2013 11:26

You have to set the drive to scsi6

kokoboi 25 January 2013 13:28

I've set it to scsi6, but still boots directly into ksrom

neozeed 25 January 2013 13:47

Do you have the right Amiga 3000 KS rom? If you hold down both mouse buttons can you boot into workbench 2?

kokoboi 25 January 2013 14:04

I'm using this rom: KS ROM v2.04 (A500+) rev 37.175
but I'm not sure if this is the correct rom I should use.
Holding both mouse buttons doesn't do anything .

mark_k 25 January 2013 14:28

That isn't the correct ROM. The ROM you're using is for the A500/A2000, not A3000. There's no SCSI driver in it, so you wouldn't be able to boot any OS from an emulated SCSI HD. If you obtain an A3000 Kickstart ROM image and use that instead, you should have better luck.

r4ge 25 January 2013 14:30

I used the a3000 rom, i've managed to install amix 2.1, to tired to do more tonight. I'll put up a decent post tomorrow with some details

mark_k 25 January 2013 14:32

That would be cool, and if you could upload the installed AMIX 2.1 HDF somewhere even better, to save lots of hassle and hair-pulling if I try to get it installed myself!

r4ge 25 January 2013 14:51

yup, no probs, i'll also put up the boot and root .adf's. some people might want to run the install them selfs. once you have all the right files its pretty straight forward.

neozeed 25 January 2013 16:12


Originally Posted by r4ge (Post 863921)
yup, no probs, i'll also put up the boot and root .adf's. some people might want to run the install them selfs. once you have all the right files its pretty straight forward.

Does this install support more than 2 users? it was a bit of a bummer when trying to show it off..

r4ge 25 January 2013 23:05

2 Attachment(s)
I would assume it supports multiple users. its UNIX!

ok, So i have attached the boot and root .adf files.

Boot the system with these, with the amix 21 cpio file as the second drive. I set this as SCSI 1, you will also need to add a target drive. I made mine 2GB. I enabled RDB to sort out the drive geometry. this stopped a lot of the crashes.

Once you boot the boot image it will ask for root disk, just f12 and add the root disk to the system then follow the prompts, i've only tried the install using the s5 file system. it takes along time to unpack the cpio image. so go make a coffee or 2 ;)

side note, there seem to be a lot of nice extras in the 2.1 image.. BASH!@#!@

also, these are not my images. Please give all your thanks to failure at amigaunix.com. it looks like he has put heaps of effort into making AMIX something that is really great.

Attachment 34019

Attachment 34020

Just a little update

I have managed to get a system up to AMIX 2.1p2a, this is the latest version. However Ethernet stopped working and I couldn't figure out why. I would kill for dmesg!

So I am starting again to see where ethernet support died. There is some kernel patches so maybe one is to blame? I'm not sure.

So I think the .hdf might be a little way off yet. I really want to have X and networking working.

caratacas 29 January 2013 05:42

Great Work Toni,

I didn't have a 2.04 rom so I've used the 3.1 A3000 rom that came with Amiga Forever and it works great. Have followed the above guide by r4ge to install. Great, Thanks.

mark_k 29 January 2013 15:52


Originally Posted by r4ge (Post 863830)
Hi guys, using the amix.uae config i have managed to boot into amix 1.1, from there i have used the boot and root img files from here http://amigaunix.com/tiki-list_file_...hp?galleryId=1, and dd'd them into adf files. I can upload them if anyone is interested. After booting these images i have been able to mount the amix 2.1 cpio into winuae and and start the install process. Its not quite done yet but its looking promissing.

Btw, to create the .adf images. I loaded amix 1.1, added a network interface and bound it to my ethernet adapter. This requires winpcap. once this is done I booted into amix and set up the interface, ie ifconfig en0 netmask, from there i ftp'd into my server and downloaded the boot.img and root_v2.img. I bunzip'd them first to save some time. then these images can be dd's to your virtual fdd, ie dd if=boot.img of=/dev/rdsk/fd0 this will take a few minutes. once boot is done you can swap out your virtual fdd (press f12) then load your root disk. this is done in the same manner, ie dd if=root_v2.img of=/dev/rdsk/fd0 again this will take a few minutes.

That seems a rather round-about method; the floppy images on the amigaunix site are ADFs, so all you needed to do was unpack them! :D

Your boot.adf is identical to the amigaunix boot.img. :) Your root.adf is slightly different from the amigaunix root_v2.img however. That's probably because you used the write-enabled disk before creating your image file of it. (The Amiga UNIX 1.1 install process requires the root floppy be write-enabled.)

BTW, the reason neozeed asked about supporting more than two users is that Amiga UNIX was released in two versions. One only supports two users, the other unlimited users. I don't know about the AMIX cpio archive, but at least the AMIX 2.1 boot floppy on amigaunix.com (not the modified HD-hack installation disk) says "(Limited)" on the initial screen.

r4ge 30 January 2013 09:31

Ohh, ok. I didn't realize the img files where the same. I am actually not that familiar with winuae and amiga emulation! ;) I think i unpacked the img files, tried it quickly and just decided there must be something different, so i went with the dd method. However, it worked. failure has given me access to his site. So I am going to post some some information and any other interesting files, patches etc that i come across.

I had noticed that ethernet emulation had stopped working after i install version 2.1. I am not sure if i have misconfigured winuae or there is a kernel patch that has broken support. At this stage I am not familiar enough with AMIX or winuae to trouble shoot that.

However once I get back from holiday I might be able to spend some more time on it and get something working.

BTW, last time I used an amiga was sometime in the early 90's and that was mostly to play the awesome games! :)

salax54 03 February 2013 10:56

First off, a big thanks to Toni for the MMU efforts! :great
How'd anyone manage to use the X environment folks?
I can boot 2.1, login as root user, and if i do /usr/X/adm/ oladduser root i get a report saying "/usr/X/adm/: cannot execute.
The command is in the proper path btw...

Ok, figured it out: to start Open Look i had to type olinit. There's a b&w X desktop now.. :-)

mark_k 03 February 2013 13:28

Check out the AMIX manuals available at amigaunix.com. While a couple are missing, the ones that are there should cover selecting a display mode and starting X. I followed the instructions to get X running in A2024 mode in the screenshot I attached above.

mingle 20 May 2013 09:18

Hi Guys,

The thought of getting Amix running under WinUAE intrigues me, so this thread is very interesting...

However, since I'm an utter turnip-head, I'm falling at the first hurdle.

I have downloaded the "amix.img" 1.1 hard disk image file from over at Amigaunix.com, and added this
as a disk image within WinUAE (using the amix.uae config file), however, when I try to boot, I just the the KS screen.

I've also tried booting from the UNIX boot/root ADF files, which work, but then ask me if I want to install UNIX,
but all I want is to boot from the amix.img hard disk...

So any help or suggestions would be great.

A fully configured Amix 2.1 HDf file would be VERY nice! :-)



thomas 20 May 2013 10:43

In Add Harddrive window select SCSI controller, not UAE.

mingle 20 May 2013 16:50

Okay, I have it using the amix.img file, set as SCSI6 device, now I just get a blank screen and the CPU at around 80%.

The HD activity indicator on the lower-right of the WinUAE window isn't showing any disk activity either.

I've tried A3000 versions of KS ROMs v2.0, v2.04 and two versions of v3.1, with no luck... Hmm...


Toni Wilen 20 May 2013 18:04

winuaelog.txt needed as usual.

Also make sure your A3000 ROM is detected by WinUAE ROM scanner (appears in ROM panel select box). 99% of "A3000" ROMs floating around are A3000 SuperKickstart rom image rips that may not fully work stand alone.

mingle 21 May 2013 01:51

1 Attachment(s)
Hi Toni,

Here's the log file. The ROM image(s) I'm trying are from the 'usual' Tosec 0.04 torrent.



All times are GMT +2. The time now is 20:12.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.08256 seconds with 11 queries