English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Amix (http://eab.abime.net/forumdisplay.php?f=125)
-   -   Amix in WinUAE (http://eab.abime.net/showthread.php?t=67210)

vintageBytes 24 March 2014 12:31

Thanks, Noth, I'm not unhappy with the RTG card change, the Picasso has a better display quality :)
I've already tweaked the X server a little bit to match the screenshots on the AMIX flyer.

I agree that wget is better, but it's not included. I use the AMIX-ftp command with my NAS without problems, but it's a TCP connection. CD, download and even upload is working there.

So, the first program we should include is wget :D
Wget should also be able to download from a normal webressource without the need of a FTP server.

Toni Wilen 24 March 2014 13:00


Originally Posted by Noth (Post 945676)
The AMIX ftp client doesn't know how to do passive mode so it won't work in slirp... It'll connect and login, change dir, but can't list or download.

Configure your ftp server to only use tiny active port range (for example 20000 to 20010) and add them all to slirp configuration :)

Amiga_CDTV 08 April 2014 19:11

I have now bought a Picasso II ! I'll be installing it later this week (might include mechanical difficulties due to my custom A3000T case).

Unfortunately it seems that my 3000T's HDD is failing, Amix reports several disk errors and it seems to be getting worse. The WB still boots without any problems, though.

Another thing: should we create another thread for the general Amix discussion? Most of this (at least my posts :)) is getting outside the original topic and WinUAE.

Noth 09 April 2014 22:33

I second that, we may as well have a thread in another section since we're talking all aspects, not just what's emulator related.

Congrats on the Picasso II card, I hope it fits without too much effort. Sounds like you need to move to CF cards if you can find a scsi2cf adapter.

Amiga_CDTV 19 April 2014 22:53

I managed to fit the Picasso II in, but now the old hard disk has died completely. I started a new install to a newer SCSI disk from WinUAE.

It seems that I just killed my new Workbench partition though (file copying halted, I restarted and now it won't validate). Can I use any newer file system for the Workbench partition without compromising the Amix partitions? (Tried once, and had to re-install both OSs).

Amiga_CDTV 22 April 2014 09:47

2 Attachment(s)
Well, now I have a new hard disk and I managed to get a new set of Workbench 3.1 (with BetterWB) and Amix into the disk from WinUAE. During the holidays I installed WB at least three times and Amix twice (due to mis-haps with disk partitions) but now I have a working system again. The Picasso II is also working now in both OSs (it fits into the case, just about!).

I especially like the xearth utility which creates an image of the earth as background in X, looks very nice.

vintageBytes 25 April 2014 10:24

Looks nice!
I'm currently testing bash 3.0 on Amix. Work very well under X. I will prepare an installation script and installation instructions, when I've tested it completely.

For now, the tab completion and history functions are working. I've also managed to get the current directory printed to the command line.

A new thread for Amix would be good. Where should we start it?

Amiga_CDTV 25 April 2014 18:46

The system is working otherwise nicely but when I exit X, I get errors of stuff it couldn't stop properly (don't have a shot of the actuall errors at hand just now). I wonder why that happened as it used to stop without complains.

Tab completion and history - that would be great!

As we naturally expect high level of public interest in Amix we should have a very own support.Amix sub-forum in here (no, not really :)) Support.other would fit but sounds a bit too general. Project.Amix?

vintageBytes 12 May 2014 22:04

Yeah, that would be great! A project.amix part, where we could collect all that informations. This topic is now a little bit off-topic :-)

Amiga_CDTV 14 June 2014 20:37

1 Attachment(s)
Where could we ask for our own project.amix (or other) sub-forum?

Where is the default configuration file of TWM in Amix? I have none in my home folder, there is system.twmrc in /usr/lib/X11/twm. I am trying to add a close button to the window's titlebar (as per here). I put that in the system.twmrc but it didn't have any effect (might be that the xlogo11 isn't there).

And.. WHY ON EARTH there is a scanned picture of a finnish 1000 mk banknote in /usr/lib/X11/images -directory?! I can understand the mandrill.jpg (seems to be somewhat classical colour image -example), but why a finnish banknote? :shocked

Minuous 15 June 2014 00:53

Is AMIX available preinstalled as a HDF somewhere? I assume it was at www.amigaunix.com but that site is now down.

Amiga_CDTV 15 June 2014 19:00

@Minuous: see here: http://www.vintagebytes.de/amix/index.html and earlier in this thread.

And I also found an answer to my question from earlier this thread: system.twmrc is in /usr/X11R5/lib/X11/twm. I put "RightTitleButton "xlogo11" = f.delete" in there and it works: windows now have a close-button.

prowler 15 June 2014 23:32


Originally Posted by Amiga_CDTV (Post 959777)
Where could we ask for our own project.amix (or other) sub-forum?

Please post your request in the project.EAB forum.

Amiga_CDTV 24 June 2014 12:16

On Amibay, somebody just sold some Amix install floppies, and an original "NKR Basic v5.2 for Amiga Unix". Any ideas what that might be (other than "a basic compiler, perhaps?" :p)

Amiga_CDTV 28 July 2014 11:58


Originally Posted by Amiga_CDTV (Post 961060)
On Amibay, somebody just sold some Amix install floppies, and an original "NKR Basic v5.2 for Amiga Unix"

The buyer on the linked thread is asking how to dump the floppy with a Catweasel, perhaps somebody here could help him?

I have just bought an Ariadne I -ethernet board for my Amix machine. Haven't tested it yet. I read that the driver for it is in the Gateway! Unix CD 2, but unfortunately I can't get the archive from amigaunix.com as the files are corrupted after the site crashed some time ago. I can download the file (from http://amix.failsure.net/tiki-list_f...hp?galleryId=5) but I can't get it decompressed. Anyone with a working copy of the archive?

Has anyone tried the drivers? How is it installed, what am I supposed to get working and what can I do with it in the best case?

@vintageBytes: any luck with the Bash 3.0 package? :)

mark_k 28 July 2014 12:39

I have uploaded an uncorrupted version of the AMIX.tar.bz2 file that I downloaded from amigaunix.com in 2013 to The Zone. (I also have all other files which were available on the site at that date...)

I also have an actual Gateway! 2 CD-ROM; is an ISO image not already available online somewhere? If not I could upload it.

Amiga_CDTV 28 July 2014 18:31

@mark_k: that was fast, thanks! If you have a complete copy of the website, that should be highly appreciated by the amigaunix.com admin, he is asking for the files (see note on frontpage). Would be nice to have the site back up.

Readme for the Ariadne driver looks pretty straight-forward. I hope I'll have a chance to plug things in and test this later this week or the next.

I came across an article called "Using the Amiga A3000UX as a NFS File Server", might be of interest for some people here.

Does that Gateway cd have any more Amix related stuff (other than the drivers)?

mark_k 28 July 2014 21:53

I have uploaded an archive of all the old amigaunix.com downloads and emailed the amigaunix.com admin about it. For anyone who's desperate to have the files now... hxxtp://www.m!e!d!i!a!f!i!r!e.com/do....com_files.tar (~500MB tar archive).

I don't know whether there are any other AMIX-related files on the Gateway! Vol. 2 CD, but I have uploaded the XZ-compressed ISO image (~421MB) in case you want to take a look: hxxp://www.m!e!d!i!a!f!i!r!e.com/dow...2_96043.iso.xz

Copy and paste the URLs, change hxxp to http and remove ! characters. (I have to obfuscate the URLs otherwise they are blocked by the EAB forum software.)

Amiga_CDTV 28 July 2014 21:59

Thanks, but the URLs seem to be missing something?

GraveR 28 July 2014 22:13


Originally Posted by Amiga_CDTV (Post 966309)
Thanks, but the URLs seem to be missing something?

Probably media[]fire (one word, without [])

All times are GMT +2. The time now is 20:31.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.06208 seconds with 11 queries