English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   ClassicWB (any OS3.X) and 3.1.4 (http://eab.abime.net/showthread.php?t=94493)

EzdineG 24 March 2019 17:41

Quote:

Originally Posted by samplist (Post 1312889)
It does contain many of the features of bestwb, some of them being replaced by others (e.g Voodoo-X for unarchiver etc). The are things missing such as some of the commodities I couldn't find icons for, TotalCalc etc. I wouldn't recommend installing bestwb over BestClassicWB as you would have many things installed twice in different locations.
You can try it and tell me if you feel something is missing.



Tried it, and everything is working as it should.

Thank you for putting this together!

Viceroy 24 March 2019 21:15

Installed no problems, love it! Great work thanks ;-)

steveh 01 April 2019 16:55

What a refreshing thread.

Was wondering when I finally get round to buying the 3.1.4 roms + os disks, will it still work with my blizzard 1230IV 256mb ram indivision aga mk2cr and fast ata mk4 basically that question is sorta aimed at any of you guys with similar hardware that may have already done the os + rom update.

JV-Soft 02 April 2019 16:56

Quote:

Originally Posted by KKR75 (Post 1298568)
New updated release for 68K version 3.1. Link below changelog.

CHANGELOG:

Code:

v3.1
        - Updated full WHDLoad package to latest beta prerelease v18.4, across ALL WB versions. The reason I opted for the latest beta is because v18.3 introduced a few bugs with certain games that was remedied in v18.4
        - Removed C:TagLiFE#?, C:PatchRAM#?, SYS:Update/ dir as no longer needed for v3.1.4
        - Removed LargeHD directory from MyFiles, also not needed with new ROM 3.1.4.
        - Removed references to TagLiFE, PatchRAM, BlazeWCP, and StackAttack in the ButtonMenu menus, only when under 3.1.4.
        - Cleaned up lots of stale .info files when using the WB1.3 theme under v3.1.4.

ClassicWB 68K 3.1.4 (Version 3.1)

Regards,

KKR75

Hi , sorry for my english, i use a translator.
I put it on a real A500 (ide, 1mb chip, 8mb fast), when I run some games and demos (WHDLOAD) and when I exit, I get this error.
Checked in UAE, also gives an error.

https://a.radikal.ru/a29/1904/98/2e5df0b703d5t.jpg

When i use kickstart 3.1.4 and classic wb (http://classicwb.abime.net/classicweb/68k.htm) , then no errors

JV-Soft 03 April 2019 00:37

I solved the problem by updating the WHDLOAD to version 18.5

BYTEMAN 04 April 2019 10:42

Are there any plans to release ClassicWB ADVSP and "OS39" andpted to 3.1.4?

Thanks,
Alexander

gms0012 09 April 2019 17:07

I installed it today on my A500 with Aca500+, 1233n 40,..... nice work and I do love the old 1.3 theme... :)

thanks for the work

Amicol 17 April 2019 01:15

Any chance of a Classic WB Lite 3.1.4?

I don't like Classic WB Full as Scalos kills icon.library

Rochabian 03 May 2019 10:46

1 Attachment(s)
iGame doesn't work in BestClassicWB (installed just after a fresh 3.1.4)

Perhaps a library problem ?

A suggestion : Can you include AHI as in ClassicWB ? I've got problem with Hippoplayer when changing the AHI mode within and save settings -> reboot (tried with ahi 4 & 6 )

Otherwise it works great, thanks for this !

demon-knight 03 May 2019 19:50

Quote:

Originally Posted by Rochabian (Post 1319292)
iGame doesn't work in BestClassicWB (installed just after a fresh 3.1.4)

Perhaps a library problem ?

A suggestion : Can you include AHI as in ClassicWB ? I've got problem with Hippoplayer when changing the AHI mode within and save settings -> reboot (tried with ahi 4 & 6 )

Otherwise it works great, thanks for this !

I had the same problem, to fix I downloaded the files guigfx_render_nofpu.lha from this page http://winterland.no-ip.org/igame/files.html and put them in the libs folder, works great after that.

Rochabian 03 May 2019 22:18

Excellent !

Many thanks demon-knight, it works.

jdryyz 19 May 2019 20:15

So I'm not a big fan of MagicMenu. I simply removed it from my WBStartup folder. The problem with that is my ToolsDaemon menu items no longer respond. If I right-click and select an item, no action is taken. I thought my ToolsDaemon.menu in S: might be messed up in some way so I grabbed another copy but that did not help.

This is a strange one. Not sure how the absence of MagicMenu affects ToolsDaemon. I have a similar ClassicWB FULL setup on an A1200 and disabling MagicMenu works fine. Granted, that is a pure OS 3.1 ClassicWB, not the 3.1.4 modified version.

digiflip 04 June 2019 22:21

wow will test 68k on my a500 plus with 68010 and 2mb chip, eventually an aca500 plus just ordered today

quantum8 06 June 2019 07:57

Hoping to use this on my 1200 as soon as my ROMs arrive.
Works great in fs-uae at least! :great

quantum8 07 June 2019 14:04

Ok so I've installed it and it worked great until I installed scalos on top.
Now I have an unusable desktop....I've got no menus (either popup or in the menu bar) and I cannot click on any of the icons to be able to launch scalos prefs.

Any ideas?

quantum8 10 June 2019 05:58

Looks like one of the items in WBStartup was causing this, so I have it working now.

rmzalbar 26 June 2019 22:55

Quote:

Originally Posted by digiflip (Post 1297567)
for this card https://sordan.ie/product/583/turbo-...ide-amiga-500/

i found changing jumper to octapussy ide driver for ks 1.3 resolved my issues with not seeing cf card and 2nd partition in pfs aio when running clasic wb 68k 3.1.4


Would you say this is an incompatibility between octa and KS 3.1.4?

cyberhead97 02 July 2019 09:47

As part of updating HstWB Installer, I have started to patching ClassicWB to support Amiga OS 3.1.4.

I have read this thread and applied some of the tweaks mentioned here like disabling patchram, taglife, blazewcp, fblit and scalos title 3.1.4 instead of ?.?. Then I have added version checking of scsi.device, so it will only be loaded if scsi.device in memory/resident is less than v43.45.

Libraries and devices from ClassicWB that already exist in Amiga OS 3.1.4 are also excluded from installation.

For some odd reason I have to reinstall MUI v3.8 in order to get Scalos prefs and iGame working, so a few required libraries must be missing.

So far I seem to have a fully working ClassicWB FULL installed on top of a fresh Amiga OS 3.1.4. This should be fairly simple to apply to the other ClassicWB's for Amiga OS 3.1: 68K, LITE, ADV, ADVSP and P96.

haightc 26 July 2019 02:38

I haven't been able to succesfully install BestClassicWorkbench... I've tried installing WB 3.1.4 then BestWorkbench then updating both to the newest versions. I have also tried install workbench 3.1.4 then bestwb and going to BestWorkbench. The installer will apear to run successful but evertime I restart I get an error to insert a disk 'OS 3.1.4' and I click ignore I just get errors that can't find a copper file and a preferenes fiels, So I made a disk called OS 3.1.4 and put the BestWB files on there but I never actually get to the workbench. What am I missing?

JohnFante 30 July 2019 08:51

Quote:

Originally Posted by cyberhead97 (Post 1330218)
As part of updating HstWB Installer, I have started to patching ClassicWB to support Amiga OS 3.1.4.

I have read this thread and applied some of the tweaks mentioned here like disabling patchram, taglife, blazewcp, fblit and scalos title 3.1.4 instead of ?.?. Then I have added version checking of scsi.device, so it will only be loaded if scsi.device in memory/resident is less than v43.45.

Libraries and devices from ClassicWB that already exist in Amiga OS 3.1.4 are also excluded from installation.

For some odd reason I have to reinstall MUI v3.8 in order to get Scalos prefs and iGame working, so a few required libraries must be missing.

So far I seem to have a fully working ClassicWB FULL installed on top of a fresh Amiga OS 3.1.4. This should be fairly simple to apply to the other ClassicWB's for Amiga OS 3.1: 68K, LITE, ADV, ADVSP and P96.

Cool :)

Will you releasing an updated installer?


All times are GMT +2. The time now is 00:02.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.07367 seconds with 11 queries