English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Problem with pausing when mouse uncaptured (http://eab.abime.net/showthread.php?t=66907)

mark_k 06 December 2012 16:38

Problem with pausing when mouse uncaptured
 
I've noticed (what I think is) a problem with the "pause when mouse uncaptured" option. Testing the 2012-12-06 winuae.zip with Windows Vista.

Run WinUAE and start emulation. Open settings window, click Pri & Extensions. In the When Active section, under Mouse uncaptured: check the Pause emulation checkbox. Click OK to continue emulation. Press middle button to un-capture mouse. Emulation pauses as it should.

Now click the WinUAE button on the taskbar. The emulation window is activated and emulation unpauses, but the mouse is still uncaptured. I think the emulation should remain paused when the user clicks the taskbar, since the mouse remains uncaptured.

Edit: a small pause-related suggestion. When in borderless windowed mode, make the WinUAE system tray icon change when emulation is paused, so there is a visible indication of whether emulation is running.

Edit 2: emulation also resumes with mouse uncaptured if you uncapture the mouse, click a floppy track indicator in the status bar and cancel the file dialog.


All times are GMT +2. The time now is 16:46.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.06170 seconds with 11 queries