English Amiga Board Amiga Lore

Go Back   English Amiga Board > Main > Amiga scene

Thread Tools
Old 30 May 2003, 21:30   #1
Toni Wilen
WinUAE developer
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 41
Posts: 17,869
WinUAE 0822R7 released


Bugs fixed:

- printer didn't work if serial port emulation was enabled
- palette wasn't updated properly when entering and exiting the GUI in fullscreen 8-bit Picasso96 mode
- button or key mapped to mouse horizontal or vertical axis
- random crash when horizontal centering was enabled
- bsdsocket emulation, ping, traceroute, AmTelnet SSH connection freeze
- config save crash and non working keyboard
- ShapeShifter-support improved, all Kickstart 2.x/3.x versions supported
- lores-mode support for "sprites outside display window"-feature
- and more..

New features:

- emulation compatibility improvements
Elfmania, Rainbow Island (broke accidentally in R6),
Mission Elevator (properly fixed this time...), SWIV,
Old Timer, Inferior, Sub Rally, Sargon History, TBL demos,
Sound of Silents, Cardamom, Cardamon etc..
- analog joystick (paddle) ports emulated
- improved hard/ZIP disk RDB detection
- Action Replay 2/3 state file support
- sound "power led" filter emulation
- freely selectable sound sample rate (8000 - 48000)
- "direct" serial port support, fixes PC to PC Lotus 2 serial link
problems. (two player only, 3 or 4 players require lower serial
latency that is not possible under Windows)
- zipped CAPS-image support
- updated AHI driver included
Toni Wilen is online now  
AdSense AdSense  
Old 30 May 2003, 21:58   #2
Registered User
LordBug's Avatar
Join Date: Jul 2002
Location: Someplace
Posts: 88

Thanks Toni
LordBug is offline  
Old 30 May 2003, 22:34   #3
Junior Member
jmmijo's Avatar
Join Date: Jan 2002
Location: PDX
Age: 54
Posts: 2,351
That's a good comment there LordBug

And as per usual Toni is doing a fantastic job
jmmijo is offline  
Old 30 May 2003, 23:57   #4
Amiga Collector
wakeupbomb's Avatar
Join Date: Jan 2003
Location: Leeds, England
Age: 32
Posts: 191
Thumbs up

nothing like a new version of WinUAE to brighten my day

Cheers Toni
wakeupbomb is offline  
Old 31 May 2003, 04:37   #5
The Ancient One
Join Date: Feb 2002
Location: Kansas City/USA
Age: 61
Posts: 685
I've just downloaded the latest release and begun testing it, and it looks like another great piece of work. Thanks, Toni!

Unfortunately this release did not fix one problem that has been annoying me for quite some time though. I keep all the old versions of the emulator handy just in case, but I've found that the latest versions always seem to run everything I've tried at least as well as the older versions, except for ONE game, which works fine under 0.8.17 and earlier. I've asked about this a couple of times here before, but I've never seen any response to tell me if anyone else had the same problem or not.

The problem is garbled graphics on the intro screen for Batman the Caped Crusader.

I'm including a screen shot that illustrates the problem that I'm experiencing. The top part of the picture is a screenshot taken using 0.8.17, and the bottom part is a screenshot taken using 0.8.22. Is anyone else having the same problem? If so, does anybody have any idea what is causing it?
Attached Thumbnails
Click image for larger version

Name:	batman.jpg
Views:	453
Size:	49.1 KB
ID:	5158  
Chuckles is offline  
Old 31 May 2003, 09:58   #6
Toni Wilen
WinUAE developer
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 41
Posts: 17,869
Batman the Caped Crusader.
Known problem, workaround: enable immediate blitter.
This is another case when old version's wrong timing of blitter accidentally worked...
Toni Wilen is online now  
Old 31 May 2003, 12:18   #7
Registered User
AmiGer's Avatar
Join Date: Sep 2002
Location: Germany
Posts: 349
Thanks for the new version...
AmiGer is offline  
Old 31 May 2003, 17:51   #8
The Ancient One
Join Date: Feb 2002
Location: Kansas City/USA
Age: 61
Posts: 685
Thanks for the info, Toni! I thought I'd tried tweaking everything in the config already, but I obviously missed this one. Now I can put 0.8.17 away entirely.
Chuckles is offline  
Old 20 June 2003, 11:15   #9
lilalurl's Avatar
Join Date: Aug 2001
Location: France
Age: 37
Posts: 2,803
Send a message via ICQ to lilalurl
About the sound filter LED emulation

First I'm sorry I react so late but I was away for a while.

Well, very great feature there. Wonder where you got that neat idea...

However, I have two things to mention :

1) Not really pertinent but anyway it might help to solve what is for me a mystery : I think it would be better to have a third colour (like rose) for the OSD power LED, so that it can really emulates the thing. Don't know if this would be easy enough to do and worthy. But the real question beyond this is : why doesn't the power LED (OSD or even lower bar in windowed mode) remain all the time ? Under Workbench or the loading of games it's on but then it's off (and it happily flashes when WinUAE has the premonition the guru is about to meditate). Could this mean the sound filter is on during the loading of games and under Workbench and switches off when calls to the sound chip are made ?

2) More important : The power LED sound filter effect emulation worked for Dune (F3 key to activate/deactivate the sound filter. You have to press another key before pressing F3 again and having the filter state changed). But it didn't in Lotus II (Second level, under the tunnnels. PW for the level : Twilight). I can only see two reasons : a) Lotus II uses another sound filter. Seems a bit illogical. b) The game makes temporary calls to the filter and Winuae can't catch theses calls, thus the lack of emulation.

In fact, after a few tests I've just seen that using F3 in Dune already affected the power LED in WinUAE 0.8.22 Release 5 (haven't check older revisions), so I wonder wether I really got the idea of the sound "power led" filter emulation.

As a conclusion, I have no conclusion, I don't understand anything, the Amiga still remains a mysterious machine. All this stuff is minor compared to other features I reckon, but it's still one step towards perfect emulation.
lilalurl is offline  
Old 20 June 2003, 14:05   #10
Toni Wilen
WinUAE developer
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 41
Posts: 17,869
Amiga's sound filter isn't that complex...

"Power Led" CIA-io-pin is connected to both power led and audio filter -> Power LED on = audio filter enabled, power LED off = audio filter disabled. (except on A1000 filter is always enabled)
Toni Wilen is online now  
AdSense AdSense  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 2.5.0 released Toni Wilen News 30 08 December 2012 18:48
WinUAE 1.3.4 released Paul News 11 02 January 2007 04:09
WinUAE 1.3.2 Released Avanze News 10 05 September 2006 21:08
New WinUAE Help released Paul News 3 02 January 2005 21:56

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 10:27.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Page generated in 0.15790 seconds with 12 queries