English Amiga Board Amiga Lore


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 13 April 2017, 10:46   #21
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 35
Posts: 174
FWIW - your LHA worked perfectly on my A1200 (with 1260) without any mucking about. Just doubled clicked and off it went.
indigolemon is offline  
AdSense AdSense  
Old 13 April 2017, 11:07   #22
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,174
Quote:
Originally Posted by DamienD View Post
To be honest I'm getting quite bored of some people here implying that I'm stupid or something and don't believe a word I say and challenger everything I do

If it continues then I really won't bother doing anything more for this community, what's the point really??? I'll leave it to you "real" Amiga gurus shall I...
But that's the way the Amiga community works, didn't you know? All about the superiority. Maybe it's because it's the only aspect of their lives in which they can feel that way, who knows... Anyway, don't feel disheartened, there are no doubt plenty of seen and unseen users silently appreciating your efforts. I often feel that way too about this community, and so abandon whatever I'm working on and spend my spare time on something else. Eventually though it always calls me back, and I spend about a week trying to figure out what I was thinking when I left off
Daedalus is offline  
Old 13 April 2017, 11:34   #23
Neil79
Registered User
Neil79's Avatar
 
Join Date: Jul 2012
Location: Kent
Age: 38
Posts: 2,481
At the end of the day DamienD the request was for me And I'm really happy with it, furthermore many of the readers of Indie Retro News are happy with it too!
Neil79 is offline  
Old 13 April 2017, 11:35   #24
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,054
Ciao Damiano, I did not understand the discussion, you are an exquisite person in addition to being a true Amiga user.

I did not understand if you have solved the problems of installation on "Foundation" Now try to do an install on my AFA OS starting from CD.
AMIGASYSTEM is offline  
Old 13 April 2017, 11:41   #25
DrBong
HOL / AMR Team Member

DrBong's Avatar
 
Join Date: Dec 2001
Location: Australia
Posts: 2,195
Post

Quote:
Originally Posted by DamienD View Post
As I've already mentioned, if using / installing with the original CD-ROM (v1.12) you do still require the CD to be present after installation when playing the game...

I love HOL, but the notes are most definitely wrong and should be corrected!!! It's not as simple as detailed...
No, unfortunately you're most definitely wrong in this case. Did a quick HD install of my Foundation V1.0 CD (no patching whatsoever) on A1200/030/64Mb. Took my whole lunch break (30min.) to install everything except the intro and mugshots to zip disk off 4xCDROM (yuck!). Had to HD install to zip disk (double yuck!) as I didn't have enough free HD space.



As you can see from the photo above plus those at the bottom of my post, the HD install worked straight off with only 1MB chipram free and without the game CD being inserted (which you said was an absolute must!). There was, however, some gfx corruption on the main game screen (not too surprising, I guess, as Foundation was aimed at standard A1200 owners back in '98 and the patches largely focused on fixing AGA issues, some of which occurred on accelerated machines).

Didn't have any time to fiddle with patching, degrading etc. as I've got much bigger fish to fry atm on the work front with Easter almost upon us. Suffice to say that I got none of the errors/CD prompts you did under emulation and was able to quit a game and return to WB afterwards. All this using the very first V1.0 release (as opposed to your V1.12/V1.27) and HD installed to external zip disk straight outta the box (tested OK from ram: too BTW).

Sure, the HOL entry needs updating to alert people to problems (like mission 6 being impossible to complete without applying the update patch), but the basic HD installation instructions as documented in the original V1.0 release of Foundation are correct as confirmed by my quick 'n' dirty test.

Even if the info. had been incorrect, we would have wanted confirmation on real Amiga hardware at a minimum. After all, HOL is a testament to Amiga games released for the classic hardware it was intended for. You insisting that the HOL notes should be changed based on your isolated experience so far under emulation was quite unreasonable and unfounded.......can you see this now?

Quote:
Originally Posted by DamienD
One problem though as noted in my original post; there are no birds tweeting on the first screen or music playing until you get to the options screen. Also if I set any "AHI" options as opposed to "Amiga Sound" then there is nothing throughout...
No surprise there as AHI is aimed mostly at sound cards than Paula. As I said in a previous post, the lack of music/sound FX suggests a chipram problem and shouldn't be happening under emulation. Anyway, can't say that I noticed any sound problems with 1MB chip/64MB fast free memory on my A1200/030 set-up in my brief tests today.

Quote:
Originally Posted by DamienD
Finally, saying all of the above though, what do I know?!? I'm just a dumb emulator user or maybe it's an emulation issue as noted in posts above this
Well, I've never thought that TBH. Can't really comment about anyone else, though, as I've been too busy to follow EAB too closely in recent months. However, having a blind belief in emulation or your own skills being without fault - especially when a body of evidence suggests that real hardware doesn't have the issues that you've experienced under emulation - is quite baffling and plainly dogmatic TBH. I can remember a couple of other game threads of yours I read and ended up posting in where it turned out to be an emulation issue despite the "symptoms" leading us all to believe that it was unlikely. As always, Toni was very quick to investigate and fix in those instances.

Quote:
Originally Posted by DamienD
Doesn't matter that my job in real life is a 3rd line technical analyst / infrastructure engineer, I'm clearly a noobie when it come to Amiga stuff as I don't own real hardware or have the required intelligence.

To be honest I'm getting quite bored of some people here implying that I'm stupid or something and don't believe a word I say and challenger everything I do
So it's OK for you to do the same to others then having been on the receiving end? Equally, it's not nice when someone (mate or not!) intimates that you're a liar when they want to trust their own experience under emulation, no matter what, over your own experience and those of others you know on real hardware. Hmmmm.....

I'm sure Paul Burkey was no idiot either - he managed to get it all sorted eventually. Do you honestly think that he would have forgotten to tell people in the game manual or FAQ that they needed to have the game CD inserted at all times when playing from HD? He only spent 1.5-2 years updating the manual and pumping out update patches after Sadeness released Foundation. That's what you call dedication and attention to detail methinks, especially at a time when the Amiga market was almost completely dead and his original publisher had long fallen by the wayside.

Quote:
Originally Posted by DamienD
If it continues then I really won't bother doing anything more for this community, what's the point really??? I'll leave it to you "real" Amiga gurus shall I...
Well, I have noticed increasing resistance on your part over time to taking advantage of advice offered by those trying to lend you a hand to sort out or clarify issues. No-one ever said that it was all free sex 'n' beer working on Amiga hobby projects BTW (far from it actually!!). If you're truly passionate about it, though, and you're motivations are not really about the free sex 'n' beer.....then like Daedalus says in his post, you will return after a break, be better & wiser for it and wonder what the hell you were thinking when you left off!

Adrian, Ian, myself and some of the other guys on the HOL/AMR teams, for instance, have copped a lot of crap here and there over the last 15 odd years, yet we're still here contributing as best as we can to the Ami community despite ever-increasing real life demands and occasional pot-shots still being taken at us. If you treat everything you tackle project-wise on the Amiga front as a sprint rather than a marathon, then you are going to burn out, muck-up more than usual and start taking every little thing - real or imagined - personally (not to mention burn bridges with others along the way that you might not be able to mend afterwards). It's as simple and as difficult as that, I'm afraid........

Anyway, like Denis and a few others here, I admire your spirit and tenacity.....so no hard feelings from my end, my friend! Hopefully none from yours either.
Attached Thumbnails
Click image for larger version

Name:	Foundation_Photo00a.jpg
Views:	26
Size:	160.6 KB
ID:	52789   Click image for larger version

Name:	Foundation_Photo01a_.jpg
Views:	25
Size:	145.2 KB
ID:	52790   Click image for larger version

Name:	Foundation_Photo01b_.jpg
Views:	22
Size:	162.3 KB
ID:	52791   Click image for larger version

Name:	Foundation_Photo02.jpg
Views:	22
Size:	152.6 KB
ID:	52792   Click image for larger version

Name:	Foundation_Photo03.jpg
Views:	26
Size:	162.0 KB
ID:	52794  

Click image for larger version

Name:	Foundation_Photo04.jpg
Views:	20
Size:	140.3 KB
ID:	52795   Click image for larger version

Name:	Foundation_Photo05a.jpg
Views:	29
Size:	215.0 KB
ID:	52796   Click image for larger version

Name:	Foundation_Photo06a.jpg
Views:	167
Size:	154.0 KB
ID:	52797  

Last edited by DrBong; 13 April 2017 at 21:45. Reason: Fixed typos + cleaned up/added some stuff!
DrBong is offline  
Old 13 April 2017, 12:16   #26
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 38
Posts: 1,580
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
I have the Original game and installed in emu to compare notes.

First I extracted the latest update files to a folder called Foundation and ran the prefs programme from there. Installed all the files it allowed and set up rtg screens, ahi and cdda through cybppc.device.

To make it not require the cd I needed to manually copy over the gfx/anim folder for the intro to work and the maps/import folder.

The game seems to work fine for the most part. with the cd in the music played for a few seconds and crashed the emulation hard. I have to use task manager to kill winuae. With cdda disabled the game appears to work fine. Sounds/music played through ahi also appeared to work ok through emulated Toccata sound in this case.
Mad-Matt is offline  
Old 13 April 2017, 12:20   #27
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,054
On WinUAE I started Foundation directly from CDs and audio emulation works perfectly (not good fault recording audio).

[ Show youtube player ]
AMIGASYSTEM is offline  
Old 13 April 2017, 14:37   #28
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,054
WinUAE AFA OS started Foundation RTG 1024x760 from HardDisk no problem audio and sound (sound disturbat because PC-registration)

[ Show youtube player ]
AMIGASYSTEM is offline  
Old 13 April 2017, 14:40   #29
PortuguesePilot
The Son of Luso
PortuguesePilot's Avatar
 
Join Date: May 2013
Location: Setúbal, Portugal
Posts: 342
Quote:
Originally Posted by Daedalus View Post
But that's the way the Amiga community works, didn't you know? All about the superiority. Maybe it's because it's the only aspect of their lives in which they can feel that way, who knows... Anyway, don't feel disheartened, there are no doubt plenty of seen and unseen users silently appreciating your efforts. I often feel that way too about this community, and so abandon whatever I'm working on and spend my spare time on something else. Eventually though it always calls me back, and I spend about a week trying to figure out what I was thinking when I left off
Couldn't have said it any better myself, Daedalus. 100% agreed. DamienD, your work is appreciated by far more than those that slant it. Don't give it up. Cheers, mate!
PortuguesePilot is offline  
Old 13 April 2017, 15:23   #30
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,054
WinUAE AFA OS started Foundation AGA from HardDisk no problem audio and sound

[ Show youtube player ]


@DrBong
The Future of AMiGA it is the emulation !!!
AMIGASYSTEM is offline  
Old 14 April 2017, 02:01   #31
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,274
Firstly, a big thank you to all my friends that took the time out of their busy lives to install / test this game (be it on a real Amiga or via emulation)

...and, many apologies for getting a little heated / frustrated in my posts last night

I can now say that I'm officially done with the original "Foundation" game... and will not revisit again (installation wise).

On the EAB File Server under the directory "~Uploads/DamienD/LHAs" you will now find the following:

... Foundation_UPD1.12.lha - requires roughly 226MB (the first file that I uploaded).
... Foundation_UPD1.20.lha - requires roughly 226MB.
... Foundation_UPD1.27.lha - requires roughly 170MB.

Use whichever one works best for you
DamienD is online now  
Old 14 April 2017, 04:51   #32
ptyerman
Registered User

ptyerman's Avatar
 
Join Date: Jun 2012
Location: Worksop/UK
Age: 53
Posts: 940
Can someone upload a ISO of Foundation Gold to the EAB server? It's not to be found anywhere I've looked over the last couple years.
ptyerman is offline  
Old 14 April 2017, 12:40   #33
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,021
Is Foundation Gold no longer for sale?
idrougge is offline  
Old 14 April 2017, 14:20   #34
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,274
Could somebody please upload "Foundation: The Director's Cut"? I have all the others now...

It's not available to purchase anymore from Vesalia and I can't find this anywhere for download either
DamienD is online now  
Old 14 April 2017, 19:54   #35
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,274
Quote:
Originally Posted by ptyerman View Post
Can someone upload a ISO of Foundation Gold to the EAB server? It's not to be found anywhere I've looked over the last couple years.
Quote:
Originally Posted by idrougge View Post
Is Foundation Gold no longer for sale?
So can anyone confirm that "Foundation: Gold" is still available for sale? I can't find anywhere on the internet that has it listed; in or out of stock

Anyway, I have the full image already

I've now created an .LHA file for real Amiga users without CD-ROM drives and patched it from v1.50 (original release) to v1.51

...but I won't upload until I'm positive that it's not available for purchase.
DamienD is online now  
Old 15 April 2017, 02:08   #36
ptyerman
Registered User

ptyerman's Avatar
 
Join Date: Jun 2012
Location: Worksop/UK
Age: 53
Posts: 940
I haven't seen it anywhere in 2 years of looking. I have the original Foundation but would like the gold edition.
ptyerman is offline  
Old 15 April 2017, 03:42   #37
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,274
Heya ptyerman,

As mentioned in my previous post; I now have the full "Foundation: Gold" image thanks to a very kind EAB member

I've also create an .LHA file for those real Amiga users that don't have CD drives to install the game themselves...

I will upload the image to the EAB Server for all but only if both of the 2 following conditions are met:

a) The game is no longer sold anywhere (which after my own personal search I believe is the case).
b) The person who kindly uploaded the image is happy for me to then upload it onto the EAB File Server.
DamienD is online now  
Old 15 April 2017, 04:06   #38
ptyerman
Registered User

ptyerman's Avatar
 
Join Date: Jun 2012
Location: Worksop/UK
Age: 53
Posts: 940
That would be great. I've spent the last hour looking on the net for it but nobody has it listed. It hasn't even come up on eBay so it must be one of those hard to come by items these days.
ptyerman is offline  
Old 15 April 2017, 13:52   #39
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,021
Is Foundation: DC still missing? I can rip that today in that case.
idrougge is offline  
Old 15 April 2017, 14:22   #40
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,274
Got that too now thanks to DrBong

...cheers anyway though
DamienD is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
[AmigaCD] The Strangers - .HDF & .LHA (for real Amiga users) DamienD Amiga scene 24 06 October 2017 01:52
Anyone know how to play Foundation? Steve support.Games 2 02 June 2011 23:11
Foundation Gold - cheats? walkthrough? trainer? gaaagh support.Games 12 11 October 2009 20:42
Foundation BarrySWE request.Old Rare Games 3 11 May 2006 22:09
Foundation..... BarrySWE request.Old Rare Games 1 25 November 2005 20:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:07.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.34921 seconds with 12 queries