English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 07 February 2017, 18:20   #1
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
Mouse click problem with cintiq companion and virtual mouse driver

Hi everybody

I'm trying to use my wacom cintiq companion with WinUAE 3.4.0 32bit to paint with Dpaint IV. No pressure sensitivity required. Just simple mouse click.

If I select cintiq companionas input device and use virtual mouse driver,the pointer works fine but I can't get it to left click when pressing with pen. How can I remedy this?

Mikko

edit. I tried lowering process priority with no help

Last edited by donmikko; 07 February 2017 at 20:05.
donmikko is offline  
AdSense AdSense  
Old 08 February 2017, 21:21   #2
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
Doesn't anyone else have this problem?
donmikko is offline  
Old 08 February 2017, 22:15   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,518
Does it work in workbench?

And the usual: config and logs required (including winuaelog.txt, debugging checkbox in Paths panel must be ticked before starting emulation).

Tablets have too many different mouse emulation methods...
Toni Wilen is online now  
Old 09 February 2017, 22:58   #4
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
Hi Toni

No. It doesn't work even in workbench. I can't even click the deluxe paint icon without windows+Alt key combination.

My PC is Wacom Cintiq companion with Windows 10. It's PC with wacom touch screen.

I've attached configuration and log files zipped.

Thank you for your help.
Attached Files
File Type: zip WinUAE.zip (10.9 KB, 18 views)
donmikko is offline  
Old 10 February 2017, 11:47   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,518
Does it work if you select "Windows mouse"? ("named" mouse selections assume rawinput support and touchscreen/tablet may not emulate it fully)
Toni Wilen is online now  
Old 12 February 2017, 19:51   #6
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
If I select Windows mouse with Virtual mouse driver enabled, the problem remains the same. But if I select windows mouse with virtual mouse driver disabled, the mouse pointer is all over the place but the click works.
donmikko is offline  
Old 15 February 2017, 18:35   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,518
I don't have any native Windows 10 (or I think this API was introduced in Windows 8 or so) tablet or touch screen. Except Windows 10 tablet but it is annoying to use for debugging..

Does anything change if you do following:
- change mouse untrap mode to magic mouse or both?
- try fullscreen and fullwindow mode?
Toni Wilen is online now  
Old 16 February 2017, 16:58   #8
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
I will try these when I get back home on weekend.
donmikko is offline  
Old 19 February 2017, 10:52   #9
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
Hi Toni

None of these did any changes for the mouse click. I've attached a snip of the mappings. For some reason left mouse is mapped as button 66?

Mikko
Attached Thumbnails
Click image for larger version

Name:	Mapping.PNG
Views:	25
Size:	18.7 KB
ID:	52086  
donmikko is offline  
Old 19 February 2017, 11:32   #10
donmikko
Registered User

 
Join Date: Feb 2017
Location: Tampere/Finland
Posts: 7
I found a workaround that works for me. From Wacom properties, I assigned stulys click to a keyatroke <F11>
Then in WinUAE I assigned F11 to left mouse click
donmikko is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A2000 left mouse button use in workbench causes mouse to stop responding. gary_nz support.Hardware 5 17 September 2017 10:03
Virtual mouse earok Coders. Asm / Hardware 19 18 March 2016 21:13
Magic mouse/virtual mouse driver issues mark_k support.WinUAE 2 04 December 2012 20:43
Mouse Click Problem With Winuae fishyfish support.WinUAE 1 24 July 2012 15:56
Windows mouse -click hold- exoticaga support.Other 2 05 April 2009 17:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:17.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.18147 seconds with 12 queries