English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 27 October 2016, 19:47   #1
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 162
Adding an old IDE disk to WinUAE 3.3.0

I have tried to add an old (but still working) FFS IDE disk (WDAC31000-00H, 1GB) to WinUAE (run as admin) by first connecting it to my PC via an "R-DriverII USB to IDE" cable, and using the "Add hard-drive" button in hard-drive settings.

The drive appears in the drop-down window but reported as an [OS] disk.
If selected, the read/write checkbox remains ghosted, and if added, theres an "E" prefix in the hard disk list, and when starting the emulator it is not visible on the Amiga side.

Out of curiosity, I tried the same approach with an IDE->card adapter, connected to the same IDE->USB cable (the 44-pin side), and this one was recognized as [RDB] disk, and I was also able to boot it.

I also tried the -disableharddrivesafetycheck without any change.

Is there a solution to this, or will some disks simply not work this way?

Thanks for any help.
Yulquen74 is offline  
AdSense AdSense  
Old 27 October 2016, 19:55   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
It is very common problem. Most (all?) USB IDE adapters don't work with old drives. (Pre-ultra dma or something like that)

Check Windows Disk Manager: it probably reports the drive as zero size or name string is corrupted etc..
Toni Wilen is online now  
Old 27 October 2016, 22:04   #3
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 162
Actually the drive size reports correctly in disk manager, it says its uninitialized and of unknown type. I also tried another brand of ide->usb, but with this one it did not even
show up in winuae, but ok in disk manager.

Well, I will just have to find another way to copy the content of this drive to somewhere
safe. Unfortunately it refuses to work together with newer ide devices in an A1200,
so I will probably have to do a floppy install of tcpip stack and pcmcia network driver onto it to be able to transfer stuff off it.
Yulquen74 is offline  
Old 27 October 2016, 22:21   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
winuae's log will show the error. Less common side-effect is that drive detects normally but any read or write access fails.

Those old drives (usually) work fine when using older PC with real physical IDE connector.
Toni Wilen is online now  
Old 27 October 2016, 23:37   #5
-Acid-
Registered User
 
Join Date: Oct 2012
Location: South Shields
Posts: 424
Buy an ide to sata adapter off ebay from a Chinese seller such as one of these www.ebay.co.uk/itm/262444536836

I use one daily with old IDE drives. I also bought some NOS IDE removable HD caddy's to make changing them over quick (one for my pc and four for my Amiga towers), i'd highly recommend them.
-Acid- is offline  
Old 28 October 2016, 19:21   #6
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 162
Good tip, I will definitely try one of those cheap adapters!
Yulquen74 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone adding formats to kaffers Disk-Utilities? BarryB Coders. General 1 09 August 2015 21:11
Format IDE hard disk with WinUAE jman support.Hardware 19 25 March 2013 14:47
Adding a second harddrive to A1200 with IDE card burf2000 support.Hardware 6 19 August 2012 19:57
Adding a ATAPI IDE Drive Dave_wb support.Hardware 6 19 February 2010 19:04
Adding games to GBAmiga 1.4.3. with multiple disk and drives ? AmiFox project.MAGE 2 23 September 2007 13:16

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:17.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12194 seconds with 11 queries