English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 September 2016, 22:52   #1
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
Improving WinUAE performance

Hello,

If I want to improve WinUAE performance so that vsync + no buffer + low sound sync is improved what should I prioritise? I am currently using onboard gfx for a i5-6500, would a gfx card help or is that a waste of funds?

Appreciate any help.
Thanks,
Kristian
Octopus66 is offline  
AdSense AdSense  
Old 27 September 2016, 17:03   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
"Performance" can mean different things...

GPU upgrade won't help. Unless there is some driver issue (Intel GPU can always equal driver issue )

But seriously, what happens and what should not happen? Details.

(Technically best option for vsync is any variable sync monitor with compatible GPU)
Toni Wilen is online now  
Old 27 September 2016, 18:25   #3
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,482
Which version of Windows are you using? Windows 10 apparently makes lower-latency audio possible. Which sound card/hardware are you using?

Try using the latest beta version of WinUAE which supports event mode WASAPI audio.

There are some tips for optimising for audio here.
mark_k is offline  
Old 27 September 2016, 23:12   #4
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
Hi Toni - ok thanks for confirming a GPU will not help. I went back to some troublesome games from memory with vsync + nobuffer + soundbuffer=1 using latest beta 8 with scanlineadjust=100 and tried WASAPI audio. It seemed to work really well. I will keep an eye out for any reproducible issues. In the past I have had sound bugs and vsync 'wobbles', but seems very good today.

Hi Mark - thanks for the link. I am on Windows 10 yes. Just realtek onboard soundcard. Do you know how I can use event mode WASAPI? Is this different from selecting WASAPI as output device?

Last edited by Octopus66; 27 September 2016 at 23:13. Reason: Answered Mark's question re: Windows 10 / soundcard
Octopus66 is offline  
Old 27 September 2016, 23:22   #5
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,482
The WinUAE 3.4 betas always use event mode WASAPI (when you select WASAPI not DirectSound). Also WASAPI EX (exclusive mode) could possibly give lower latency than non-exclusive.

Which driver is in use for your sound card? Are you using full-screen mode? Windowed and full-window modes force vsync on Windows 10.
mark_k is offline  
Old 03 October 2016, 10:06   #6
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
Hi, sorry for not replying, my PC is currently broken and needs to go back for a repair No WinUAE for me for a while.
Octopus66 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
About improving the WinUAE Floppy Drive Sound emulation... Dr.Venom request.UAE Wishlist 48 10 April 2017 11:09
WinUAE settings for best HD performance? AEV support.WinUAE 3 16 June 2016 10:19
Winuae config for maximum performance? Haywirepc support.WinUAE 8 03 March 2015 09:25
Improving emulated performance from original speed (or lack of) Morbane support.Amiga Forever 14 18 December 2011 02:57
Poor WinUAE performance and flashing screen dekarAF support.WinUAE 68 25 October 2009 10:09

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11754 seconds with 11 queries