English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 September 2016, 22:47   #1
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
Pinball Fantasies AGA - flipper bug

Hello all,

I have been having a problem with Pinball Fantasies AGA (using 3.3.0). The issue is the ball appears to go through the flipper, which is very distracting when you start to notice it.

This happens with all configs I have tried (quickstart A1200/CD32). I attempted to record a video, but it was easier to go on youtube. The first video I found exhibits the issue. I paused at 42 seconds in and moving frame by frame it is quite apparent that the flipper goes through the ball as shown below.



[ Show youtube player ]

Any help with this? Its really bugging me

Thanks a lot!
Octopus66 is offline  
AdSense AdSense  
Old 27 September 2016, 00:24   #2
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 8,991
Hmmm, just tested. I can sort of see what you mean but it's only slight...

Also tried the OCS / ECS version and it's the same.
DamienD is offline  
Old 27 September 2016, 12:12   #3
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
Hi Damien,

Thanks for confirming. I agree it could be described as 'only slight', but once you see it you cannot 'unsee' it. It is definitely there and does not happen on a real Amiga, so I think it's a bug. Unless there is a config trick to fix it. I tried everything I could think of.
Octopus66 is offline  
Old 27 September 2016, 12:21   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
I can't see how it can be emulation bug. Game does not use any hardware collision methods.

EDIT: Unless sprite updates are very timing critical and if it happens too early/late, some sprites show in position of previous/next field and some current field (ball and flippers are sprites)

Last edited by Toni Wilen; 27 September 2016 at 13:24.
Toni Wilen is offline  
Old 27 September 2016, 19:47   #5
DopPie
Zone Friend

DopPie's Avatar
 
Join Date: Sep 2004
Location: Den Hoorn, NL
Age: 38
Posts: 259
I just fired up Pinball Fantasies AGA on my A1200. If I look very closely I think I can see it happening when the ball has a high speed and the flipper moves upwards. But it is only for a very brief moment. Maybe just a frame.
DopPie is offline  
Old 27 September 2016, 22:24   #6
Octopus66
Registered User

 
Join Date: Feb 2016
Location: London
Posts: 56
I see it happening at low speed though too.

I decided to dust the CD32 off to try and show what I am seeing. The original videos were 240 fps, but I think YouTube brings this down to 60.

If you play at 0.25 speed at 60 fps it should be visible or I can send the originals somewhere (40MB).

WinUAE 3.3.0
[ Show youtube player ]

CD32
[ Show youtube player ]

Toni - do you think it might be the sprites needing precise timing? The physics seem ok.

Last edited by Octopus66; 27 September 2016 at 22:26. Reason: Saw Toni's edit
Octopus66 is offline  
Old 28 September 2016, 12:58   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
After some more thought: no, it would also cause random jumping of the ball.
Toni Wilen is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pinball Fantasies AGA error Akira project.WHDLoad 4 22 January 2016 21:32
A1700 Playing Pinball Fantasies AGA spannernick support.Games 3 28 June 2015 14:32
Pinball Fantasies Billion Dollar Gameshow bug? TikTok support.Games 5 01 February 2014 17:33
Pinball Fantasies AGA/CD32 problem john4p project.WHDLoad 0 16 July 2012 12:56
Pinball Fantasies AGA - Tables killergorilla HOL contributions 5 12 April 2005 21:15

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:23.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.13403 seconds with 11 queries