English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 18 September 2016, 17:36   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Mouse is uncaptured on graphics API change

I noticed an issue related to changing graphics API (Direct3D ↔ DirectDraw).

With emulation running and mouse captured, press F12 to open the settings window then click OK or Cancel. The mouse is automatically re-captured when the settings window closes.

However if you change graphics API, the mouse is not re-captured when the settings window closes. In particular, if you have the pause-when-mouse-uncaptured option enabled, on clicking OK to dismiss the settings window emulation is paused showing a black screen.

Suggestions to fix:
  • If mouse was captured before opening the settings window, re-capture it even on changing graphics API.
  • If emulation was paused before opening settings and changing graphics API, copy the "old" Amiga image into the new-API window to avoid showing a black screen. (Or just always do that on API change.)
mark_k is offline  
AdSense AdSense  
Old 18 September 2016, 17:48   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,518
Option that is changed basically only once or twice? Not worth the trouble even to think about it
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing to full-screen mode when pause when mouse uncaptured crashes mark_k support.WinUAE 1 24 January 2015 15:35
Bug: Mouse still captured when selecting "start mouse uncaptured" scoobydude512 support.WinUAE 1 24 June 2013 10:28
WinUAE 2.5.0 graphics API change issue with A2024 modes mark_k support.WinUAE 2 09 December 2012 16:19
Problem with pausing when mouse uncaptured mark_k support.WinUAE 0 06 December 2012 16:38
How to change Mouse Pointer in AmigaSYS4 fitzsteve support.Apps 8 26 August 2010 16:21

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:40.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.10402 seconds with 11 queries