English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 28 August 2016, 22:59   #1
Actyon
Registered User
 
Join Date: Feb 2013
Location: Madrid, Spain
Posts: 16
GUI window is too slow

Something trange happened to my WinUAE. Since some weeks ago, when I play and then open the GUI window (F12), WinUAE almost crashes and takes too long to load the GUI window. Even then, it is also difficult to navigate the window, the options, the buttons, everything takes too long. Also if I switch to another window (eg. Firefox) and then switch back to WinUAE's GUI window, it also takes long to re-render itself.

I am using Vista and the portable (zip) version of WinUAE. Presently I am using version 3.3.0, but I have also tried with 3.0.0 and it behaves the same. I don't think 3.0 was like that back when I used that version. My system hasn't been through any configuration changes.

I also tried to download and unzip WinUAE in another directory and the strange behavior persisted. I noted that the paths I had chosen were the same, so I guess that even the portable version of WinUAE installs and refers to some setting files. My theory is that these shared/common files are somehow corrupted and affect WinUAE's performance?

Any suggestions?

PS. I briefly tried WinFellow. Its performance was very good. However I saw no options about capturing screens or saving savestates, which are very important for me. Aren't these supported?

Last edited by Actyon; 28 August 2016 at 23:17.
Actyon is offline  
AdSense AdSense  
Old 29 August 2016, 11:57   #2
Actyon
Registered User
 
Join Date: Feb 2013
Location: Madrid, Spain
Posts: 16
I should add that this happens when the emulator is running. When I run WinUAE first (that is, before loading a game), everything works as should.
Actyon is offline  
Old 29 August 2016, 13:05   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
Only when fullscreen mode is open? Or also in windowed? DirectDraw or Direct3D mode? (Misc panel. DD can work quite strangely in newer Windows versions)
Toni Wilen is offline  
Old 29 August 2016, 14:41   #4
Actyon
Registered User
 
Join Date: Feb 2013
Location: Madrid, Spain
Posts: 16
I use windowed mode but it doesnt seem to make any difference. Switching between DD and D3D doesn't fix anything.

As I said I have Vista, which is not newer Windows version. In any case, the problem appeared quite recently and inexplicably. I was playing decently during summer. I don't remember changing any configuration settings since then, nor in WinUAE nor in my OS nor in my hardware.
Actyon is offline  
Old 30 August 2016, 09:24   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
Unfortunately I have no more suggestions. This is the first time I have heard about this kind of weird problem.

GUI is made from basic win32 gui elements, there is nothing custom.

You could run with log window open to see if something odd is getting logged ("winuae.exe -log")
Toni Wilen is offline  
Old 01 September 2016, 16:49   #6
Actyon
Registered User
 
Join Date: Feb 2013
Location: Madrid, Spain
Posts: 16
Thank you for your coments so far. In the meantime can someone answer the following questions?

1. Does WinUAE, even the portable version, save some files in some "common folder"? As I said, whenever I download a portable installation, no matter where I install it, they always maintain some same settings, for example d:\emulators\roms I had chosen in the first place. How is it possible for every WinUAE new installation to "remember" this information even when I unzp them to different folders? If there is such a common shared folder or file, I intend to purge it in order to have a 100% fresh installation.

2. Does Winfellow support capturing and savestates? If yes, I could switch to that program and get over with any WinUAE problems.
Actyon is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow window rendering ClassicWB OS 3.5 vacum project.ClassicWB 20 14 July 2013 18:24
WinUAE too slow charging games on Window Vista j_sntos support.WinUAE 48 03 February 2012 08:16
WHDLoad GUI exoticaga project.WHDLoad 17 23 September 2007 20:44
Kumiko GUI - Amiga Workbench 3.1 GUI for Windows milika Amiga scene 31 18 April 2007 19:16
Screenshots in GUI? snarfo request.UAE Wishlist 4 30 December 2004 19:49

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:46.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.16157 seconds with 11 queries