English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 23 February 2016, 05:43   #1
ED-209
Registered User

ED-209's Avatar
 
Join Date: Mar 2012
Location: OCP
Age: 37
Posts: 960
Hostages bug on 020+

Seems there is a bug in Hostages (1988) where in the first part of the game, as soon as you emerge on to the street you are shot dead
It works ok on OCS/ECS configs, only 020+ is affected.
All game versions have same result (SPS / cracked / WHDload).
Tested with standard a1200 quickstart.
ED-209 is offline  
AdSense AdSense  
Old 23 February 2016, 06:43   #2
TenLeftFingers
Registered User

TenLeftFingers's Avatar
 
Join Date: Sep 2013
Location: Ireland
Age: 38
Posts: 782
That is very funny I have an 1200 too so I hope there is a "cure" but I remember playing the game some time ago amd that didn't happen. Ill check -maybe it was the c64 emulator I was playing :/
TenLeftFingers is offline  
Old 23 February 2016, 07:10   #3
ED-209
Registered User

ED-209's Avatar
 
Join Date: Mar 2012
Location: OCP
Age: 37
Posts: 960
Yes it makes the game slightly difficult
ED-209 is offline  
Old 23 February 2016, 07:33   #4
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Posts: 2,522
BOOM!!! DEAD!!! You're right, I have never test that out before..

Noticed also 030 is affected on whdload
Attached Thumbnails
Click image for larger version

Name:	Hostages (1988)(Infogrames)[cr VF - Beyonders]_001.png
Views:	177
Size:	17.5 KB
ID:	47639  

Last edited by ransom1122; 23 February 2016 at 07:40.
ransom1122 is online now  
Old 23 February 2016, 08:21   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
It is game bug. Switching off immediate/waiting blitter probably fixes it. (and no JIT allowed)
Toni Wilen is offline  
Old 23 February 2016, 09:01   #6
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Posts: 2,522
Quickstart 1200 has immediate blitter & JIT Disabled. So issue/bug is still there.
ransom1122 is online now  
Old 23 February 2016, 10:25   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
Read my post more carefully again.
Toni Wilen is offline  
Old 23 February 2016, 13:16   #8
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Posts: 2,522
Game issue on 020+ end of question then.
ransom1122 is online now  
Old 23 February 2016, 13:18   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
I think you still didn't read it carefully enough
"waiting blitter" (or Wait for Blitter) option is the key word.
Toni Wilen is offline  
Old 23 February 2016, 13:18   #10
s2325
Zone Friend

s2325's Avatar
 
Join Date: Jun 2006
Location: Gargore
Age: 37
Posts: 17,538
I had some bad crack(?) with same issue on A500 config. Instant death after start.
s2325 is offline  
Old 23 February 2016, 15:29   #11
ED-209
Registered User

ED-209's Avatar
 
Join Date: Mar 2012
Location: OCP
Age: 37
Posts: 960
Quote:
Originally Posted by Toni Wilen View Post
It is game bug. Switching off immediate/waiting blitter probably fixes it. (and no JIT allowed)
Disabling "wait for blitter" fixed it, thanks Toni!
ED-209 is offline  
Old 07 June 2016, 12:53   #12
a500
 
Posts: n/a
In my case "wait for blitter" didn't work, I must set "Cycle-exact" full.
Using WinUAE 3.2.2, A500 OCS
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hostages (Inforgrames) quahappy HOL contributions 0 18 May 2015 20:51
hostages trainer? pepinos request.Old Rare Games 8 15 July 2010 21:09
020 + JIT bug? smoorke support.WinUAE 2 16 July 2009 20:52
Hostages... unstable Kristian95 project.WHDLoad 2 10 May 2008 18:01
Help with Hostages please! FunkScientist support.Games 13 17 October 2003 23:21

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:45.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15310 seconds with 12 queries