English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 09 February 2016, 11:45   #1
moogthedog
 
Posts: n/a
Super-speedy winUAE

Newbie here, so apologies if this is a michey mouse question.

I came across an issue this morning where everything in winUAE was running too fast - I'd estimate about 150% speed. The FPS in the status bar was happily showing 50FPS, but the action in any games was too fast to keep up with.

I carefully checked through the configuration screens, but I couldn't see anything wrong. I used the 'Quickstart' screen to change away from my default Amiga 500 configuration and then back again, but it carried on running fast.

Eventually I renamed the configuration.cache file (adding a '.old' extension) and it settled down after it created a new one. I'm glad it's repaired, but I'm interested in what I may have done in the first place to create the problem. I certainly hadn't gone in and explicitly set/unset any throttles.

I've seen that there's some F12+otherstuff key combos that might change the emulator's behaviours, but I don't have a readme or a manual listing any of them, so I'm sort of in the dark.

Thoughts?
 
AdSense AdSense  
Old 09 February 2016, 17:47   #2
huepper
Registered User

huepper's Avatar
 
Join Date: Nov 2009
Location: GDR
Age: 43
Posts: 232
Upload both configs and we will see.
I think it's a problem in CPU panel:

CPU Emulation Speed is set to "fastest possible".

For real Amiga 500 or 1200 you have to set it to:

Approximate A500/A1200 or cycle-exact
huepper is offline  
Old 10 February 2016, 10:56   #3
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 56
Posts: 517
You Scots, getting it faster than everybody and still moaning

Greets from a soft Southerner, as Huepper said, in the CPU panel you will see CPU Emulation Speed, make sure its set to A500 / 1200 cycle exact..

Also, what version of WinUae are you using because the setting have changed in bits over time...

Its recommended you use the last final for stability but most of us use the beta's as Toni is a whizz at sorting the bugs that arise so generally the beta's can be as reasonably dependable as any beta can be.

If in doubt, last final...

Paul..
Mclane is offline  
Old 10 February 2016, 11:35   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
It probably was simply incompatible configuration, some games don't care, some work strangely, some work fast, some just crash.

Just visiting/changing Quickstart options won't change configuration if "start in quickstart mode" is not ticked and you didn't click "Set configuration" button.
Toni Wilen is online now  
Old 10 February 2016, 12:38   #5
Mclane
Old fart!

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 56
Posts: 517
or have a configuration named Default which it will load automatically..

Default is handy if you use a particular setup most of the time ie A500+ for a large selection of games sold where a bare machine is most likely to work (possibly with a 1MB upgrade).

Most people have a selection of configs ie AGA, different CPU's but with games its best to have it set as how the machine arrived in the box, the more funky stuff you add, the more a game MAY have an issue.
Mclane is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedy. The variable speed accellerator. DDNI Hardware mods 9 18 June 2012 21:33
Help running Super Stardust CD32 in Winuae manicx support.WinUAE 5 06 July 2011 15:47
Can't load Super Methane Bros in WinUAE, Vollldo support.Games 8 12 March 2011 13:00
Shoot the Speedy One... JonSick request.Old Rare Games 0 16 September 2010 12:14
Super Frog in Winuae dsinclair999 support.WinUAE 15 06 May 2006 23:22

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:43.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.14544 seconds with 11 queries