English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 24 January 2016, 19:14   #1
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
SD Card HD

I have a SCSI2SD card in the CDTV. I have partitioned the SD card (2gb sandisk) and Installed WB, everything works fine.

I wanted to use WinUAE to Install CWB. Problem is, the SD card is in the list of Add Harddrives as RDB but it's not bootable, it isn't listed in the early start menu or HDToolbox using WinUAE 3.2.2. The earliest that works is 2.6.1.

Is this a known problem, Is it being fixed for 3.3.0?
Arnie is offline  
AdSense AdSense  
Old 24 January 2016, 20:54   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
SD cards should not be any more special than other memory cards.

-> logs needed. Enable logging (Paths panel), load your config with SD card mounted and added (as UAE controller), boot to WB. Quit. Attach winuaebootlog.txt and winuaelog.txt.
Toni Wilen is offline  
Old 24 January 2016, 21:48   #3
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
Logs added, used A600 2mb default config.

Last edited by Arnie; 19 February 2016 at 21:45.
Arnie is offline  
Old 24 January 2016, 21:59   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
What kind of SD adapter you have? It reports no name in the log and reports only drive letter but no device path which seems odd..

My USB3 memory card adapter works fine with SD and CF cards.

Does same happen if you run winuae with admin privileges?
Toni Wilen is offline  
Old 24 January 2016, 22:04   #5
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
It's a microSD to SD adapter

Here are the logs for running as admin.

and the logs winUAE.7z) running winuae 2.6.1 (crashes with ramlib though)

Last edited by Arnie; 19 February 2016 at 21:45.
Arnie is offline  
Old 25 January 2016, 09:33   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
I meant how you connect the SD card to Windows PC? There is something strange going on with your adapter.

(I'll check what changed in 2.6.1 later, probably some extra validation)
Toni Wilen is offline  
Old 25 January 2016, 12:59   #7
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
It's a laptop with a built in Card reader.

It uses the SDA Standard Driver (sdbus.sys)
Arnie is offline  
Old 25 January 2016, 18:25   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Bug found, it will be fixed in next beta. (Too many ':' characters..)
Toni Wilen is offline  
Old 25 January 2016, 18:53   #9
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
Yay!! Thanks Toni
Arnie is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slave CF card setup disappears after reboot with dual CF card adapter tygre support.Hardware 43 22 March 2016 10:21
Please help. Accelerator card breaks startup-sequence scsi.device (CF Card)? ibsimpson Hardware mods 1 09 May 2012 16:12
PC app that reads/writes to Amiga-formatted card in card reader? Photon support.Apps 6 19 July 2011 09:33
A600: CF in IDE, SRAM card in PCMCIA... how to add a 'to PC transfer card'? Photon support.Hardware 9 15 January 2011 18:17
For sale: AteoBus A1200 busboard with Pixel64 RTG card, Network and scsi card. Smiley MarketPlace 0 18 July 2006 23:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:49.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.24881 seconds with 11 queries