English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 18 January 2016, 12:35   #1
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 162
WinUAE and USB->SCSI adapters

Can such device (example in link below) be used to setup a SCSI disk using WinUAE, and then insert
it back into A590 or similar old SCSI controller on the Amiga side for optimal
use?

Thanks in advance for any replies.

http://www.ebay.com/itm/Microtech-US...3D141877617049
Yulquen74 is offline  
AdSense AdSense  
Old 18 January 2016, 15:27   #2
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
While I haven't used WinUAE for that I do have experience with these USB-SCSI converters.

What I would do, is create an HDF of the exact same size as your target SCSI hard drive, set that up as you want using WinUAE, then write the HDF to the SCSI drive using a command like dd or similar (I use Linux, though there are probably Windows equivalents, maybe WinImage???). That way the setup process would be much faster than having WinUAE access the SCSI drive directly.

The price of the converter you linked to is rather high. Strangely the same seller has a Belkin converter for US$48 which is more reasonable (still with the same very-high shipping cost though). Both converters use the same chip inside, and are functionally identical.

General converter tips (for all SCM-chip-based converters): Most work as standard USB mass storage devices, providing you set the connected drive's SCSI ID to 0. To use more than one SCSI drive in a chain, or with non-0 ID, you have to install a specific driver in Windows. Only 32-bit drivers were ever produced though. You can force the old driver to install even in 32-bit Windows 10. The converters work fine with no need for special drivers in Linux.

Most of the converters derive their power from the SCSI TERMPWR line. That means the drive(s) you connect must supply termination power in order for the converter to work. (Or use a special adapter which inserts termination power. The Belkin converter would have come with one of those when new.)

Last edited by mark_k; 18 January 2016 at 16:23.
mark_k is offline  
Old 18 January 2016, 16:31   #3
Amiga_CDTV
Mind Walker
Amiga_CDTV's Avatar
 
Join Date: Oct 2013
Location: Helsinki, Finland
Posts: 140
It appears that all USB-SCSI -adapters are quite expensive.

I have used an old Belkin USB-SCSI -adapter and it worked fine with WinUAE (directly accessing the hard disk). But it was very very slow as it was only USB 1.

As mark_k suggests, using a disk image and then writing it to the disk is faster.
Amiga_CDTV is offline  
Old 28 January 2016, 14:41   #4
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Another benefit of preparing a disk image prior to writing to the target SCSI drive is that you can run a disk optimiser like ReOrg on the partitions. That would be much faster than operating on the SCSI HD directly.
mark_k is offline  
Old 29 January 2016, 05:28   #5
kneehighspy
Registered User

 
Join Date: May 2015
Location: cerulean / usa
Posts: 73
i purchased one of the belkin usb2scsi devices from ebay and i tried it on 3 different laptops of mine, my alienware m18xr2, an older inspiron laptop and a no named brand and i couldnt get it to work on any laptop properly at the moment, no matter how i install the drivers, it always displays the exclamation error in hardware config and says unable to start the device.

the m18xr2 running 64bit win7, the other two just running standard installs of 32bit win xp. i will mess with it more this weekend.

//kneehighspy
kneehighspy is offline  
Old 29 January 2016, 16:12   #6
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Which Belkin converter do you have? There were two models. Exactly which SCSI devices do you have connected to it?

Here's how I would go about getting it to work:
  • First, don't install any driver that you might have found online. [Once you know the converter is working you can manually install a later version driver which is likely to be more compatible with XP and later. I can give more info about that...] There are no drivers for 64-bit Windows anyway.
  • With Windows and no driver installed, only the single SCSI device with ID 0 will be recognised.
  • Connect the SCSI device you want to use to the converter. Make sure the jumpers on the device are set so its SCSI ID is 0. (External SCSI Zip drives can only be set to ID 5 or 6 so can't be used without installing the driver. But you'd be better off just getting a USB Zip drive instead.)
  • Make sure the SCSI device is set to provide termination power to the SCSI bus. The converter uses that for its power supply. If your device can't do that, you can add another SCSI device to the chain (jumpered for non-0 ID) which does supply termination power. The Belkin converter originally came with a termpower adaptor and power supply but if you bought a used one that may be missing.
  • Power on the SCSI device(s). Wait until they spin up/initialise and only after that connect the converter to your PC's USB port.
  • Hopefully Windows should detect the drive with ID 0.

To rule out a hardware problem, you could download a Linux live CD/DVD and boot from that. Linux fully supports pretty much all the SCM-based SCSI converters with no need to install extra drivers. If you can't get it working in Linux there may be a hardware problem. But as mentioned above, you have to ensure that at least one SCSI device in the chain is supplying termination power to the SCSI bus.

Edit to add: Also make sure the device at the end of the SCSI chain is terminated. Either enable its built-in termination or use an external terminator.

Last edited by mark_k; 29 January 2016 at 20:03.
mark_k is offline  
Old 30 January 2016, 06:12   #7
kneehighspy
Registered User

 
Join Date: May 2015
Location: cerulean / usa
Posts: 73
mark_k,

thanks for the suggestions, i will give them a try over the weekend. the belkin unit i have is the F5U015. the 'drivers' that are listed online are usually for crap driver websites that try to get you to install their extra 'payloads'.

at first just plugging in the adapter it wouldnt even be recognized. so i hooked up an external cdr, with proper terminations, now i can see the adapter in hardware config but it has the exclamation claiming driver not running.

i will give your suggestions a try and see where that goes, i do appreciate the info, its very much appreciated.

now if i could just get my A508IDE i ordered mid december received in the mail i can get back to my amiga 1000 fun.

again, thanks for the info, much appreciated! i will post my results once i am done. thanks!

//kneehighspy
kneehighspy is offline  
Old 30 January 2016, 12:27   #8
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Quote:
Originally Posted by kneehighspy View Post
at first just plugging in the adapter it wouldnt even be recognized. so i hooked up an external cdr, with proper terminations, now i can see the adapter in hardware config but it has the exclamation claiming driver not running.
That's the usual symptom if you haven't set the drive's SCSI ID to 0.

If you previously installed some driver for the converter, right-click it in Device Manager and (hopefully) there's an option to uninstall the driver. Do that.

Last edited by mark_k; 30 January 2016 at 13:11.
mark_k is offline  
Old 01 February 2016, 02:28   #9
kneehighspy
Registered User

 
Join Date: May 2015
Location: cerulean / usa
Posts: 73
Quote:
Originally Posted by mark_k View Post
That's the usual symptom if you haven't set the drive's SCSI ID to 0.

If you previously installed some driver for the converter, right-click it in Device Manager and (hopefully) there's an option to uninstall the driver. Do that.

thanks mark_k i appreciate the help. i did get it working on my dell inspiron, but not on my alienware m18xR2. i have run into issues where some non usb 3.0 usb devices will not work properly on my 64 bit alienware win7 machine. but when i try them on one of my lesser spec laptops, they work fine, one example using a ttl adapter to flash my gotec drives, wouldnt work at all on my alienware laptop but work fine on the non usb3 32bit windows xp laptops.

the usb->scsi adapter is working fine on my non usb3 32bit win xp laptops as per using your suggestions, but will not work at all on my alienware laptop.

which is fine with me cause i have three monitors hooked to my alienware m18x and its used mainly as my coding machine, so i dont mind having to use the older laptops as my usb devices machines.

thanks again for your input, i really appreciate it.

//kneehighspy
kneehighspy is offline  
Old 02 February 2016, 16:43   #10
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
You could look into whether a driver update is available for your Alienware laptop. Also a Windows update/fix might be possible.

One example of an issue (with workaround) that stops certain devices working in USB 3.0 ports is shown at http://blogs.msdn.com/b/usbcoreblog/...-3-0-port.aspx (That's for Windows 8.1 not 7 so probably not the cause of your problem.)

Also another issue at http://us.focusrite.com/answerbase/c...-non-root-hubs

You could also try connecting the non-working device to your Alienware via a powered USB 2.0 hub.
mark_k is offline  
Old 03 February 2016, 13:58   #11
dirkies
Zone Friend

dirkies's Avatar
 
Join Date: Aug 2002
Location: Belgium
Age: 44
Posts: 1,175
I have this one, http://www.adaptec.com/en-us/support...ac/usbxchange/
Works fine but only upto WinXP SP3, no newer drivers were ever released, and will not work even on later 32bit WinOSes.

I also know there is a driver included for this specific USB>SCSI adapter in the Rapidroad USB module software, but have not tested that yet.

So I would need to install WinUAE in my virtual machine XP and see if it will connect to y JAZ drive or SCSI CDrom I have laying around here.
dirkies is offline  
Old 03 February 2016, 15:42   #12
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
I think I managed to get the Adaptec USBXchange driver to install in later 32-bit Windows. How did you try installing it? I definitely managed to get the SCM USB-SCSI driver to install in a Windows 10 32-bit VM, so it is possible to force installation of older drivers which weren't specifically developed for more recent Windows versions.

See [ Show youtube player ]. Skip to the 3:05 point.

Basic steps:
  • Open Device Manager (from System Control Panel)
  • Right-click the entry for the device you want to install the driver for and choose "Update Driver Software..."
  • Choose "Browse my computer for driver software" then "Let me pick from a list of device drivers on my computer"
  • There should be a "Have Disk" button. Click that then browse to the directory where you unpacked the driver files (.sys and .inf files)
  • Hopefully that should install the driver.
Also see the "To locate the .inf file and manually install the driver" section in Microsoft KB927524.

Edit to add: Even if you have the USBXchange, download and install the USB2Xchange driver instead. That's a later version and works with both USBXchange and USB2Xchange.

Last edited by mark_k; 04 February 2016 at 14:35.
mark_k is offline  
Old 17 February 2016, 09:19   #13
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 37
Posts: 6,220
Send a message via Skype™ to Jope
I run my usb2xchange with Win XP in a Virtualbox VM.. Someone made Linux drivers for it, but they were for some ancient kernel and were never merged.

Now there's a project, make a DKMS driver out of that..
Jope is offline  
Old 17 February 2016, 12:42   #14
dirkies
Zone Friend

dirkies's Avatar
 
Join Date: Aug 2002
Location: Belgium
Age: 44
Posts: 1,175
same here, works fine under XP (with the correct drivers, not the one from the Adaptec site!) but can't make it work for anything more recent. May try win7/10 x86 for a change...
although it is just to check my Amiga JAZ disks I still had around, not much other use today for this device. Although let's see how it works with the Rapidroad if I get my A4000 assembled back together (it already has a cyberstormSCSI in there but just for the sake of testing rapidroad, why not?)
dirkies is offline  
Old 30 January 2017, 15:33   #15
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Just to bump this thread with some more info...

For any SCM-based USB-SCSI converter, you can manually force the (most) appropriate driver to install even on 64-bit Windows. The driver used is Windows' own USB mass storage driver. It only supports a single drive with SCSI ID 0 but that's better than not working at all. I can give step-by-step instructions if anyone needs them.
mark_k is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Mouse Adapters + PC Keyboard Adapter Amigan123 MarketPlace 0 30 August 2013 07:00
Amiga USB Mouse Adapters Amigan123 MarketPlace 0 29 June 2013 16:41
For Sale - PSX/PS2 Adapters, Indivision adapters and misc kipper2k MarketPlace 9 16 September 2012 19:00
Question : USB to Parallel adapters weasel_ch support.WinUAE 6 15 August 2009 02:07
Different Acard SCSI-IDE/SATA adapters Calgor support.Hardware 25 11 December 2007 15:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:43.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.26313 seconds with 11 queries