English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene

 
 
Thread Tools
Old 11 January 2016, 00:19   #1
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 41
Problem running programs from HD in emulator

I must be missing something basic here. I have trouble running many programs from the HD. E.g. in AmigaForever I copy the A4000 item, on the Media tab I add a new HD based on the Shared\dir\Work directory. After I boot I go to Work/Software/PPaint and double-click on the PPaint icon, but the system crashes: "PPaint - Program failed (error #8000000B). Wait for disk activity to finish. [Suspend] [Reboot]".

Do I somehow need to install all these programs to DH0? Would be nice to just have a shared HD all systems can use.

Thanks!
Knocker is offline  
AdSense AdSense  
Old 11 January 2016, 00:49   #2
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
PPaint works from the AmigaSYS + AmiKit systems.

I don't know why it crashes, maybe, like you said, PPaint needs to be installed to the Workbench?

Last edited by Arnie; 11 January 2016 at 01:30. Reason: added amikit
Arnie is offline  
Old 11 January 2016, 15:49   #3
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
I don't know which config is behind the "A4000 item" in Amiga Forever.

I would suggest to add an FPU to the config if it is not yet present.

If the OS is 3.1 you might also need to upgrade SetPatch http://aminet.net/package/util/boot/SetPatch_43.6b
(Check version numbers! Only replace the file if the Aminet version is higher than what you already have!)

PPaint does not need installation.
thomas is offline  
Old 11 January 2016, 22:24   #4
Aegis
Gentleman

Aegis's Avatar
 
Join Date: Dec 2015
Location: The Fortesque Mansion
Posts: 235
Send a message via Skype™ to Aegis
That Shared/Work directory you're assigning is specifically for the Workbench 3.X setup - this uses a different Amiga model (A4XXX) and Kickstart ROM (Amiga 3.X) - it also features a mix of 3.1/3.5/3.9 components and libraries that aren't part of the vanilla 3.1 install the A4000 entry uses.

Your best bet if you want the 'classic' A4000 experience is to create a new shared folder (A4000_Work or similar) and install apps from Aminet etc. You can find a free download of PPaint 7.1c that should work here: http://ppaint.com/index.php (scroll down to the bottom).
Aegis is offline  
Old 12 January 2016, 21:19   #5
Knocker
Registered User

 
Join Date: Jan 2016
Location: Santa Cruz/US
Posts: 41
Thanks for all the responses!

Arnie, to be honest I hadn't even used AmigaSys/AmiKit. PPaint seems to works fine in AmigaSys.

thomas/Aegis - I got it to work after setting Amiga model to A4XXX and Kickstart ROM to Amiga 3.X. I don't really need to run on a specific machine, just wanted something "powerful" that can use the shared work folder. Devpac 3.18 also seems to be working in this config - that was another program I had problems with.
Knocker is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga running C=64 Vice Emulator mistermsk support.Other 7 14 February 2014 05:10
Simple tutorial required for running Amiga emulator on a Mac Pauly79 support.FS-UAE 1 10 February 2014 12:38
Slowdown when some programs are running arti support.WinUAE 4 28 October 2008 03:27
Amiga E: Running external programs lennonlives support.Apps 6 09 October 2008 18:46
Running Audio Synths with an Emulator ypestis support.Apps 5 29 March 2006 20:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:56.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11748 seconds with 11 queries