English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 15 January 2016, 11:07   #41
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
Quote:
Originally Posted by AnnaWu View Post
Toni, any progress for the planned expansion sound card (AdLib or Sound Blaster) board emulation?
No. But someone probably should start by creating pile of test disks that play sounds automatically

Quote:
SYS:PC/system/PC.boot contains text strings concerning the aboot.ctrl file.
PC.boot seems to be 8088 code, certainly loaded at startup by the janus.library.
Janus x86 side is properly loaded, it can be seen in your screenshot.

Quote:
I have set run >NIL: SYS:PC/pcdisk in the startup-sequence just after the bindrivers command.
Which Janus version? I think PC service stuff changed completely in later Janus versions.

Quote:
Perhaps the bios are not really 2088XT... don't know how to diagnose or debug that.
v3.5 = 2088 Bios. Wrong bios would crash or early boot self tests would fail.

Quote:
I expected to find a 8088@4,77MHz, it shows NECV20@10,4MHz and it is really more nervous than PC-Task.
Dosbos core is minimum 286 but it shouldn't cause any problems.
Toni Wilen is online now  
AdSense AdSense  
Old 15 January 2016, 11:45   #42
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
@Toni It is the Bridgeboard disk, sell with the 2088XT card in 1989
Janus Handler 2.63
Janus Library 33.1
It is noted RJ Mical 2.1g in the about of PCWindow (PC Mono or PC Color)

SYS:PC/pcdisk service is used for awrite and aread msdos/janus commands but also with the pc.boot/aboot.ctrl

Perhaps I should upgrade... with janus.library v36.83 ?
http://amiga.resource.cx/exp/a2088xt
Gilloo is offline  
Old 15 January 2016, 12:00   #43
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
I don't know. Unless you have confirmed working config (from confirmed working real installation 1:1 copy), I don't really care if it works or not, it could be normal that it does not work. Sorry

Works for me (at least it worked). Installed janus (don't remember which version) created aboot file, don't remember more.
Toni Wilen is online now  
Old 15 January 2016, 12:52   #44
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 429
I use the last version of Janus.
Everything (ABoot, AT IDE, XTIDE Universal, VGA, .../depending on the x86 Bridgeboard model) is working/bootable for me.
Special thanks goes to Toni.


Last edited by AnnaWu; 15 January 2016 at 13:10.
AnnaWu is offline  
Old 15 January 2016, 16:56   #45
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
It is possible no one has tested old janus with "old style" aboot system.
Toni Wilen is online now  
Old 16 January 2016, 18:48   #46
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
Don't search anymore, there was 2 things wrong

1) in the header file of my hd file
ABOOT + 3 zeros
Heads 0x0004 (max 0x0010)
Sectors 0x0020 (max 0x0040)
Cylinders 0xffcc (max 0x0400)

The Cylinders value is wrong, it must be 0x01fc instead 0xffcc
4*32*460*512 + 512 = 30147072 (30MB)

2) in the startup sequence, the following must be present
BindDrivers
run >NIL: SYS:PC/PCDisk
run >NIL: SYS:PC/AMouse
run >NIL: SYS:PC/Services/TimeServ


All is right
If you remove the 512 header, the aboot file becomes a classic .hdf or .img file.
If anybody is interressed, I can provide a tool to check, fix, add or remove this block.
Attached Thumbnails
Click image for larger version

Name:	2088XT_ok.png
Views:	205
Size:	16.5 KB
ID:	46988  
Gilloo is offline  
Old 17 January 2016, 18:41   #47
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
Little by little...

PCDisk ok
TimeServ ok, but MSDOS3.30 is not Y2K compliant...
AMouse... windows and mouse dependent programs hang up.
Gilloo is offline  
Old 17 January 2016, 18:52   #48
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 429
Check the older thread, maybe it is helpful.
http://eab.abime.net/showthread.php?t=76395
AnnaWu is offline  
Old 18 January 2016, 09:56   #49
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
keyboard :
alt shortcut are not supported...
i.e. left alt + 92 = \
Gilloo is offline  
Old 19 January 2016, 09:35   #50
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
Quote:
Originally Posted by Gilloo View Post
keyboard :
alt shortcut are not supported...
i.e. left alt + 92 = \
I don't see how this is related to emulation, there is no keyboard microcontroller in XT systems (only AT and later) that could cause this, it is all done in janus software or in dos.
Toni Wilen is online now  
Old 19 January 2016, 09:38   #51
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
Quote:
Originally Posted by Gilloo View Post
keyboard :
alt shortcut are not supported...
i.e. left alt + 92 = \
In fact yes they are supported, but it must be done slowly: left alt then one second after type the wanted number on the keypad
On the other hand, the numlock key seems to do nothing.

Concerning the mouse, the amouse.com wait for the amouse service via the 11 interrupt, and wait it for a while...
Gilloo is offline  
Old 19 January 2016, 09:55   #52
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,559
"Works for me" which means (as usual): test case is required. Test case that matches exactly. Preferably "boot from this hd using this config, open pc window, type amouse". Nothing like "do this and do that and then something else and perhaps something happens or perhaps not".
Toni Wilen is online now  
Old 23 January 2016, 20:12   #53
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
Hi Toni,
Here's some work for you...

hdd_13_bb.zip

A2000_13_bb.uae

hdd 13 bb is a 20MB hdd image done with
workbench 1.3 (french)
extras 1.3
bridgeboard 1.3

need: 1.3 rom and A2088 BIOS 3.6.1 380788-06.bin

Inside dh0:, there is a hd image of a complete set of janus and msdos 3.30 which were with the 2088XT package.
Just click on System1.3, open PC, launch PC Color then
type amouse in the msdos window.
amouse hangs, (but atime works (with a wrong date, but it is another story of Y2K bug...))

On the pc hd there is a tools directory with msd.exe inside.
This M$ tool works well with the amouse.com on a true bb 2088XT.

Tell me if something missing...
Gilloo is offline  
Old 24 January 2016, 15:04   #54
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 429
The AMOUSE.COM (PC side) driver is working, tested on Volkov Commander and Star Commander.
Before don't forget to switch the mouse:
Amiga: Left Amiga + P
PC : Insert + P

AnnaWu is offline  
Old 24 January 2016, 15:45   #55
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 429
Example: A2088 Color AB HDD.hdf > TheZone!
AnnaWu is offline  
Old 24 January 2016, 19:06   #56
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
@AnnaWu thanks.
@Toni Concerning amouse, don't search anymore there are bad versionning between my PC janus software and the amiga side. I need something between 1.2 and 1.7... I will try with
the good disk
Gilloo is offline  
Old 25 January 2016, 10:09   #57
Gilloo
Registered User
 
Join Date: Nov 2010
Location: Grenoble, Isère, Rhône-Alpes, France, Europe, Earth
Posts: 154
To fix the Y2K bug... 1900+116 = 19116
http://aminet.net/package/driver/other/TimeServY2K
Gilloo is offline  
Old 25 January 2016, 17:03   #58
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 429
Quote:
Originally Posted by AnnaWu View Post
Example: A2088 Color AB HDD.hdf > TheZone!
Quote:
Originally Posted by Gilloo View Post
To fix the Y2K bug... 1900+116 = 19116
http://aminet.net/package/driver/other/TimeServY2K
New update in >TheZone!<
AnnaWu is offline  
Old 25 January 2016, 19:40   #59
Leandro Jardim
Registered User
Leandro Jardim's Avatar
 
Join Date: Nov 2009
Location: Legoland
Age: 38
Posts: 1,147
I have some questions, how do you do to create dos floppy images without using WinImage, only with free tools? How do you copy external files to the ms-dos floppy image, what tools offer this feature? And finally, it is possible to do this all using only AmigaOS software?

Last edited by Leandro Jardim; 25 January 2016 at 19:48.
Leandro Jardim is offline  
Old 25 January 2016, 20:01   #60
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,944
Quote:
Originally Posted by Leandro Jardim View Post
I have some questions, how do you do to create dos floppy images without using WinImage, only with free tools? How do you copy external files to the ms-dos floppy image, what tools offer this feature? And finally, it is possible to do this all using only AmigaOS software?
The floppy PC-MSDOS you can create with WinUAE and also wanting to format from AmigaOS (see screenshot), for copying Floppy you can use DOS commands, but if I remember correctly, there are also tools to AmigaOS.

Last edited by AMIGASYSTEM; 18 December 2016 at 18:57.
AMIGASYSTEM is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bridgeboard emulation (x86 CPU, for example A2286) GiuseppeC support.WinUAE 627 16 November 2016 15:42
Thylacine emulation in WinUAE? analogkid support.WinUAE 2 13 January 2016 22:22
WinUAe A590 Emulation Mad-Matt support.WinUAE 8 09 November 2014 15:23
Need help with CD32 emulation on Winuae trydowave support.WinUAE 9 31 August 2012 10:07
WinUAE + CD32 Emulation MechUnit support.WinUAE 7 25 November 2003 17:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:36.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.27580 seconds with 13 queries