English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 14 November 2015, 16:18   #1
rbm
Registered User
 
Join Date: Jul 2013
Location: CAT
Posts: 46
UAEquit

Because there is no UAEquit CLI program that works when any 68060 or PPC expansions is selected.

The attached that uses "uae.resource" works.

Usage:

"UAEquit" .......................... Shutdown
"UAEquit RESET" ................. Reset
"UAEquit HARDRESET" .......... Hard reset


The simple source code:

#include <stdio.h>
#include <stdlib.h>
#include "uae_pragmas.h"
#define VERSION_STRING "\0$VER: UAEquit v1.0"
UBYTE *version_string = VERSION_STRING;
int main (int argc, char *argv[]){
if (!InitUAEResource()) printf ("UAE not found\n");
else {
if(!(strcmp(argv[1],"RESET"))) Reset();
if(!(strcmp(argv[1],"HARDRESET"))) HardReset();
if(!(argv[1])) ExitEmu();
printf ("Invalid Parameter\n");
}
}
Attached Files
File Type: lha UAEquit.lha (2.7 KB, 49 views)
rbm is offline  
AdSense AdSense  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
uaequit / uaectrl don't quit with Winuae 1.5.1 Thyphoon support.WinUAE 8 21 August 2008 17:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:03.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.08909 seconds with 12 queries