English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 16 September 2015, 02:23   #1
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,641
Arrow WinUAE 3.1.0, Win10, RTG and DirectX grayed out

Hi Toni,

I've installed WinUAE 3.1.0 on my Mini-PC (Intel j2900 with Intel HD Graphics DX 11.2) together with DirectXJun2010Redist.

It works so far, but all the WinUAE GUI fields for RTG settings and for Direct3D or DirectDraw are grayed out. What's missing or wrong?
Attached Files
File Type: 7z RTGandDXgrayedout.7z (21.6 KB, 56 views)
PeterK is offline  
AdSense AdSense  
Old 16 September 2015, 08:18   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,522
The usual, install DX9 redistributable. (No, Windows has never come with full DX, not even 7, 8, 8.1 or even 10. It is stupid.)
Toni Wilen is online now  
Old 16 September 2015, 08:37   #3
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,641
Yes, that's what I did: first installed DX9 Nov2007 Redist and then Jun2010 Redist. There is no requester from WinUAE anymore asking for the DX9 files.

Update:
Quote:
42-161 [0 000=000]: Direct3D: Pixel shader 2.0+ support detected, shader filters enabled.
42-168 [0 000=000]: Device name: 'Intel(R) HD Graphics' a0012000a109c.e
42-484 [0 000=000]: D3D9Ex: 00000056 ALPHA DYNAMIC SCANLINE
42-484 [0 000=000]: D3D9Ex: PS=3.0 VS=3.0 800*600*0p FS VS=0 B=2WE 32-bit 0
42-562 [0 000=000]: D3D9Ex: pixelshader filter 'M:\WinUAE\_winuae.fx':-1 enabled
42-567 [0 000=000]: D3D9Ex: 752*576 main texture, depth 32
I don't have this filter installed: _winuae.fx

How do I have to install Filtershaders.zip correctly ?? Where should plugins go to?

Update2:
OK, I've copied the plugins dir into the WinUAE install dir and WinUAE has generated the _winuae.fx file automatically now. But all the RTG and DirectX fields are still grayed out in the GUI.

Could this problem be caused by the missing VDD and Mini VDD display driver files?
Attached Thumbnails
Click image for larger version

Name:	Expansion.PNG
Views:	155
Size:	36.3 KB
ID:	45491   Click image for larger version

Name:	Display.PNG
Views:	156
Size:	39.3 KB
ID:	45492   Click image for larger version

Name:	Miscelllaneous.PNG
Views:	167
Size:	43.1 KB
ID:	45493  

Last edited by PeterK; 16 September 2015 at 10:31.
PeterK is offline  
Old 16 September 2015, 12:15   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,522
All looks fine. You didn't include your config but make sure filter is at least null, not none.
Toni Wilen is online now  
Old 16 September 2015, 13:20   #5
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,641
Even with the Null filters it's still the same as shown on the screenshots above. Btw, DSound is also grayed out.
Attached Files
File Type: 7z Default.7z (2.3 KB, 35 views)
PeterK is offline  
Old 16 September 2015, 14:03   #6
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,942
On Windows 10 You've tried to install everything DirectX etc.. and start WinUAE by privileged user administrator !

Last edited by AMIGASYSTEM; 16 September 2015 at 20:10.
AMIGASYSTEM is offline  
Old 16 September 2015, 14:09   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,522
Quote:
Originally Posted by AMIGASYSTEM View Post
You've tried to install everything DirectX etc.. and start WinUAE by privileged user administrator !
Lets keep doing proper debugging and not doing random things until something expected or unexpected happens!

EDIT: Direct3D is obviously working by checking logs.

EDIT2: Actually testing with admin may be good idea if current user has really weird permissions... (normal privilege user still should work)

Last edited by Toni Wilen; 16 September 2015 at 14:31.
Toni Wilen is online now  
Old 16 September 2015, 14:12   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,522
Quote:
Originally Posted by PeterK View Post
Even with the Null filters it's still the same as shown on the screenshots above. Btw, DSound is also grayed out.
What do you mean by DSound being grayed out?

Do you have C:\Windows\System32\D3DX9_43.dll ?
Toni Wilen is online now  
Old 16 September 2015, 14:58   #9
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,641
I've just checked out the same WinUAE settings and config on the same PC with Windows 7. And the main difference compared to Windows 10 and XP is the way how the GUI elements (buttons, selectors) and their colors are displayed.

The problem in Windows 10 is the simplified color schema. The vertical color fades for the selectors like in Windows 7 are simply replaced by light gray backgrounds, but this doesn't mean that these fields are grayed out as I thought. Only the dark gray GUI elements are inactive.

Unfortunately, some GUI elements in WinUAE have just white backgrounds and others have these vertical color fades under Windows 7. What is the reason for their different appearance? Under XP all the active selectors are only white and comparing the XP GUI with Windows 10 has caused the confusion.

Last edited by PeterK; 16 September 2015 at 15:14.
PeterK is offline  
Old 16 September 2015, 15:27   #10
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,522
Could you attach screenshot comparison? I have Windows 10 with default settings and disabled elements are darker. (I don't even remember how it looked under 7..)

Anyway, WinUAE uses pure Windows GUI elements, no customizations.
Toni Wilen is online now  
Old 16 September 2015, 17:44   #11
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,641
All 9 images from XP, W7 and W10 are in the 7z package. W10 is in post #3, W7 files are also attached here;
Attached Thumbnails
Click image for larger version

Name:	ExpansionW7.png
Views:	174
Size:	97.2 KB
ID:	45506   Click image for larger version

Name:	DisplayW7.png
Views:	169
Size:	120.5 KB
ID:	45507   Click image for larger version

Name:	MiscW7.png
Views:	171
Size:	120.9 KB
ID:	45508  
Attached Files
File Type: 7z GuiCompare.7z (548.1 KB, 50 views)
PeterK is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Winuae RTG problems eanklin support.WinUAE 2 14 June 2011 06:58
WinUAE 2300 - update DirectX Photon support.WinUAE 7 03 December 2010 03:57
WINUAE problems with RTG gibb3h New to Emulation or Amiga scene 2 20 August 2010 20:10
More RTG memory in WinUAE El Amigos support.WinUAE 2 24 November 2006 17:12
winUAE rtg problem deoFusion New to Emulation or Amiga scene 0 28 September 2006 10:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:29.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.16132 seconds with 12 queries