English Amiga Board Amiga Lore


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 04 August 2015, 09:14   #41
Sir_Lucas
Registered User

Sir_Lucas's Avatar
 
Join Date: Dec 2008
Location: Norwich, UK
Posts: 267
Great!!!
Sir_Lucas is offline  
AdSense AdSense  
Old 10 August 2015, 17:46   #42
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
@all

I was planning in releasing the new version yesterday but I did not take the time to work on it during the week and the week-end, sorry about that! I'll try for this coming Sunday,though

Cheers!
tygre is offline  
Old 17 August 2015, 18:45   #43
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Dear all!

Just to let you know that version v0.91 of AmiModRadio is now available (here, here, or here).

This version includes a MUI user-interface that will appear when AmiModRadio starts from the Workbench (thanks RetroFan for the icons! ) or from a CLI with parameter MUI. The MUI interface is not complete because I am struggling to learn MUI...

As always, bug reports and feature requests are welcome!!!

Cheers!
tygre is offline  
Old 17 August 2015, 20:02   #44
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Very nice . Congrats.

I think it should open by itself Hippoplayer hidden though.

Also take a look if you like this 16 colors image for the radio when using MUI.

Edit: It seems the forward button doesn't work and it hangs the program.
Ups! Wasn't it thought to be used with AmigaAMP? Sorry then.

Edit: But it hangs with AmigaAMP
Attached Files
File Type: zip Radio2_16C_Iff.zip (3.0 KB, 49 views)

Last edited by Retrofan; 17 August 2015 at 20:37.
Retrofan is offline  
Old 17 August 2015, 20:37   #45
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 156
Is this supposed to be working on an accelerated 68000 Amiga with internet, WB3.1 and much fastmem?

I get the GUI running, but all the buttons are blank and it says "could not fetch and/or play modules". I have both rexxmast and hippoplayer running, internet (roadshow/plipbox) active and >9MB fastmem left, in addition to about 1,8MB chipmem. V0,91.
Yulquen74 is offline  
Old 17 August 2015, 20:43   #46
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Yulquen it works with HippoPlayer here. Maybe you've got it in another place? Mine is in SYS:Utilities/Hippoplayer/Hip. Open it before opening Amimod.

If the buttons are blank maybe you lack the datatype for iffs, surely ilbm.datatype.

Last edited by Retrofan; 17 August 2015 at 20:49.
Retrofan is offline  
Old 17 August 2015, 21:26   #47
Yulquen74
Registered User
 
Join Date: May 2013
Location: Kleppe / Norway
Posts: 156
Ok, the images have to many colors for the old datatypes and would probably
look like dirt on an 8 color screen anyway.

But I got it working in cli mode after installing the unpacker library.
Is it not supposed to download and play module after module automatically?
When selecting 6 or 2, it downloads and plays a module, and after that I have to
select again, else Hippo just repeats the one. If it downloads and unpacks an unknown file, it also stops.

Should it not download and unpack the next one while playing the
current one?
Yulquen74 is offline  
Old 17 August 2015, 23:32   #48
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
(Sorry, at work, so I will do "two in one" )

@RetroFan

Thanks for your support, I really appreciate it! Opening the player and such is bug #2 (#1 being supporting modules.pl). Hopefully, soon!

@Yulquen74

Currently, you must select "6" or ">>|" yourself at the end of the current module(s). Continuous playing (auto downloading) is bug #5, so also soon

Thanks for your feedbacks!
tygre is offline  
Old 23 August 2015, 22:38   #49
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Sunday... do you have something to tell or try ?
Retrofan is offline  
Old 24 August 2015, 07:26   #50
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Hi Retrofan and all!

I really appreciate your interest

I am implementing the "continous mode" (see #5) but that means creating a process and getting my two processes to talk with each other... almost there

Hopefully no more than few days (max a week) will be necessary to fix my mess!

I'll keep you posted and, in the meantime, take care!
tygre is offline  
Old 24 August 2015, 23:43   #51
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Offtopic Tygre, but I was now dreaming that it would be nice to have for the Amiga a program like this:

http://cdn5.andro4all.com/wp-content...analisis-1.jpg

A mixing board.

Or is there any freely distributable?

I could help you with the images if so.

Last edited by Retrofan; 24 August 2015 at 23:56.
Retrofan is offline  
Old 25 August 2015, 06:56   #52
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Next, next, next... x10,000 release

Cheers!
tygre is offline  
Old 30 August 2015, 23:05   #53
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Hi all!

Version v0.92 of AmiModRadio is available here, here, or here

Besides refactorings and bug fixes (it includes bug fixes for #5, #14, #15, #16, and #17.), the main feature is the continous-playing mode! AmiModRadio now monitors the status of the player and, if player support is available, it will notice when the player stopped playing and will automatically load and play new modules

(You must configued your player to notice "song end" and also to stop playing endless modules... Also, MultiPlayer does not allow monitoring...)

As usual, bug reports and ideas are welcome!

Cheers!

Last edited by tygre; 30 August 2015 at 23:07. Reason: Typos
tygre is offline  
Old 16 September 2015, 06:44   #54
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Hi all!

Version v0.93 of AmiModRadio is available here, here, or here

Besides refactorings and bug fixes (it includes bug fixes for #9 (having a progress reports in the MUI) and #22 (reporting missing libraries and such), the main new feature is an improved MUI Still some work to do though...

As usual, bug reports and ideas are welcome!

Cheers!
tygre is offline  
Old 16 September 2015, 18:54   #55
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Very nice. I've seen you don't have an icon for the drawer, so I've made three if you like any. One is Ken's style, another old Glow and another Mattahan drawer.

Edit: They are ok. Ken's one with dual 256C PNG images and the Glow one with 128 colors each, more than original but I think it's ok.
Attached Files
File Type: zip AmiModDrawers.zip (24.7 KB, 51 views)

Last edited by Retrofan; 17 October 2015 at 03:33.
Retrofan is offline  
Old 16 September 2015, 21:00   #56
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Quote:
Originally Posted by Retrofan View Post
Very nice. I've seen you don't have an icon for the drawer, so I've made three if you like any. One is Ken's style, another old Glow and another Mattahan drawer.
Hi RetroFan!

Wow, thanks a lot! I will definitely add them to the next release

Cheers!
tygre is offline  
Old 17 October 2015, 02:58   #57
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Quote:
Originally Posted by tygre View Post
Hi RetroFan!

Wow, thanks a lot! I will definitely add them to the next release

Cheers!
Tygre, it's been a month -has passed fast to me-. Something to share this weekend?
Retrofan is offline  
Old 20 October 2015, 19:14   #58
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Hi Retrofan!

Sorry for the silence... busy time at work and at home... Plus, had to put back my Amiga together

Will try for an update in the coming two weeks! (This current week included!)
tygre is offline  
Old 21 October 2015, 02:08   #59
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,242
Send a message via Skype™ to Retrofan
Tygre I don't like to have to open Hippoplayer before opening AmiModRadio.

So what I've done is to rename your program to "AmiMod", delete its icon and make an icon-script launcher with this:

Code:
Run >NIL: SYS:Utilities/HippoPlayer/Hip HIDE QUIT 
WBRun >NIL: SYS:Utilities/AmiModRadio/AmiMod
It works pretty well in my case. Of course if you can include the first command line in your program, all of this won't be necessary.

Edit: I've just read your wiki page. I like what you want: "Having AmiModRadio use multiple players depending on the type of the modules: e.g., AmigaAmp for MP3s and HippoPlayer for modules"

But till that option is released, and like it is working right now playing just modules, I think Hip is the best option, so I prefer to open it automatically.
Attached Files
File Type: zip AmimodRadio.zip (3.2 KB, 38 views)

Last edited by Retrofan; 21 October 2015 at 02:39.
Retrofan is offline  
Old 21 October 2015, 02:42   #60
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 475
Hi Retrofan!

Actually, this option works for me in CLI mode... but, for some reasons, not yet when running AmiModRadio from Workbench... Bug to fix

Thanks!
tygre is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which games are using modules? 1988 request.Modules 7 29 July 2016 21:24
A few modules Rogue request.Modules 1 31 May 2014 19:22
two modules s2325 request.Modules 4 01 May 2010 16:23
Brain Killer Aminet links changed (and a question about Aminet links) Korodny HOL data problems 0 26 November 2009 22:21
Modules.. Muerto request.Modules 2 15 December 2005 18:32

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:36.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Page generated in 0.23980 seconds with 12 queries