English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 01 July 2015, 13:55   #1
DisposableHero
Registered User
 
Join Date: Nov 2004
Location: England
Posts: 183
Savestate Issue

I've been playing The Settlers on WinUAE, using Savestates to save my game. However, I've just attempted to load one back in and been given an error message - 'OPCODE 615A HAS FAULTY PREFETCH! PC=00F803BC'. Is the savestate recoverable, what has caused this, and is there anything I can do to prevent it happening again?
DisposableHero is offline  
AdSense AdSense  
Old 01 July 2015, 18:21   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
It can happen with 68020+ more compatible/cycle-exact modes. CPU savestate format can become incompatible in newer version without notice.
Toni Wilen is online now  
Old 01 July 2015, 18:47   #3
DisposableHero
Registered User
 
Join Date: Nov 2004
Location: England
Posts: 183
So I should run the game in A500 mode but with extra memory selected?
DisposableHero is offline  
Old 10 July 2015, 13:06   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
(yes, late answer)

Settler most likely does not need any compatible settings, 68000 mode, even with faster CPU speed, should work fine.

You may be able to recover your old state file by finding winuae version that loads it correctly, switch off more compatible and cycle-exact (if set), save it again (don't overwrite old statefile!). It now may load in newer versions.
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Savestate also for Harddisks Konrad request.UAE Wishlist 17 29 May 2016 11:46
Regarding savestate torbenb support.WinUAE 2 24 January 2012 19:33
Alien Bash II Savestate Screen-res issue mnc99 support.WinUAE 14 16 December 2011 16:26
Error when loading savestate hipoonios support.WinUAE 1 14 September 2011 19:17
savestate and customscreenmodes Ratte support.WinUAE 1 17 August 2009 21:00

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:32.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11383 seconds with 11 queries