English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 23 December 2002, 18:47   #1
Simon S
 
Posts: n/a
Question My keyboard dies when WinUAE boots.

Well, not permanently, whenever it boots WinUAE, the keyboard lights go out (numlock, capslock ect..) and I get no response once the emulator is running (everything else seems fine).

Alt-Tab is locked and the middle mouse button no longer tabs out and ctrl-F11 does nothing.

I fixed the frozen mouse and joypad by selecting the input config instead of compatibility mode, but the keyboard is dead. Only an Alt-Tab-Del will bring control of the PC back. My drivers are all updated and I've been messing with the config for ages, but no luck.

This has happened since about 3 releases ago
Athlon 1.33ghz
512MB DDR RAM
WinME
Microsoft Internet Keyboard
 
AdSense AdSense  
Old 24 December 2002, 20:51   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,657
Does installing DirectX 8.1 or 9.0 help?
Do you see error messages in winuaelog.txt?
Toni Wilen is offline  
Old 24 December 2002, 22:21   #3
Simon S
 
Posts: n/a
I had DirectX 8.1 and it failed as described above. I've installed DirectX 9 and the same problem occured. However I can now Alt-Tab out of WinUAE, but unfortunatly still no response in the emulator itself.

I've never had keyboard problems of any kind before.

This is my latest log:
WinUAE 0.8.22, Release 4
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2002 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2001 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
CLOCKFREQ: QPF 1.19MHz
CLOCKFREQ: RDTSC 1332.97MHz (busy) / 1333.29MHz (idle)
Testing MM-timer resolution:
0.85ms 0.86ms 1.06ms 1.02ms 0.96ms 1.02ms
Testing Sleep() resolution:
4.10ms 0.68ms 5.04ms 5.02ms 5.06ms 4.00ms
Using MultiMedia timers (resolution < 2.5ms)
NATMEM: Our special area is 0x11000000
shmget of size 65536 for rtarea


It's a really impressive emulator and I can live with the earlier versions, but I don't want to miss out on all the great improvements. I think it's been since the "Input" tab appeared in configurations that I've had this problem.
 
Old 24 December 2002, 22:46   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,657
Quote:
This is my latest log:
Enable logging (misc-tab) and check also winuaelog.txt for error messages.

Anyone else having WinUAE keyboard problems with Windows ME?
Toni Wilen is offline  
Old 24 December 2002, 23:08   #5
LordBug
Registered User
LordBug's Avatar
 
Join Date: Jul 2002
Location: Someplace
Posts: 88
Turn on Logging, and illegal mem access logging (both under Misc). You should have something that appears like I have below.

As a side note to Toni, Trying this exact same config setup hardlocks my PC in 22R4. Works fine in 22R3. I don't want to derail this thread with that, so I'll PM you or start a new thread (your call, lemme know).


This is a stock OS3.0 Workbench setup, booting off an HDF file.

WinUAE 0.8.22, Release 3
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2002 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2001 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
Follow sprite mode set
No disk in drive 0.
Resetting frame rate hack
Building CPU table for configuration: 68020/881
1866 CPU functions
Building CPU function table (3 0 0).
Max CPUID level=1 Processor is AuthenticAMD
have_cmov=1, have_rat_stall=0
Setting signal handler
Building Compiler function table
Ct: 00000004, picasso_vidinfo.selected_rgbformat 00000000
Don't care mouse mode set
set_ddraw() called, and is 800x600@8-bytes
OpenGL extensions: GL_ARB_depth_texture GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_program GL_ARB_window_pos GL_S3_s3tc GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_vertex_weighting GL_HP_occlusion_test GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_WIN_swap_hint WGL_EXT_swap_control
OPENGL: using texture depth 16 texture size 1024 * 1024 scanline texture size 1024 * 1024
Using primary buffer (32768 bytes)
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 44100 Hz, buffer is 24576 bytes, distance 8192 bytes, Primary buffer
Resetting frame rate hack
PAL mode, 50Hz
Illegal lput at 00200000
Illegal wget at 00f10000
Illegal wget at 00f10002
Illegal wget at 00f10004
Illegal wget at 00f10006
Illegal wget at 00f10008
Illegal wget at 00f1000a
Illegal wget at 00f1000c
Illegal wget at 00f1000e
Illegal wget at 00f10010
Illegal wget at 00f10012
Illegal wget at 00f10014
Illegal wget at 00f10016
Illegal wget at 00f10018
Illegal wget at 00f1001a
Illegal wget at 00f1001c
Illegal wget at 00f1001e
Illegal wget at 00f10020
Illegal wget at 00f10022
Illegal wget at 00f10024
Fastmem (32bit): mapped @$10000000: 32 MB Zorro III fast memory
Card 1 (ZorroIII) done.
UAEGFX-card: mapped @$12000000
Card 2 (ZorroIII) done.
Filesystem: mapped memory @$e90000.
Card 3 (ZorroII) done.
Byte put to custom register DFF110.
warning: Program does not wait for blitter 00FAAE76
SetSwitch() - trying to show picasso96 screen
Ct: 00000004, picasso_vidinfo.selected_rgbformat 00000004
ignored overlay because desktop depth == requested depth (16)
DDRAW: Primary surface created in video-memory
DDRAW: Secondary surface created in video-memory
try_surface_locks() returning secondary
set_ddraw() called, and is 800x600@16-bytes
Window mode (bits: 16, pixbytes: 2)
SetSwitch() from threadid 1000 - showing picasso96 screen
WinUAE now inactive via WM_ACTIVATE
DirectSound driver freed
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 44100 Hz, buffer is 24576 bytes, distance 8192 bytes, Secondary buffer
WinUAE now active via WM_ACTIVATE
DirectSound driver freed
Using primary buffer (32768 bytes)
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 44100 Hz, buffer is 24576 bytes, distance 8192 bytes, Primary buffer
DMACON: 23f0 INTENA: 602c INTREQ: 60 VPOS: 0 HPOS: 2
COP1LC: 00000420, COP2LC: 00000758
DIWSTRT: 0181 DIWSTOP: 0281 DDFSTRT: 0018 DDFSTOP: 0020
BPLCON0: 0303 BPLCON1: 0000 BPLCON2: 0024
Average frame time: 19.803371 ms [frames: 712 time: 14100]
DirectSound driver freed

Last edited by LordBug; 25 December 2002 at 01:52.
LordBug is offline  
Old 24 December 2002, 23:22   #6
Simon S
 
Posts: n/a
Question

Hmm, it does complain about illegal operations. This is my usual setup.
-------------------------------------------------------


WinUAE 0.8.22, Release 4
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2002 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2001 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
shmget of size 16777216 for z3
shmget of size 65536 for filesys
shmget of size 524288 for kick
shmget of size 2097152 for chip
Follow sprite mode set
No disk in drive 0.
Resetting frame rate hack
Building CPU table for configuration: 68040
1866 CPU functions
Building CPU function table (4 0 0).
Max CPUID level=1 Processor is AuthenticAMD
have_cmov=1, have_rat_stall=1
JIT: Setting signal handler
JIT: Building Compiler function table
Ct: 00000009, picasso_vidinfo.selected_rgbformat 00000000
WinUAE now active via WM_ACTIVATE
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
DDRAW: Primary surface created in video-memory
DDRAW: Secondary surface created in video-memory
CreateOverlaySurface being called with 8-bits!
set_ddraw: Couldn't CreateOverlaySurface(648,516,8) because 88760091 S=1 F=0876 C=0091 (145) (Device doesn't support requested pixel format).
Don't care mouse mode set
WinUAE now inactive via WM_ACTIVATE
DirectSound driver freed
Primary buffer size smaller than requested (98304 > 32768), using secondary
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
using desktop depth (8 -> 32) because not using overlay or opengl mode
ignored overlay because desktop depth == requested depth (32)
WinUAE now active via WM_ACTIVATE
DirectSound driver freed
Primary buffer size smaller than requested (98304 > 32768), using secondary
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
DDRAW: Primary surface created in video-memory
DDRAW: Secondary surface created in video-memory
try_surface_locks() returning secondary
set_ddraw() called, and is 648x516@32-bytes
Window mode (bits: 32, pixbytes: 4)
Resetting frame rate hack
PAL mode, 50Hz
Illegal lput at 00200000
Illegal wget at 00f11000
Illegal wget at 00f11002
Illegal wget at 00f11004
Illegal wget at 00f11006
Illegal wget at 00f11008
Illegal wget at 00f1100a
Illegal wget at 00f1100c
Illegal wget at 00f1100e
Illegal wget at 00f11010
Illegal wget at 00f11012
Illegal wget at 00f11014
Illegal wget at 00f11016
Illegal wget at 00f11018
Illegal wget at 00f1101a
Illegal wget at 00f1101c
Illegal wget at 00f1101e
Illegal wget at 00f11020
Illegal wget at 00f11022
Illegal wget at 00f11024
Fastmem (32bit): mapped @$10000000: 16 MB Zorro III fast memory
Card 1 (ZorroIII) done.
Filesystem: mapped memory @$e90000.
Card 2 (ZorroII) done.
Byte put to custom register DFF110 PC=00FAABB4
warning: Program does not wait for blitter 00FAAE76
FS: mounted HDF unit DH0:0
FS: mounted HDF unit DH1:1
FS: mounted virtual unit DH2:2
PTEST
PAL mode, 58Hz
PAL mode, 50Hz
WinUAE now inactive via WM_ACTIVATE
DirectSound driver freed
Primary buffer size smaller than requested (98304 > 32768), using secondary
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
WinUAE now active via WM_ACTIVATE
DirectSound driver freed
Primary buffer size smaller than requested (98304 > 32768), using secondary
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
WinUAE now inactive via WM_ACTIVATE
DirectSound driver freed
Primary buffer size smaller than requested (98304 > 32768), using secondary
DirectSound driver 'Primary Sound Driver' found and configured for 16 bits at 48000 Hz, buffer is 49152 bytes, distance 16384 bytes, Secondary buffer
DMACON: 23f0 INTENA: 602c INTREQ: 60 VPOS: 0 HPOS: 3
COP1LC: 00001020, COP2LC: 00028928
DIWSTRT: 2b82 DIWSTOP: 2bc2 DDFSTRT: 0038 DDFSTOP: 00d8
BPLCON0: e303 BPLCON1: 0011 BPLCON2: 0224
Average frame time: 20.114723 ms [frames: 1046 time: 21040]
DirectSound driver freed
 
Old 25 December 2002, 10:04   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,657
Unfortunately log doesn't reveal anything interesting. (and those illegal wget-messages are normal)

Can you test with other manufacturer's keyboard?
Toni Wilen is offline  
Old 29 December 2002, 15:34   #8
efcee
 
Posts: n/a
keyboard

i have the same problem using my athlon xp laptop i can use alt-tab but the keyboard isnt usable
kind regards
 
Old 25 May 2003, 12:45   #9
Conan
 
Posts: n/a
Re: keyboard

Quote:
Originally posted by efcee
i have the same problem using my athlon xp laptop i can use alt-tab but the keyboard isnt usable
kind regards
Hello, well i have the same problem with Windows XP and WinUAE. My keyboard doesn't respond while playing a game. Very frustrating. When a games ask me to fire, every key seems to be the firebutton. Very strange. Has anyone have a solution for us??????
 
Old 26 May 2003, 11:29   #10
Simon S
 
Posts: n/a
Yup, I had tried WinUAE with the old keyboard I got with my PC, and it still has the same no response problems. All keys are disabled except Alt-tab (and Ctrl-Alt-Del obviously).

Unfortunatly I've no idea who made that keyboard so I guess it's not too useful as a bug report.

Good luck tracking down this bug, but no amount of messing with my config seems to help.

Both keyboards are just plugged straight into the regular keyboard port (the little purple ps/2 port) and I haven't had the opportunity to try it out with a USB keyboard.
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
CF Boots fine in WinUAE - NON-DOS DH0: Error in A1200 Nostromo support.Hardware 43 12 April 2013 17:39
Caligari Dies Pyromania Amiga scene 16 25 August 2009 08:30
Arthur C Clarke dies at 90 Belgarath Nostalgia & memories 24 10 April 2008 18:25
Marble Madnes dies harry support.WinUAE 20 09 January 2003 17:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:03.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.16249 seconds with 11 queries