English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 April 2015, 13:32   #1
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 473
HALT3 crash beta 3.1.0

I get this HALT3 crash when I compiled netsurf aga with clib2.
Ixemul version works ok.

It would help to know what that error means, thanks.

BTW.
There seem to be problem with mounting folder as harddrive.
Lots of
PHP Code:
50-889 [221 223-190]: Mounting uaehf.device 15 (13095) (size=0):
50-889 [221 223-190]: failedblocksize == 
lines in log.txt
which is 100MB!
arti is offline  
AdSense AdSense  
Old 26 April 2015, 13:50   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,565
Your log contains multiple different configurations loaded and restarted, from different days, including PPC setup and AROS ROM, all kinds of invalid accesses and son. Makes no sense whatsoever.

Never use RESTART option when creating log files or testing something.

HALT 3 = CPU attempted to execute code from non-existing memory. Usual cause is application crash/memory corruption, stack overflow etc.
Toni Wilen is online now  
Old 30 May 2015, 23:57   #3
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 473
I enabled window logging and get more info.

"Your Amiga program just did something terribly stupid FFFFFFC4 PC=4255D548
FFFFFFA4 Illegal wget at ffffffa4 PC=4255d548"

Has this something to do with wget program ?
Attached Files
File Type: txt log.txt (22.0 KB, 80 views)
File Type: txt winuaebootlog.txt (11.5 KB, 52 views)
File Type: txt winuaelog.txt (6.0 KB, 54 views)
arti is offline  
Old 31 May 2015, 00:05   #4
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 473
With segtracker enabled output looks different.

Code:
Your Amiga program just did something terribly stupid FFFFFFC4 PC=4259ED98
FFFFFFA4  0000 0000 0000 0000 0000 0000 0000 0000
FFFFFFB4  0000 0000 0000 0000 0000 0000 0000 0000
FFFFFFC4  0000 0000 0000 0000 0000 0000 0000 0000
FFFFFFD4  0000 0000 0000 0000 0000 0000 0000 0000
FFFFFFE4  0000 0000 0000 0000 0000 0000 0000 0000
4259ED78  ECF6 4259 ED0B 4259 ED35 0000 518F 48E7
4259ED88  3C22 246F 0024 2C79 417C 24FC 41EF 0018
4259ED98  4EAE FFC4 222F 0018 4282 4C7C 0000 0000
4259EDA8  03E8 2F00 5BC3 49C3 2F03 2801 2A02 8AAF
4259EDB8  0024 2F05 2F04 4EB9 4284 E7FC DEFC 0010
arti is offline  
Old 31 May 2015, 00:21   #5
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 473
Without JIT , enforcer caught hit. Looks like something wrong with timer.

Code:
Enforcer Hit! Bad program
Illegal WORD READ from: 0000000e                PC: 0000000e
Data: 556a4347 00000000 00000000 00000000 00000001 00000005 425baaac 00000000
Addr: 4187ce80 425baaac 4187ceec 42863a8c 41bae410 4187cf18 00000000 4187ce64
Stck: 00000000 00000000 00000001 00000005 42861444 41c3051c 0000000b 00000a7f
Stck: 4233622c 4187ceec 556a43c3 00070d37 00000014 00000000 00000000 00000000
Stck: 41bb1710 41c30470 4286191a 4187cf18 4286191a 00fc17a0 556a43c3 00070d37
Stck: 00000001 00019999 41c30518 42864af2 41c30470 4230320c 4187cf64 00000000
Stck: 000003e8 00000000 00000000 42384606 00000000 4238457c 00000001 42383acc
----> 00fc17a0 - "ROM - timer 39.4 (29.7.92)" Hunk 0000 Offset 00000cd8
----> 00f9f86a - "ROM - dos 40.3 (1.4.93)" Hunk 0000 Offset 000005ae
0000000e : * a35e                 ILLEGAL.L
00000010 :   4fff                 ILLEGAL.L
00000012 :   a322                 ILLEGAL.L
00000014 :   4fff                 ILLEGAL.L
00000016 :   a324                 ILLEGAL.L
00000018 :   4fff                 ILLEGAL.L
0000001a :   a326                 ILLEGAL.L
0000001c :   4fff                 ILLEGAL.L
0000001e :   a328                 ILLEGAL.L
Name: "NetSurfAGA"

Enforcer Hit! Bad program
Illegal LONG WRITE to: 00000100                 PC: 4165f87e
Data: 8000000a 00000000 00000000 00000000 00000001 00000005 425baaac 8000000a
Addr: 4187ce80 425baaac 4187ceec 42863a8c 4000236a 4165f86a 400008f4 40002238
Stck: a45c0020 4165f812 8000000a 00000000 00000000 00000000 4107a894 00000000
Stck: 4166d04c 4184bf20 41618104 8000000a 41662939 41618585 416186d0 0000000e
Stck: 00000000 00000000 00000000 00000000 00000000 425baac4 00000000 00000000
Stck: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Stck: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000001
----> 00fa4dda - "ROM - dos 40.3 (1.4.93)" Hunk 0000 Offset 00005b1e
----> 00fa4ebe - "ROM - dos 40.3 (1.4.93)" Hunk 0000 Offset 00005c02
4165f864 :   4000                 NEGX.B D0
4165f866 :   588f                 ADDA.L #$00000004,A7
4165f868 :   4e73                 RTE.L
4165f86a :   4e7a 2003            MOVEC2.L #$2003
4165f86e :   2602                 MOVE.L D2,D3
4165f870 :   0882 000f            BCLR.L #$000f,D2
4165f874 :   4e7b 2003            MOVE2C.L #$2003
4165f878 :   23c0 0000 0100       MOVE.L D0,$00000100
4165f87e : * 4e7b 3003            MOVE2C.L #$3003
4165f882 :   4e73                 RTE.L
4165f884 :   42a7                 CLR.L -(A7)
4165f886 :   f017                 ILLEGAL.L
4165f888 :   4200                 CLR.B D0
4165f88a :   2417                 MOVE.L (A7),D2
4165f88c :   0897 0007            BCLR.B #$0007,(A7)
4165f890 :   f017                 ILLEGAL.L
4165f892 :   4000                 NEGX.B D0

Is there any way to trace the source of this crash?
arti is offline  
Old 31 May 2015, 01:20   #6
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,535
Send a message via MSN to FOL Send a message via Skype™ to FOL
Im getting Halt 3 everytime I make a copy of a something on the same HDD.
Will have to get some logs when I next fire up WinUAE.
FOL is offline  
Old 31 May 2015, 08:14   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,565
Quote:
Originally Posted by FOL View Post
Im getting Halt 3 everytime I make a copy of a something on the same HDD.
Will have to get some logs when I next fire up WinUAE.
Check stack size. Too small stack is the most common cause for crashes.
Toni Wilen is online now  
Old 01 June 2015, 02:00   #8
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,535
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by Toni Wilen View Post
Check stack size. Too small stack is the most common cause for crashes.
I always set it to 8192 in workbench.
FOL is offline  
Old 01 June 2015, 09:32   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,565
8192 is too small for deep recursive copy.
Toni Wilen is online now  
Old 01 June 2015, 09:48   #10
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,535
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by Toni Wilen View Post
8192 is too small for deep recursive copy.
1 File is hardly deep recursive.
Even does it with 1 folder with a few files in it.

I have to copy to another drive then back to where I want it.
FOL is offline  
Old 01 June 2015, 09:52   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,565
Then start including proper testing information, instead of "it does not work when I do this.". Only possible answer is "don't do it."

For example:
- try some other copy command from another WB disk version.
- set stack to some huge value temporarily
- boot without startup-sequence and try again
- boot with setpatch only and so on.

Usual Amiga debugging stuff.

- check log for full halt reason.
Toni Wilen is online now  
Old 01 June 2015, 12:42   #12
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,535
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by Toni Wilen View Post
Then start including proper testing information, instead of "it does not work when I do this.". Only possible answer is "don't do it."

For example:
- try some other copy command from another WB disk version.
- set stack to some huge value temporarily
- boot without startup-sequence and try again
- boot with setpatch only and so on.

Usual Amiga debugging stuff.

- check log for full halt reason.
As I said, when I next fire it up I will get logs. I did not say "it does not work when I do this."
FOL is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5.30 to 2.4.1 crash... mjnurney support.FS-UAE 3 10 April 2015 13:04
WinUAE 2.8.1 Crash Saghalie support.WinUAE 1 06 November 2014 08:12
another WinUAE 1.5.1 crash jharrison support.WinUAE 4 04 September 2008 16:53
1.0 Crash Methanoid support.WinUAE 0 20 June 2005 23:08
crash?? Unregistered support.WinUAE 2 31 May 2001 14:32

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:15.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.22166 seconds with 12 queries