English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 12 April 2015, 18:22   #1
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Strange side effect on screen in Workbench

Hello. I have strange side effect when using Workbench after closing Personal Paint (AmigaOS 3.X from Amiga Forever). Getting the same issue with winuae_3100b15 and official 3.0.0. too.
PS. Tried different native and rtg filter settings (no scaling, overscan blanking and default) without success.
Note that i'm using Full-window display settings, because on Windows 10 build 10049 i have endless black screen and system freeze when settings are Fullscreen (strange too)...
EDIT: I have found that this is happening when using UAE Zorro III (*) / Picasso RTG mode (and not when closing Personal Paint only, but very random). On native AGA everything is ok.
Attached Thumbnails
Click image for larger version

Name:	screenshot.jpg
Views:	161
Size:	290.2 KB
ID:	43957  
Attached Files
File Type: zip winuae_debug.zip (216.0 KB, 31 views)

Last edited by Snake79; 12 April 2015 at 21:47.
Snake79 is offline  
AdSense AdSense  
Old 12 April 2015, 22:53   #2
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Ok, i have found a sollution: i have changed RTG from UAE Zorro III (*) to Picasso IV Zorro II, reinstalled Picasso drivers under Workbench (from http://aminet.net/package/driver/video/Picasso96) choosing Picasso IV (not uaegfx) and then the problem has gone.
Snake79 is offline  
Old 13 April 2015, 19:19   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,564
I can't duplicate. Are you sure it isn't windows 10/display driver bug? (It seems there is driver compatibility problems with windows 10 builds which is normal in early versions)

Using PicassoIV (or any other "real" board) is not that good solution, they have very restricted VRAM size and resolutions.
Toni Wilen is online now  
Old 13 April 2015, 19:46   #4
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Quote:
Originally Posted by Toni Wilen View Post
I can't duplicate. Are you sure it isn't windows 10/display driver bug? (It seems there is driver compatibility problems with windows 10 builds which is normal in early versions)
You're right. I have downloaded latest nvidia driver (350.12 released today), installed it and everything is back to normal. I can do fullscreen (without black-screen freeze) and that graphical glitch is gone too when using uaegfx. Thanks.
Snake79 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need explanation of a demo effect - screen zoom/rotate Dunny support.Demos 7 06 August 2012 09:04
Strange graphic effect with CD32 demodisc 2.0 a4k-oerx support.WinUAE 2 24 November 2008 19:00
Strange effect in Resolution: Lores, Line-Mode: Normal a4k-oerx support.WinUAE 1 13 November 2008 19:27
[Found: Barbarian 2 - Palace] laughing skeleton came on the side of the blank screen PiAnt Looking for a game name ? 2 30 October 2007 21:07
Selection-screen Global Effect Tim Janssen support.Games 15 18 October 2002 08:33

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:15.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.14526 seconds with 12 queries