English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 17 March 2015, 09:13   #1
Zerotech
Registered User
Zerotech's Avatar
 
Join Date: Jul 2013
Location: Melbourne, Australia
Age: 37
Posts: 59
Send a message via Skype™ to Zerotech
Just got an Amiga 500 for review, sort of...

Youtube: [ Show youtube player ]

Well I did get a hold of an amiga 500 but the top case had been damaged during transit and the floppy plastic clip was also broken so i super glued it.

I have since ordered another top case on ebay, I might also need to get a new floppy as well as the problem is it wont insert when powered off.

The floppy drive is a Chicon drive.

I will need to get a hold of an UK/AU power adapter for it to test, from disassembling it it was a bit dusty but nothing seems to be physically damaged so I think it will work.
Zerotech is offline  
AdSense AdSense  
Old 17 March 2015, 13:15   #2
Zerotech
Registered User
Zerotech's Avatar
 
Join Date: Jul 2013
Location: Melbourne, Australia
Age: 37
Posts: 59
Send a message via Skype™ to Zerotech
I am a little upset over the broken top case in particular more than the disk drive clip being broken.

I have since ordered one and requested to get the original amiga 500 logo. It would be silly to get an amiga 500 plus case onto a a500 computer.

My review will have to take a while until I get a hold of the case and an uk/eu to aus power adapter.
Zerotech is offline  
Old 17 March 2015, 13:48   #3
Hewitson
Registered User
Hewitson's Avatar
 
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 35
Posts: 2,235
I wouldn't bother with an adapter, just cut the old plug off and put a new one on.
Hewitson is offline  
Old 19 March 2015, 09:24   #4
Zerotech
Registered User
Zerotech's Avatar
 
Join Date: Jul 2013
Location: Melbourne, Australia
Age: 37
Posts: 59
Send a message via Skype™ to Zerotech
Update: [ Show youtube player ]

I recently got myself the power adapters, Good thing the amiga works.

2 issues I am having, the sound screeching when turned on, this is probably due to RF interference signals affecting the rf shield and the floppy drive is jammed I cannot insert floppy disks.

What I will need to do are to get 2 parts and hopefully soon I will have a working amiga 500 for review.
Zerotech is offline  
Old 19 March 2015, 11:35   #5
roy bates
Registered User
 
Join Date: Apr 2011
Location: birmingham
Age: 49
Posts: 2,824
there is colour composite out on the 520 mate...
you have no sound going into the 520,no cable connected.

the rf shield is already there,so im not sure what you mean in the video.


as for the floppy,try to take it apart and grease it,there is two switch's and they might need switch cleaner on them.
and its probably full of crap and dust and so needs cleaning.

Last edited by roy bates; 19 March 2015 at 11:44.
roy bates is offline  
Old 19 March 2015, 13:16   #6
Zerotech
Registered User
Zerotech's Avatar
 
Join Date: Jul 2013
Location: Melbourne, Australia
Age: 37
Posts: 59
Send a message via Skype™ to Zerotech
Ok I have switched the cables to colour composite AV and it seems the sound issue screechings are eliminated, as for the floppy I guess that doesn't hurt to tear it apart and see if I can attempt to fix it up.

The rf shield is on so that I can get rf signal video without it you cant get anything in the video.

I'm not concerned about the sound at this point, however I am getting the audio cable soon so don't worry about it right now, what I am more interested is to power on and see if the unit works.
Zerotech is offline  
Old 20 March 2015, 02:56   #7
Nobby_UK
Registered User
Nobby_UK's Avatar
 
Join Date: Jul 2013
Location: Liverpool
Posts: 838
Quote:
Originally Posted by Zerotech View Post
The rf shield is on so that I can get rf signal video without it you cant get anything in the video.

Huh ?
Most of us throw the shielding away ASAP
Nobby_UK is offline  
Old 26 March 2015, 16:13   #8
Obliterator
Registered User
Obliterator's Avatar
 
Join Date: Jan 2011
Location: Perth Western Australia
Age: 42
Posts: 89
I ditched my shielding it bit me when I wasn't paying attention while removing it to fit my Indivision ECS there was blood drawn so it went into the bin the shielding not the Amiga :P
Obliterator is offline  
Old 26 March 2015, 20:31   #9
IanP
Registered User

 
Join Date: Mar 2015
Location: Bristol/UK
Posts: 121
Quote:
Originally Posted by Zerotech View Post
Ok I have switched the cables to colour composite AV and it seems the sound issue screechings are eliminated, as for the floppy I guess that doesn't hurt to tear it apart and see if I can attempt to fix it up.

The rf shield is on so that I can get rf signal video without it you cant get anything in the video.

I'm not concerned about the sound at this point, however I am getting the audio cable soon so don't worry about it right now, what I am more interested is to power on and see if the unit works.
If your TV has an RGB SCART input an Amiga to RGB SCART lead will give the best picture quality and can include stereo audio. When you super glued the floppy did you get any glue around the eject button as that could prevent you inserting a disk if the eject button isn't free to move out.
IanP is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 500 and gvp 500 hd advise.. 0Danne0 support.Hardware 5 27 February 2014 13:15
New Amiga user (sort of) mikepxavier New to Emulation or Amiga scene 18 06 August 2012 07:05
Compatibility with Amiga 500 and 500+ games ErickDF Amiga scene 2 23 May 2008 21:16
WTB: Amiga 600, 500, 500 +, 1200 (NTSC) JeremyDay MarketPlace 2 30 November 2006 04:27
Amiga OS XL review LaundroMat Amiga scene 2 06 February 2002 17:05

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:25.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23890 seconds with 11 queries