English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 06 March 2015, 11:03   #1
selco
Registered User
 
Join Date: Aug 2013
Location: Germany
Posts: 41
WinUAE-Debuuger: Memwatchpoint and AUTOCONFIG

Hi Toni,
while trying to look closer into the Autoconfig mechanism I tried to set a memwatch point to catch access to the ZorroII Autoconfig area.

That does not work, the access does not stop the emulation.
(I have 1 MByte Z2 Fast Mem configured)
The memwatchpoint even makes this fastmem diasppear! Removing the watchpoint make the extra mem re-appear again.

Here is what I did:

Code:
WinUAE 3.0.0 (2114.12.17) Jit off, cycle exact, A1200 3.1 ROM

New Start

<Boot Animation>

Shift F12

TM
00200000 10 0 expansion memory
Attributes 0605 First 00214620 Lower 00200020 Upper 00300000 Free 964552
 00214620: 00214620-00214658,00214870,00000038 (56)
 00214870: 00214870-00300000,00000000,000eb790 (964496)

00000400 10 -10 chip memory
Attributes 0703 First 000007d8 Lower 00000420 Upper 00200000 Free 1908784
 000007d8: 000007d8-000009d0,00000c90,000001f8 (504)
 00000c90: 00000c90-00000dd8,0002e310,00000148 (328)
 0002e310: 0002e310-00200000,00000000,001d1cf0 (1907952)


w 0 e80000 100
 0: 00E80000 - 00E800FF (256) RWI CPU
 
g

CTRL-A-A


<should stop when doing Autoconfig but goes to Boot Animation>

Shift F12

TM
00000400 10 -10 chip memory
Attributes 0703 First 0003c8b8 Lower 00000420 Upper 00200000 Free 1841296
 0003c8b8: 0003c8b8-0003c8f0,0003cfa8,00000038 (56)
 0003cfa8: 0003cfa8-001fe800,00000000,001c1858 (1841240)

--> expansion memory disappeared


w 0
Memwatch 0 removed

g


CTRL-A-A

<Boot Animation>

Shift F12

TM
00200000 10 0 expansion memory
Attributes 0605 First 00214620 Lower 00200020 Upper 00300000 Free 964552
 00214620: 00214620-00214658,00214870,00000038 (56)
 00214870: 00214870-00300000,00000000,000eb790 (964496)

00000400 10 -10 chip memory
Attributes 0703 First 000007d8 Lower 00000420 Upper 00200000 Free 1908784
 000007d8: 000007d8-000009d0,00000c90,000001f8 (504)
 00000c90: 00000c90-00000dd8,0002e310,00000148 (328)
 0002e310: 0002e310-00200000,00000000,001d1cf0 (1907952)

-> expansion Mem is back

Best regards
selco
selco is offline  
AdSense AdSense  
Old 07 March 2015, 20:12   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Possibly fixed in next beta. It isn't really designed to work with memory "banks" that move around.
Toni Wilen is online now  
Old 16 March 2015, 10:19   #3
selco
Registered User
 
Join Date: Aug 2013
Location: Germany
Posts: 41
Just tested with WinUAE 3.1.0 Beta 12.
-> Works!

Thanks Toni, its very much appreciated!

Best regards Alexander
selco is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Local slot autoconfig - how? Heiroglyph Hardware mods 13 14 August 2011 15:17
Amiga 2000 autoconfig prob Scarab support.Hardware 5 04 March 2005 16:14
OS 3.9 romupdate causes autoconfig data to dissapear, how to resolve that? keropi support.Hardware 3 17 January 2005 16:46
WinUAE 0.9.92 "WinUAE 1.0 public beta #3" Released! Jim News 2 23 December 2004 11:29
WinUAE 0817r3-GUI dissappears/ WinUAE freezes. 7-Zark-7 support.WinUAE 2 23 December 2001 14:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:48.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12181 seconds with 11 queries