English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 22 December 2014, 14:19   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,479
Booting NetBSD fails since 2900b16

Testing my NetBSD 6.0.1 HDF with WinUAE 3.0.0 (A3000/040 config), it starts to boot then emulation locks up using 100% host CPU. I can't un-capture mouse and pressing F12 doesn't open the settings window. Output in log:
CPU halted: reason = 1

With WinUAE 2.8.1 the HDF boots okay. I checked some 2.8.2/2.9.0/3.0.0 betas and it boots with 2900b15, fails with 2900b16. The only maybe-related thing in the b16 changelog:
- 68040 MMU MOVE16 fault size was wrong. (Cache line, not long)

HDF (83.9MB), you might already have it:
hxxp://www.4!s!h!a!r!e!d.com/file/kfNmf5cG/NetBSD_4GB_HD_after_install_A3.html
(Copy and paste, change hxxp to http and remove all ! from URL. Have to do that due to the stupid EAB link policy... )
Attached Files
File Type: zip NetBSD_install_A3000_040.uae.zip (2.9 KB, 75 views)
mark_k is offline  
AdSense AdSense  
Old 22 December 2014, 16:26   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,524
It was undocumented MOVEM fault change that was wrong and I think it was only a test which should have been removed..
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
NetBSD/Amiga gibs New to Emulation or Amiga scene 82 06 September 2017 17:22
NetBSD 6.0 released! strim News 2 19 October 2012 01:44
NetBSD 68k megabyte support.Apps 1 27 June 2012 12:30
WinUAE 2.3.0 + NetBSD 5.0.2 No go. ahhyes support.WinUAE 71 15 November 2010 09:29
NetBSD 5.0 shortwind support.WinUAE 6 03 October 2009 13:53

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:51.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11813 seconds with 12 queries