English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 09 December 2014, 16:33   #1
Ami_GFX
Registered User
 
Join Date: Sep 2011
Location: USA North America
Posts: 179
D3D point/bilinear setting trouble

EDIT: Moved from beta thread.

Quote:
Originally Posted by Toni Wilen View Post
Enable bilinear filtering (in Filter panel). D3D has it optional, DD forces it (for some stupid reason). Or use some D3D shader filter.

D3D is the only one available when using RTG hardware emulation, you only got DD accidentally because you didn't have working D3D.



More advanced emulated hardware options: need to use more advanced other options too



This could be caused by VRAM limit. You probably used higher resolution&color depth vs your real hardware.

I'm using the same screen resolution as my real Amiga, 800x600. All I did was make an image file of the HD and change from a Cybervision 64 to PicassoIV monitor file.

I see Point/Bilinear in the filter panel under extra settings. There is no enable/disable. In the filter settings on top of the panel for RTG modes, all I get is Null filter and none. If I set the scaling to "No Scaling" I get the look I want but it messes with the display settings. I have to change the display from the native display to the size of the Amiga display to get things to work right.

Using the older version of DirectX, I can use Direct Draw with RTG emulation. No real issues except for the small boot screen and the nag screen to update DirectX.

Last edited by Toni Wilen; 12 December 2014 at 12:35.
Ami_GFX is offline  
AdSense AdSense  
Old 09 December 2014, 18:29   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,531
Quote:
Originally Posted by Ami_GFX View Post
I see Point/Bilinear in the filter panel under extra settings. There is no enable/disable. In the filter settings on top of the panel for RTG modes, all I get is Null filter and none. If I set the scaling to "No Scaling" I get the look I want but it messes with the display settings. I have to change the display from the native display to the size of the Amiga display to get things to work right.
Slider under the checkbox adjusts it. (I know, not very intuitive...)
Toni Wilen is offline  
Old 10 December 2014, 15:05   #3
Ami_GFX
Registered User
 
Join Date: Sep 2011
Location: USA North America
Posts: 179
The slider won't move if Point/Bilinear is selected. I can change the ratios in the box next to it.

If I select "No Scaling" with the display set to "Native", I get an oversized control box when I push F12. The box won't move as I move the cursor and I can't get to the bottom of it which has the main control buttons. If I select the same resolution as the Amiga, I get the same screen but it moves with the cursor. The problem with this configuration is changing Amiga screen modes within the emulation. I have to change the display tab to match the Amiga resolution for RTG modes.

If I don't have DirectX updated and the emulation goes into Direct Draw, I get a small sized control box that is at the native resolution of the host computer. In this case I have "default" selected instead of "No Scaling"

In all three cases, the resulting display is visually the same.
Ami_GFX is offline  
Old 10 December 2014, 15:20   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,531
Quote:
Originally Posted by Ami_GFX View Post
The slider won't move if Point/Bilinear is selected. I can change the ratios in the box next to it.
Did you move it far enough? It has only 2 settings: fully leftmost and fully rightmost when point/bilinear is selected. Easier is to click on the the middle of the line (not the slider itself) to toggle it.
Toni Wilen is offline  
Old 10 December 2014, 20:23   #5
Ami_GFX
Registered User
 
Join Date: Sep 2011
Location: USA North America
Posts: 179
Now I see, it doesn't move at all when I try to drag it, I have to click on one side of it.

Changing it has no effect on the display. If I enable scaling, I get the jagged fonts. I only get a smooth display with scaling disabled.
Ami_GFX is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pre-Scaling before Bilinear Scaling? rsn8887 request.UAE Wishlist 6 05 September 2015 19:13
Trouble Setting up Transcend 4GB IDE Flash Disk mfletcher support.Hardware 15 07 January 2014 11:22
Ffe D3d synchro Retrogaming General Discussion 0 22 November 2012 13:19
Trouble setting up SCSI CD RW with CSMK3 CU_AMiGA support.Hardware 3 05 August 2008 16:51
D3d bug? Ultron support.WinUAE 1 08 August 2006 16:51

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:21.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23471 seconds with 11 queries