English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 05 October 2014, 12:53   #1
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
Sound on = stuttering

I have been fiddling with WinUAE settings and just can't get it right, I can make (for example old demos) it run smoothly but only when the sound is disabled. Every time I switch the sound on, it is jerking / stuttering.

For example, if I watch an old Amiga intro that has a scroller. It scrolls from right to left smoothly but while the music is playing it stutters a lot.

I have tested WinUAE 2.51 and the latest 2.81 and both give me similar results.

Nothing I've tried helps:
- CPU emulation speed - Fastest / Approximate
- More compatible
- Immediate blitter / wait for blitter
- VSync on / off - Different resolutions and framerates
- Double/triple/no buffering
- Different sound settings, from lowest to highest frequency etc.

I'm starting to wonder if this stuff needs such an amount of processing power or something else, that my computer is not powerful enough. Or maybe there is something with my onboard soundcard etc. that this emulator doesn't like?

My setup is:
i3-3225
ASUS P8B75-M LX Plus motherboard
8gb RAM
nVidia 650 Ti 2gb gfx card
Win7 64bit
ACER X223W 22" display

One would assume that my system, while not being among the fastest, would be good enough(?)

It is weird, everything runs just fine when the sound is disabled but once I enable it, comes the stuttering.


Edit: Noticed this, every time I start it again it works smoothly for a few seconds, then it starts, as if some buffer gets full or something. When I keep it on for 5 mins it gets slower, slower, slower and finally halts to a crawl. Like it uses more and more and more of CPU or collects some carbage somewhere. When the sound is disabled it can run happily for as long as I want.

Any idea what should I try next? Thank you.

Last edited by hnn; 05 October 2014 at 13:09.
hnn is offline  
AdSense AdSense  
Old 05 October 2014, 13:11   #2
s2325
Zone Friend

s2325's Avatar
 
Join Date: Jun 2006
Location: Gargore
Age: 37
Posts: 17,542
Try turning off cycle-exact option.
s2325 is online now  
Old 05 October 2014, 13:17   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
Cycle-exact should make no difference with any modern system. (and if it does, problem is still somewhere else)

Sounds like a driver bug, make sure it is up to date. Does both directsound and wasapi modes have same problem? (in sound card selection menu). Another possibility is very aggressive power saving but it shouldn't affect desktops.

Attach also logs. (both logs).
Toni Wilen is online now  
Old 05 October 2014, 13:19   #4
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
When I put that on it almost stops, but it seems disabling it won't help either. It still stutters a lot when the music is playing.

I tried with Directsound and wasapi.
Attached Files
File Type: txt winuaebootlog.txt (20.5 KB, 52 views)
File Type: txt winuaelog.txt (9.5 KB, 37 views)

Last edited by hnn; 05 October 2014 at 13:38. Reason: Logs attached
hnn is offline  
Old 05 October 2014, 13:43   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
You have really old config file (huge amount of obsolete entries reported in winuaebootlog.txt). Remove it and start from scratch, it is _really_ ancient.

Run in windowed mode and check CPU% status, it should show low value (max 50% or so). Something is wrong if it stays above 100%.
Toni Wilen is online now  
Old 05 October 2014, 13:54   #6
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
I don't completely understand all of those, but I deleted the old logs and started from the scratch using "quickstart", not using one of the preset configurations I had on the list.

It again stutters a lot when the sound is on, but works perfectly fine when it is disabled.

I checked, according to taskmanager the CPU load never exceeds 20 percent.
hnn is offline  
Old 05 October 2014, 17:58   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
Bottom of window are SND and CPU values. SND should stay inside +-30% range and CPU should stay under 50% or so (at least when using 68000 non-fastest possible mode) and FPS should hover between 49-50. Take note of values and if they are "wrong": switch off sound, does CPU and FPS values change back to normal values?

Try switching Display panel buffer mode (double vs triple buffer).

Attach also winuaelog.txt using new config.
Toni Wilen is online now  
Old 05 October 2014, 18:54   #8
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
I feel dumb now not noticing those values before

Ok, with sound on:

SND Between -2 and +1
CPU 15%
FPS 49,8

With sound off:
CPU 15%
FPS 49,9

It seems to slightly jerk also with the sound off, but with sound on it is worse. The only way to make it smooth seems to be setting the screen windowed, and vsync on. But even then it is completely stuttery with the sound on.

Switching between buffer mode had no difference.

Here is the latest winuaelog.txt
Attached Files
File Type: txt winuaelog.txt (9.3 KB, 43 views)

Last edited by hnn; 05 October 2014 at 19:01.
hnn is offline  
Old 06 October 2014, 16:24   #9
onkelarie
Registered User

onkelarie's Avatar
 
Join Date: Aug 2004
Location: Spijkenisse / the Netherlands
Age: 47
Posts: 438
What works for me:

In display panel i set the sync to pal legacy. Also choose the correct monitor hz (most likely 60 if using lcd?)
onkelarie is offline  
Old 06 October 2014, 16:43   #10
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
Success !!

Funny thing is I think I tried these settings yesterday without success, maybe I didn't and just had a "senior moment"....

I used these:
Cycle exact
Windowed display - 59hz PAL (set my monitor to 59hz first)
Triple buffering
Legacy vsync

It seems I can also put my display to 60hz but WinUAE does not offer me the option 60hz PAL, only 60hz NTSC. But when I put it to that it works as well (only then it is slightly faster than normal).


EDIT: It seems it is always faster than normal. Now it is stutter free, but I just have to make it a little slower somehow. I was watching a couple of demos from Youtube and comparing them with my emulator, and my emulator shows them about 120-130% speed.

Last edited by hnn; 06 October 2014 at 17:08.
hnn is offline  
Old 06 October 2014, 17:44   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
You said in your first post that you tried without vsync. Do you really have same problem with vsync disabled?

VSync syncs whole emulation to selected refresh rate (which is the whole point of vsync), you only get "normal" speed with 50Hz (or 100Hz).
Toni Wilen is online now  
Old 06 October 2014, 18:11   #12
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
I tried again. With vsync off it is stuttering a lot but the music and everything run at normal speed.

When I enable vsync it runs very smoothly music and all, but faster than it should.

I set it to 60hz as my monitor runs on 60hz. Also tested 59hz. Later I tried to set my monitor to 50hz and try that but for some odd reason it does not stay that way, it switches back automatically.
hnn is offline  
Old 06 October 2014, 18:54   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
Weird. Does it become more stable if you disable vsync and then adjust FPS Adj. setting in chipset panel above 60? (for example 65) Ignore increased speed
Toni Wilen is online now  
Old 06 October 2014, 19:14   #14
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
It becomes more stable, as in no stuttering. But the sound goes bad, lots of static.
hnn is offline  
Old 06 October 2014, 23:32   #15
onkelarie
Registered User

onkelarie's Avatar
 
Join Date: Aug 2004
Location: Spijkenisse / the Netherlands
Age: 47
Posts: 438
@hnn, I completely feel your frustration. I used to struggle with the same problem for a long time as well. I did manage to solve it a few years ago and never used another configuration since.

So I'm now at home and checked my settings. I have in the display tab the following:

- Refresh rate (top right dropdown): Default refresh rate. This should set the rate to the default rate your videocard is at;
- In the settings section, I have set the screen to 'Native' (1920x1080 resolution in my case) with Legacy Sync selected;
- Last but not least, I use Triple buffering;

Funny thing is (Correct me if I'm wrong Toni), that with these settings it tries to run PAL emulation, despite the 60hz monitor framerate.

I always use the intro of Hybris to check if sound is running at the correct speed, I recognize it immediately when it's played at 60hz NTSC speed instead
onkelarie is offline  
Old 07 October 2014, 10:45   #16
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,560
This is really weird problem if SND% stays stable, it has to be some kind of driver or hardware incompatibility, especially if there are glitches even if sound buffer is max (with multi-second latency..).

Are you 100% sure you have up to date sound driver, not some old Windows built-in driver. Note that emulators (and some music software) vs "normal" programs have very different requirements, emulators generally create lots of very small blocks of sound in real-time (less than 1000 samples if buffer is very small), many times/second, other programs play much larger samples.

Quote:
Originally Posted by onkelarie View Post
Funny thing is (Correct me if I'm wrong Toni), that with these settings it tries to run PAL emulation, despite the 60hz monitor framerate.
It is normal. VSync does not care about PAL or NTSC, it simple changes "speed of time" to adjust emulation and real world refresh rates.

PAL emulation with 60Hz vsync means emulator still internally uses 50Hz timings (running program thinks it is running on PAL Amiga), only user sees 60Hz update. You can even adjust speed of emulation manually (fps adj setting) without breaking compatibility.
Toni Wilen is online now  
Old 07 October 2014, 11:38   #17
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
I double checked the sound driver, got the latest version from the manufacturer's page. It was the same I installed a few days ago, but I removed it and reinstalled just in case it was corrupted.

The result is still the same. I can make it run smooth but only if it is significantly faster, otherwise it stutters. (unless I disable sound, without sound it is stutter free).

When I get a new laptop sometime soon, I can try if it runs better on that, compared to this desktop. Also I was wondering, if it is some issue with my integrated sound card.... maybe disabling it and getting one of those cheap PCI or USB sound cards could help.

I noticed also this: Every time I change a setting it runs smooth for a few seconds before stuttering. As if it takes that long for some buffer etc. to get full or something.
hnn is offline  
Old 07 October 2014, 12:42   #18
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
This does not directly help you with WinUAE -- but you can also try FS-UAE. It has the same emulation code, but it uses completely different code to interface with your audio and video hardware. And if FS-UAE does not work well on your computer either, that's an interest result too...
FrodeSolheim is offline  
Old 07 October 2014, 13:09   #19
hnn
Registered User

 
Join Date: Oct 2014
Location: Finland
Posts: 10
Thank you, to be honest I had never even heard of this one.

I tried it and fiddled with the synchronization settings, but it seems whatever I try the result is exactly the same as with WinUAE.

It advised me to put my screen to 50hz, as I said earlier my monitor doesn't seem to like that and automatically reverts back to 59 or 60. I can try again if I can set it to 50 and make it stay that way, and see what happens.
hnn is offline  
Old 07 October 2014, 13:14   #20
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 36
Posts: 3,368
Actually, changing your screen mode to 50Hz (and fiddling with the syncronization settings) is only necessary if/when you want perfectly smooth scrolling (no stuttering graphics). It is not otherwise required, and performance will be better if you leave video sync *off*. Any sound issues will also be less likely to occur with video synchronization turned off.

If you still got sound issues in FS-UAE with *default FS-UAE settings*, this does further indicate that you have some kind of weird drives/hardware issue as Toni suggested...
FrodeSolheim is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio Popping and Stuttering EightTrackMind support.FS-UAE 10 01 March 2014 18:50
50 hz 60 hz stuttering? heinzgruber support.WinUAE 32 08 August 2013 14:23
WinUAE running @ 20fps with stuttering sound Moose support.WinUAE 13 08 September 2009 20:08
"Hard drive" access causes sound & video stuttering Gameboi project.WHDLoad 3 15 January 2009 17:59
Stuttering FullScreen Bushmaster support.WinUAE 2 05 June 2005 18:34

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:01.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.34180 seconds with 12 queries