English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 19 August 2014, 16:39   #181
amigafreak68k
Registered User
 
Join Date: Apr 2013
Location: Engelsdorf / Germany
Posts: 398
With .71 AmigaOS 4.x usage doesn't work
amigafreak68k is offline  
AdSense AdSense  
Old 19 August 2014, 16:43   #182
BinoX
Miggy Man
BinoX's Avatar
 
Join Date: Nov 2004
Location: Cornwall, United Kingdom
Age: 33
Posts: 831
It works fine with OS 4.0, it's what I'm using
BinoX is offline  
Old 19 August 2014, 16:53   #183
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 38
Posts: 1,580
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
yeah, no known issues regarding ppc firmware revision and os4.
Mad-Matt is offline  
Old 19 August 2014, 18:12   #184
ancalimon
Supernormal

ancalimon's Avatar
 
Join Date: Jul 2007
Location: Istanbul / Turkey
Age: 36
Posts: 1,229
Quote:
Originally Posted by Mad-Matt View Post
yeah, no known issues regarding ppc firmware revision and os4.
In the OS 4.1 booklet, it tells something about privately released firmwares (with GRex options) causing problems with OS4 detecting graphics board while installing.
ancalimon is offline  
Old 19 August 2014, 18:37   #185
themamboman
Registered User
 
Join Date: Dec 2012
Location: Atlanta, USA
Posts: 136
So, I'm following BinoX's OS4.0 install guide (link in this thread) and it appears to be working for OS4.1 as well. Good job!

Question: If PearPC was targetting a G3-level PowerPC CPU, what does QEMU target? Could we hope for G4 with Altivec support?

Where do we go to make donations to Toni?
themamboman is offline  
Old 19 August 2014, 18:40   #186
BinoX
Miggy Man
BinoX's Avatar
 
Join Date: Nov 2004
Location: Cornwall, United Kingdom
Age: 33
Posts: 831
I'm glad that it seems to work for OS 4.1 and I'm happy that it was useful

I shall buy myself a copy when/if the PPC emulation gets better and faster

There's a donate button at the top of the www.winuae.net site
BinoX is offline  
Old 19 August 2014, 18:50   #187
Schlachtwerk
68k RULEZ
Schlachtwerk's Avatar
 
Join Date: Jul 2010
Location: Germany
Posts: 168
Hi Guys, what i need to run elf Files under OS3.9 ?
Normal PPC Executables work but the elf files will not start.
Schlachtwerk is offline  
Old 19 August 2014, 19:07   #188
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,579
Send a message via Skype™ to Retrofan
With OS4.1 using my CyberstormPPC config I constantly get this Gurus, for example now just trying to rename my Apps partition:



All about DSI.

Edit: Maybe because I didn't enable Base page access on the install?

BTW with the beta 12 now I am installing OS4.1 on an A1200 BPPC plus Picasso IV it seems without problems.

Last edited by Retrofan; 20 August 2014 at 01:56.
Retrofan is offline  
Old 19 August 2014, 19:53   #189
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,936
Quote:
Originally Posted by Toni Wilen View Post
Wrong log. (Follow instructions in post #116 exactly).
Here is the log, I hope they are the right ones, there are two test one with blizzardppc and the other with CyberStormPPC configured in "Accellerator boards ROM"

Last edited by AMIGASYSTEM; 21 August 2014 at 09:36.
AMIGASYSTEM is offline  
Old 19 August 2014, 20:53   #190
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,520
Quote:
Originally Posted by AMIGASYSTEM View Post
Here is the log, I hope they are the right ones, there are two test one with blizzardppc and the other with CyberStormPPC configured in "Accellerator boards ROM"
I think you forgot to tick "Enable full logging" checkbox in Paths panel before starting emulation. Without it winuaelog.txt is not generated which is the most important part.
Toni Wilen is online now  
Old 19 August 2014, 21:08   #191
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 1,936
Hello Toni, excuse the trouble I'm procuring, hopefully I did well, I put the check mark for "Enable Full Log" before starting WinUAE

Last edited by AMIGASYSTEM; 21 August 2014 at 09:36.
AMIGASYSTEM is offline  
Old 19 August 2014, 21:28   #192
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,520
Quote:
Originally Posted by AMIGASYSTEM View Post
Hello Toni, excuse the trouble I'm procuring, hopefully I did well, I put the check mark for "Enable Full Log" before starting WinUAE
Do not use "UAE" controller, it is not visible outside of m68k AOS. It needs to be IDE. (Was already said many times in this thread I think..)

Also your BPPC config is a bit weird, A4000 ROM and A4000 hardware. BPCC is A1200 only.
Toni Wilen is online now  
Old 19 August 2014, 21:52   #193
DarrenHD
Registered User
 
Join Date: Aug 2008
Location: London / Canada
Posts: 339
Quote:
Originally Posted by Schlachtwerk View Post
Hi Guys, what i need to run elf Files under OS3.9 ?
Normal PPC Executables work but the elf files will not start.
Are you using the runelf program to start the elf programs ?
DarrenHD is offline  
Old 19 August 2014, 22:09   #194
Schlachtwerk
68k RULEZ
Schlachtwerk's Avatar
 
Join Date: Jul 2010
Location: Germany
Posts: 168
Quote:
Originally Posted by DarrenHD View Post
Are you using the runelf program to start the elf programs ?
Yes i have used runelf and the ppc lib emu.
Schlachtwerk is offline  
Old 19 August 2014, 22:25   #195
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 38
Posts: 1,580
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
Have you run ppclibemu_Install? Just having ppc.lib in libs isnt usually enough. You need to run the elf loadseg patch. This may crash the emu though
Mad-Matt is offline  
Old 19 August 2014, 22:47   #196
Schlachtwerk
68k RULEZ
Schlachtwerk's Avatar
 
Join Date: Jul 2010
Location: Germany
Posts: 168
Okay then we have the Problem ^^
Schlachtwerk is offline  
Old 20 August 2014, 00:46   #197
_ThEcRoW
Amiga Geek
_ThEcRoW's Avatar
 
Join Date: Apr 2005
Location: Spain
Age: 38
Posts: 904
@mad-matt
Thanks for the explanation regarding warpup and powerup! Will spend the next free days when available studying all that info. Mainly im interested in having a ppc enabled 3.9 system for experimentation, although i will take a look at os4 when i got the 3.9 all set up and running, one step at a time.
Thanks all for the various test and info provided, as it is a valuable resource too.
_ThEcRoW is offline  
Old 20 August 2014, 03:37   #198
Pyromania
Moderator

Pyromania's Avatar
 
Join Date: Jan 2002
Location: Chicago, IL
Posts: 1,785
How fast does OS 4.0 run if your running WinUAE on a nice i7 system? Anyone done some high end benchmarks on balls to the walls machines?
Pyromania is offline  
Old 20 August 2014, 04:18   #199
themamboman
Registered User
 
Join Date: Dec 2012
Location: Atlanta, USA
Posts: 136
Quote:
Originally Posted by Pyromania View Post
How fast does OS 4.0 run if your running WinUAE on a nice i7 system? Anyone done some high end benchmarks on balls to the walls machines?
What are some good OS4/PPC benchmarking tools to use?

I thought it was kinda slow on my 2011 MacBook Pro with an i7 2635QM processor with 4GB.

I put it on my desktop with an AMD FX-8350 and 16MB RAM and it was MUCH faster. That proc can hit 4.2Ghz in turbo mode.

I'd like to see the numbers too and compare them to my G3 Micro-A1C.
themamboman is offline  
Old 20 August 2014, 14:59   #200
themamboman
Registered User
 
Join Date: Dec 2012
Location: Atlanta, USA
Posts: 136
Got my emulation updated to 4.1 update 6. Now, just waiting for networking to work in OS4.1 so I can use AmiUpdate to get all the way to current.

http://i.imgur.com/MnIn24T.png

Last edited by themamboman; 20 August 2014 at 15:00. Reason: added picture
themamboman is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
PPC emulation for winuae marauder request.UAE Wishlist 25 04 November 2014 06:13
WinUAE appreciation thread Bloodwych Retrogaming General Discussion 34 26 August 2011 20:29
WinUAE ppc support? blasterreal support.WinUAE 8 29 September 2010 00:51
WinUAE: PPC Amiga Classic future emulation? DaNi support.WinUAE 24 12 January 2008 22:24
PPC on WinUAE ? glue request.UAE Wishlist 4 28 January 2007 12:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:34.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23700 seconds with 12 queries