English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 03 August 2014, 14:27   #1
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
Full screen vsync 50Hz not working

I'm not sure when this last worked on my machine as I have been using windowed mode for a while. Now if I try to enter fullscreen mode + low latency vsync+50hz pal refresh rate + no buffering WinUAE will not go fullscreen. It tries but nothing is displayed except a black screen and then it goes back to the desktop with winuae still active in the taskbar but nothing visible. I have an Intel HD 4000 graphics chip if this is any help.

Fullscreen + No buffering... works ok
Fullscreen + No buffering + low latency vsync...works
Fullscreen + No buffering + low latency vsync + 50Hz PAL refresh rate... FAILS
Fullscreen + No buffering + low latency vsync 50/60Hz... FAILS

Last edited by Steve; 03 August 2014 at 14:33.
Steve is offline  
AdSense AdSense  
Old 03 August 2014, 15:20   #2
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Quote:
Originally Posted by Steve View Post
I'm not sure when this last worked on my machine as I have been using windowed mode for a while. Now if I try to enter fullscreen mode + low latency vsync+50hz pal refresh rate + no buffering WinUAE will not go fullscreen. It tries but nothing is displayed except a black screen and then it goes back to the desktop with winuae still active in the taskbar but nothing visible. I have an Intel HD 4000 graphics chip if this is any help.
Checked using latest beta: fullscreen mode + low latency vsync + 50hz pal refresh rate and it's working on my rig (i5, gtx760).
Snake79 is offline  
Old 03 August 2014, 15:30   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,543
winuaelog.txt required but it is most likely display driver problem (or lack of real 50Hz support).
Toni Wilen is offline  
Old 03 August 2014, 18:44   #4
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
Hmmmmm......... false alarm!

Strangely enough after returning to the problem it seems to have resolved itself. Its now working fine! Maybe it just needed a restart. Perhaps some Windows 8.1 driver issue? Sorry about that. Oh well thanks anyway.
Steve is offline  
Old 02 November 2015, 00:32   #5
volvo_0ne
Registered User

 
Join Date: Mar 2015
Location: Sheffield UK
Posts: 232
I'm no expert, (far from it) but "No Buffering" seems to fix a lot of GFX speed and especially scrolling issues on WinUae.

I've no idea why, but it seems to work in many cases.
volvo_0ne is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen in full screen but not full window Winuae all versions Mixter support.WinUAE 18 30 June 2013 00:45
On the fly full screen <-> full window switching NewDeli request.UAE Wishlist 19 22 May 2010 17:40
getting screen modes working full screen damo support.WinUAE 1 06 February 2009 22:12
Want to get full screen working well? need tips dword support.WinUAE 15 22 July 2008 13:44
100hz screen with vsync Diggit support.WinUAE 10 24 January 2003 17:17

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:47.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17340 seconds with 11 queries