English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 14 July 2014, 19:48   #1
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
Angry Problem Sprite RTG Nightlong

Possible to systematize it

Viper2000 is offline  
AdSense AdSense  
Old 14 July 2014, 19:59   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Do you have game 1.2 patch installed? (link can be found in hol entry)
Tested without JIT?
Toni Wilen is online now  
Old 14 July 2014, 20:03   #3
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
Yes everything
Viper2000 is offline  
Old 14 July 2014, 20:14   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,510
It's normal. Happens on real Amiga, too.
thomas is offline  
Old 14 July 2014, 20:18   #5
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
no real amiga it's ok
Viper2000 is offline  
Old 14 July 2014, 20:25   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Real Amigas can also have different RTG setups, different CPUs and more.. It means nothing.

You can try to 100% matching RTG mode, including byte order and depth.
Toni Wilen is online now  
Old 14 July 2014, 20:37   #7
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
I have tried but nothing. patience
There is a problem in palette color?
Viper2000 is offline  
Old 14 July 2014, 20:52   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
It is not using palette mode, it can't be palette problem

What about this: adjust second color mode box (expansion panel) to R5G5B5, third to (24bit) and fourth to (32-bit) (=disable last two)

Apparently original version of game wanted big-endian 16-bit color mode.

(I am not interested because it is a PC port)
Toni Wilen is online now  
Old 14 July 2014, 21:07   #9
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
Nothing.Patience
Viper2000 is offline  
Old 14 July 2014, 21:21   #10
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
Now it's ok. Thanks
Viper2000 is offline  
Old 15 July 2014, 14:09   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Do you mean glitches are gone after using above 15-bit mode? (which is the only mode that game supported originally, patches added 24/32-bit mode support)
Toni Wilen is online now  
Old 15 July 2014, 16:04   #12
Viper2000
Registered User
 
Join Date: Jul 2011
Location: Alaska
Posts: 24
Quote:
Originally Posted by Toni Wilen View Post
Do you mean glitches are gone after using above 15-bit mode? (which is the only mode that game supported originally, patches added 24/32-bit mode support)
Yes R5G5B5->(24bit)->B8G8R8A8(*).
Thanks
Viper2000 is offline  
Old 17 July 2014, 13:06   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Ok, so it is a game bug in little-endian graphics modes (BGR color component order) which were introduced in game patch.

This is not just emulation problem, some real RTG boards are also BGR only because used PC graphics chip does not support other byte orders.
Toni Wilen is online now  
Old 17 July 2014, 16:30   #14
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,510
Like I said, it happens on real Amiga, too, when using a graphics card similar to the emulated one (Voodoo3 in my case).
thomas is offline  
Old 17 July 2014, 18:04   #15
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
I wanted to 100% confirm it. (RGB vs BGR game bug)
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
RTG Question and Maybe Problem Ed Cruse support.WinUAE 2 11 November 2012 16:44
RTG problem affleck support.WinUAE 2 22 October 2006 01:05
winUAE rtg problem deoFusion New to Emulation or Amiga scene 0 28 September 2006 10:41
Another World WHDload & Sprite problem! immodium support.Games 6 03 November 2005 21:04
RTG Problem :( BippyM support.WinUAE 1 12 November 2002 01:09

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:16.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17695 seconds with 11 queries