English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 03 July 2014, 20:30   #1
Michael Sykes
WinUAE end user

Michael Sykes's Avatar
 
Join Date: Jan 2014
Location: Bremen
Age: 38
Posts: 623
Angry Autofire broken?

I wanted to play Turrican II after a very long time.
So I went to input settings and used autofire for joy2(button1) on my 3rd button on the pc controller(p880).I used to play it without it back in the days but maybe I get old...

The problem is that it does start firering but does not stop.
No matter which button I press.
I do not use toggle mode.Tryed it but it doesn't help with the problem.

I did not try in quickstart yet I used the whdload version and a very bloated scalos as my desktop.Last time I played it everyting was fine.
Ok I disabled JIT but thats normal for me playing older games and demos.

What can it be? Anyone an idea? Toni,maybe?

EDIT: I tried quickstart mode A500 and it behaves exactly the same way. One button press starts autofire but it never stops. If I hold the button it will activate the secondary weapon and if I release it autofire starts again.

Last edited by Michael Sykes; 03 July 2014 at 20:47.
Michael Sykes is offline  
AdSense AdSense  
Old 03 July 2014, 21:07   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,531
Works for me -> attach your config file.
Toni Wilen is offline  
Old 03 July 2014, 21:33   #3
Michael Sykes
WinUAE end user

Michael Sykes's Avatar
 
Join Date: Jan 2014
Location: Bremen
Age: 38
Posts: 623
As I wrote above it did not work in qickstart,too.
But if it helps in some way here is my config.
I used to start it and changed the controls from 'CD32' to 'default' for the P880 on the fly.And I disabled JIT after starting the game.

http://www.file-upload.net/download-....9---.uae.html
Michael Sykes is offline  
Old 03 July 2014, 22:16   #4
Michael Sykes
WinUAE end user

Michael Sykes's Avatar
 
Join Date: Jan 2014
Location: Bremen
Age: 38
Posts: 623
I found the problem! It was the Saitek Profile editor.
I have no idea what caused it but after loading the defaults it works like intended again.

Sorry for wasting your time Toni.
Thanks for the quick reply and keep up the good work.

EDIT: I also just did not realize there are 3 options to toggle for autofire,
on,yes and no.Now I feel really stupid.
But Turrican with autofire works and that was what I wanted!

Last edited by Michael Sykes; 03 July 2014 at 22:29.
Michael Sykes is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Joystick Autofire daznic support.Hardware 6 18 October 2016 20:56
Winuaex autofire? Jerry support.OtherUAE 4 10 July 2009 11:22
Autofire with Keyboard Kellerkind support.WinUAE 0 31 August 2006 17:22
How do I use autofire for keyboard? leipuri support.WinUAE 3 27 June 2006 17:49
Autofire in WinUAE Mudr support.WinUAE 0 06 September 2004 11:07

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:09.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11862 seconds with 11 queries