English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 20 March 2014, 11:42   #1
Sascha
 
Posts: n/a
GUI : "Chipset Extra" drop-down control behavior

Ok, maybe something's fishy on my system or maybe I am simply missing some basic understanding on this, but I noticed a few oddities in regards to the "Chipset Extra" settings in the GUI (located under Settings/Hardware/Chipset). This behavior is present in the latest beta (2.7.1 public beta 11) but also seems to go back all the way to at least version 1.4.0 (haven't tried any earlier versions, though). It happens on a clean install, after starting WinUAE for the first time.

a) Independent of what you choose in the "Chipset Extra" drop-down list, nothing changes in regards to what is selected with the radio buttons above. My first guess was that these two should correlate, i.e. once you select some specific preset it would select the appropriate radio button. But, I might be wrong about this, obviously.

b) In that drop-down control there's an empty entry right above the entry called "Generic". Once I select that empty entry, the whole drop-down control becomes disabled (grayed-out) and I cannot select anything else any longer.

c) More a suggestion for improvement than a report: it would be nice of all those drop-down controls could be controlled by the cursor up/down keys once they have the focus.

Hope this is of some help. Aside from that, kudos and thanks to you, Toni, for developing and maintaining this great piece of software over all those years!

Cheers,
Sascha

Last edited by Sascha; 20 March 2014 at 11:55.
 
AdSense AdSense  
Old 20 March 2014, 11:56   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,510
Quote:
Originally Posted by Sascha View Post
a) Independent of what you choose in the "Chipset Extra" drop-down list, nothing changes in regards to what is selected with the radio buttons above. My first guess was that these two should correlate, i.e. once you select some specific preset it would select the appropriate radio button. But, I might be wrong about this, obviously.
The "Chipset-Extra" selects the motherboard, not the chipset. If you select A4000 for example, you get an IDE controller and ZorroIII, but you can still use OCS on this motherboard.

Quote:
b) In that drop-down control there's an empty entry right above the entry called "Generic". Once I select that empty entry, the whole drop-down control becomes disabled (grayed-out) and I cannot select anything else any longer.
The Chipset-Extra basically is an easy way to select a consistent set of options from the the "Adv. Chipset" page. If you select the empty entry, the "compatible settings" mark is unchecked on the Adv.Chipset page. If you check "Compatible Settings" again, then "Chipset Extra" will be enabled, too. (But the rest of Adv. Chipset is grayed-out).

Quote:
c) More a suggestion for improvement than a report: it would be nice of all those drop-down controls could be controlled by the cursor up/down keys once they have the focus.
I am quite sure that this ranges in the category of "GUI programming" and everybody should know how much Toni likes this category
thomas is offline  
Old 20 March 2014, 12:05   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
GUI uses standard Win32 elements and have usual standard key shortcuts.

EDIT: shift or control + cursor keys work.

EDIT2: Normal cursor up/down is disabled, I think there was some reason for it but I don't remember anymore..

Last edited by Toni Wilen; 20 March 2014 at 20:04.
Toni Wilen is online now  
Old 20 March 2014, 23:46   #4
Sascha
 
Posts: n/a
Thanks a lot guys for "de-mystifying" these settings... it all makes much more sense now.

Cheers,
Sascha
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
small GUI bug: ghosting of "write protection" label df0/df1 rsn8887 support.WinUAE 1 23 August 2010 17:02
Do you keep extra spare amiga hardware "just in case" ? keropi Amiga scene 32 26 March 2007 13:52
"Chipset Extra" bug? Marte support.WinUAE 1 21 March 2007 20:00
Does "Cycle-exact" do nothing with the AGA chipset? fmcpma support.WinUAE 10 26 October 2006 13:11
Scanned reviews of "Drop It" & "Project Ikarus" Tim Janssen HOL contributions 1 15 May 2003 09:55

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:44.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17257 seconds with 11 queries