English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 17 March 2014, 14:02   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Artifacts with frame skip and double, fields line mode

I noticed a problem when:
- The Amiga video output is interlaced
- Using one of the new double, fields and double, fields+ interlaced line modes
- Frame skip (refresh slider in display settings) is set to skip an odd number of fields.

With double, fields: Only one field is ever updated, leaving the lines of the other field unchanged.
With double, fields+: Only one field is ever shown (e.g. always the odd field)

The problem doesn't happen with the old double, frames line mode for some reason.

I think the simplest fix would be to round the number of frames skipped so only an even number of fields are skipped when using the new line modes. (So enabling one of those line modes would remove the 2nd, 4th, 6th etc. tickmarks from the refresh slider.)
Attached Thumbnails
Click image for larger version

Name:	Example1.png
Views:	101
Size:	14.4 KB
ID:	39423   Click image for larger version

Name:	Example2.png
Views:	79
Size:	5.3 KB
ID:	39424   Click image for larger version

Name:	Example3.png
Views:	87
Size:	3.4 KB
ID:	39425  
mark_k is offline  
AdSense AdSense  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Modifying WinUAE's scanlines line mode mark_k support.WinUAE 24 18 November 2013 21:07
Vsync Fullscreen and Double Buffer, incorrect frame rate? rsn8887 support.WinUAE 1 07 April 2011 20:43
Line mode blitter absence Coders. General 4 25 September 2009 20:50
TV line mode Avanze request.UAE Wishlist 0 25 July 2006 17:37
Blinking Taskbar Line in FS mode ;(( Leo42 support.WinUAE 3 31 May 2003 13:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:45.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15922 seconds with 12 queries