English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 08 March 2014, 20:29   #1
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
cdtv feature missing or fail !

[ Show youtube player ]

look at 14:20 he launches lemmings from diskette adn after put an audio cd in the cdtv and with the cdtv front panel play the music from the audio cd...
I can't do it from winuae even if i map the the front panel to keys or joypad !!!
Did i do something wrong or winuae doesn't emulate this feature correctly ?
turrican3 is offline  
AdSense AdSense  
Old 11 March 2014, 18:31   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
It is emulated (even if it is quite useless feature, front panel buttons are CD mechanism hardware feature, not Amiga feature) but it didn't work because state of "front panel buttons enabled" variable was wrong after reset and non-CD booting didn't send any "front panel on/off" packets to CD drive.
Toni Wilen is offline  
Old 21 March 2014, 16:19   #3
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
hi Toni,
i tried with the last beta, if i launch a game like xenon 2, the front panel works.
But if i launch like in the video lotus 2 and mount an iso with music or even a game like xenon 2, it doesn't work even with the screen display on, i can't see the emulated cdtv trying to read the cd or else nothing happened when i try to use cdtv front panel when i boot on an adf but like i said it works if you boot from a cd.
I suppose when you boot from adf the cdtv doesn't control anymore the cd-rom, this is the cd-rom itself which react alone when you use the cdtv front panel ???
Thank to improved the cdtv emulation because i couldn't launch xenon 2 with winuae 2.7.0 but i can with beta 11. I didn't test others beta.
turrican3 is offline  
Old 21 March 2014, 16:34   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Sorry but your explanation is too confusing..

btw, your Xenon test is invalid, you just inserted the CD after CDTV title screen and in other test you had it already inserted.
Toni Wilen is offline  
Old 21 March 2014, 16:39   #5
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
Quote:
Originally Posted by Toni Wilen View Post
Sorry but your explanation is too confusing..

btw, your Xenon test is invalid, you just inserted the CD after CDTV title screen and in other test you had it already inserted.
I always tried with xenon 2 already mounted, i never wait the cdtv title.Even when i launch lotus 2 the cdtv naturally choosed to boot on the df0.
To be sure i tried with the cdtv logo already displayed but i have the same result.
Sorry for my english, it still difficult to me to clearly translate what i think, i will try to improve it.

Last edited by turrican3; 21 March 2014 at 16:48.
turrican3 is offline  
Old 21 March 2014, 16:43   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Quote:
Originally Posted by turrican3 View Post
I always tried with xenon 2 already mounted, i never wait the cdtv title.
Xenon 2 only works if CD is inserted after title screen. You had different config if worked without waiting, even enabled drive changes memory usage!

EDIT: Just write simply step by step instructions, instead of wall of text..
Toni Wilen is offline  
Old 21 March 2014, 16:52   #7
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
Quote:
Originally Posted by Toni Wilen View Post
Xenon 2 only works if CD is inserted after title screen. You had different config if worked without waiting, even enabled drive changes memory usage!

EDIT: Just write simply step by step instructions, instead of wall of text..
Sorry, you are right, i surely did a reset during my tests. On true cdtv does work like this ???? Do you have to wait the cdtv intro screen to launch xenon 2 ? Sorry i never had a cdtv.
ps "Toni :Just write simply step by step instructions, instead of wall of text.. " He'll keep your tip in mind.

Last edited by turrican3; 21 March 2014 at 17:06.
turrican3 is offline  
Old 21 March 2014, 18:25   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Xenon II is real CDTV confirmed.
Toni Wilen is offline  
Old 23 March 2014, 16:02   #9
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
Quote:
Originally Posted by Toni Wilen View Post
Xenon II is real CDTV confirmed.
Did you have a doubt ?
turrican3 is offline  
Old 23 March 2014, 18:44   #10
mr.vince
Cheesy crust

mr.vince's Avatar
 
Join Date: Nov 2008
Location: Hawk's Creek
Age: 41
Posts: 1,374
No.
mr.vince is offline  
Old 22 December 2014, 05:04   #11
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
Hi Tony,
launching a cdda with the input : cdtv front panl play,
should work now ???
You know i made the test like the guy who launch lotus 2 on cdtv and play a cd audio during the game.
I tried with a true cd-audio and an iso and i have the same result.
The on-screen display show that the cd is running, but no music go out of my computer.
the log
Attached Files
File Type: txt winuaelog.txt (8.6 KB, 35 views)
turrican3 is offline  
Old 22 December 2014, 05:23   #12
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
ok same config but this time i tried to start to play cdda just after the rom (bios) is loaded then the cdda launch and this time i can hear the music !!
and the adf is read like usual. why can i hear the music, if i press fastly, just after the launch : the cdtv front panel start/pause.
But if i wait just 1/10 of second cdda start but i can't hear nothing ???
log
Attached Files
File Type: txt winuaelog.txt (8.6 KB, 37 views)

Last edited by turrican3; 22 December 2014 at 05:30.
turrican3 is offline  
Old 22 December 2014, 08:28   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Both logs show track 1 being played. Perhaps you have another sound device or output? CD audio (currently) uses totally separate code path and probably only goes to default audio output device.
Toni Wilen is offline  
Old 22 December 2014, 20:35   #14
turrican3
Moon 1969 = amiga 1985

turrican3's Avatar
 
Join Date: Apr 2007
Location: belgium
Age: 41
Posts: 3,124
ok toni,
i will look... but it sounds strange to me that i can hear the cdda if i launch it very fastly, but i can't if i wait even 1/2 second, and i never had any problems with cdda before ????
But i'll have a look to your idea.
turrican3 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
CDTV: Snoopy: In The Case Of The Missing Blanket & MI 1 copkiller64 request.Old Rare Games 20 15 July 2010 10:58
Snoopy In ''The Case Of The Missing Blanket'' CDTV mk1 request.Old Rare Games 6 18 August 2009 00:30
Missing/rare CDTV titles mai HOL contributions 3 30 August 2008 01:27
Games missing high score saving feature Shoonay project.WHDLoad 5 21 May 2006 18:56
Some CDTV CD32 missing scans XoreX HOL contributions 7 24 November 2004 22:40

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:34.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.31052 seconds with 12 queries