English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 09 February 2014, 15:45   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Config file backward compatibility

A little tip for anyone having issues using a config saved with WinUAE 2.7.0 with earlier WinUAE versions...

I wanted to use my current config with an earlier version of WinUAE. But since adjusting the config and saving with a newer version, something about it causes older versions to crash.

The config works with WinUAE 2.7.0. With WinUAE 2.6.1, loading and starting emulation gives this log output:
JIT: Can't handle access 00839A40!
JIT: Can't handle access 7BC52DE4!
... that line repeated many times ...
JIT: Can't handle access 7BC52DE4!
Segmentation fault


Loading the config, disabling JIT and starting emulation just reports
Segmentation fault

Similar result with WinUAE 2.6.0, except there without JIT it reports:
ExceptionFilter Trap: 09B96AAC 38E800E2 00000000
Segmentation fault


It turns out that the cause of the problem was using the new line mode settings in WinUAE 2.7.0. In the config I have line mode set to Double and interlaced line mode set to Double, fields. For whatever reason earlier versions of WinUAE don't like that; no Line mode radio button is selected when I load the config. After setting line mode to Double I was able to start emulation as normal.
Attached Files
File Type: zip my_test_JIT.uae.zip (3.0 KB, 27 views)
mark_k is offline  
AdSense AdSense  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem to load config file and quicksavestate Kloks support.WinUAE 23 30 March 2013 18:35
Detailed WinUAE config file description ldaneels support.WinUAE 5 21 October 2012 06:42
Autoload for config file at startup hoderer support.WinUAE 3 04 May 2010 07:56
Are WinUAE config files backward compatible? antonvaltaz support.WinUAE 5 30 November 2009 00:41
where to put -norawinput in a config file? for vista usage kirk support.WinUAE 18 09 April 2009 19:24

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:57.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.09708 seconds with 12 queries