English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 28 December 2013, 12:34   #1
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
WinUAE crashing after Alt-Tab

Exactly as stated in the title. Anytime I perform an Alt-Tab while in full-screen mode then WinUAE crashes. I am using version 2.7. Attached are a couple of dumps.
Attached Files
File Type: dmp winuae_270_20131227_191301.dmp (45.2 KB, 58 views)
File Type: dmp winuae_270_20131228_112913.dmp (45.1 KB, 49 views)
Steve is offline  
AdSense AdSense  
Old 28 December 2013, 12:43   #2
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
JFI ... I have also tried Alt-Tab in full-screen with official WinUAE 2.7.0 (2013-12-05) and on my WinXP SP3 PC/Laptop it works fine !!!

@steve
Do you still use an old config file for new 2.7.0 ... if yes, try to save a new config file from 2.7.0 and use this one instead ... maybe this help.
amilo3438 is offline  
Old 28 December 2013, 12:49   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Of course it does not crash on all systems, it is 100% obvious (and D3D code path is different on pre-Vista systems anyway)

Vsync only? (You seem to have vsync enabled)
RTG or native screen only?

Does it really work with 2.6.1? (I don't think so for some reason..)

EDIT: and of course, winuaelog.txt needed.
Toni Wilen is online now  
Old 28 December 2013, 13:01   #4
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
Hi. Vsync off still seems to make it crash. It is just standard display not RTG. New logs attached. It has been crashing a little differently now. Alt-Tab back to Windows seems ok but then go back to WinUAE and it crashes. Very odd. I don't know about 2.6.1 but I don't think I remember this happening before. It is a new configuration file I have created especially for Putty Squad that I'm using.
Attached Files
File Type: txt winuaelog.txt (7.0 KB, 51 views)
File Type: dmp winuae_270_20131228_115612.dmp (49.0 KB, 58 views)
File Type: dmp winuae_270_20131228_115746.dmp (53.4 KB, 51 views)
Steve is offline  
Old 28 December 2013, 13:15   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
Please test with 2.6.1 because it crashes inside D3DX9_43.dll. D3DXCore::CSprite::Flush so it must have something to do with D3DSprites. If you have on screen leds enabled, try to disable them, any change?
Toni Wilen is online now  
Old 28 December 2013, 13:51   #6
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
Quote:
Originally Posted by Toni Wilen View Post
Please test with 2.6.1 because it crashes inside D3DX9_43.dll. D3DXCore::CSprite::Flush so it must have something to do with D3DSprites. If you have on screen leds enabled, try to disable them, any change?
Yep, that's the problem! Turned off the on screen LEDs and there is no crashing with Alt-Tab now. So maybe it is a graphics driver related issue? I am only using the on-board Intel graphics processer that is in the i7-3770k - I don't have a dedicated graphics card. Do you still want me to try 2.6.1?
Steve is offline  
Old 28 December 2013, 15:01   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,561
If 2.6.1 crashes, it is near-guaranteed it is driver problem.
Toni Wilen is online now  
Old 31 December 2013, 17:38   #8
Steve
FreelanceAndroidDeveloper
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 38
Posts: 2,103
Quote:
Originally Posted by Toni Wilen View Post
If 2.6.1 crashes, it is near-guaranteed it is driver problem.
I've just tested out the same configuration with 2.6.1 and get the same problem so it looks like its definitely a driver issue. Oh well. Not a big deal I guess. I'll just leave the LED's off as I don't need them all the time. Thanks for your help.
Steve is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.3.2 alt-tab vs priority behavior Photon support.WinUAE 0 29 July 2011 01:50
Default configurations tab in WinUAE antonvaltaz support.WinUAE 7 18 July 2011 15:00
HowTo Alt+Tab in Style NewDeli New to Emulation or Amiga scene 0 16 November 2009 12:33
Alt-Tab behavior solution Photon support.WinUAE 14 01 October 2009 23:35
WinUAE 1.3 crashing Tony Landais support.WinUAE 11 26 July 2006 12:59

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:26.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.13749 seconds with 12 queries