English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 16 December 2013, 09:48   #1
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Lightbulb BetterWB 3.2 released

BetterWB 3.2 16-DEC-2013

This is a new version of BetterWB workbench pack, that aims to be an enhancement, an updated extension to AmigaOS 3.1, without all those hardware requirement typically associated with these kind of packs. It is indeed a better 3.1 than 3.1 itself!

BetterWB works on any Amiga. It installs on top of a clean AmigaOS 3.1 installation. It is distributed as a set of floppy images and occupies about 8MB of harddrive space.

Changes since last version:

-DosPrefs is a commodity that replaces both Clicknot and Unixdirs3 and adds wildcard support
-A powerful system Trashcan is now included as a commodity
-MagicMenu has now a preferences program and is configured to use less resources
-boards.library got updated to its last incarnation
-A bugfixed requestchoice command fixes 3 bugs that were previously available
-Tooltype tweaking on some commodities for more comfortable use
-Workaround for an icon.library bug regarding internal deficons
-Format GUI now works without problems
-Plus Many more fixes and minor enhancements

You can download BetterWB from its homepage at:

http://lilliput.amiga-projects.net/BetterWB.htm

Last edited by gulliver; 17 December 2013 at 00:15.
gulliver is offline  
AdSense AdSense  
Old 16 December 2013, 12:36   #2
Nostromo
Registered User
 
Join Date: Dec 2008
Location: The World!
Posts: 414
Hi Gulliver what's up remember me?

Thanks for the update, I will check it out!
Nostromo is offline  
Old 16 December 2013, 17:18   #3
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 1,751
bugfixed requestchoice: It`s not multirequestchoice from Aminet?

-Workaround for an icon.library bug regarding internal deficons

What bug exactly is/was this?
daxb is offline  
Old 16 December 2013, 17:28   #4
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,736
Quote:
Originally Posted by daxb View Post
-Workaround for an icon.library bug regarding internal deficons

What bug exactly is/was this?
You can not nail pictures on the wall that don't exist.
http://eab.abime.net/showpost.php?p=...&postcount=776
PeterK is offline  
Old 16 December 2013, 17:59   #5
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Quote:
Originally Posted by daxb View Post
bugfixed requestchoice: It`s not multirequestchoice from Aminet?

-Workaround for an icon.library bug regarding internal deficons

What bug exactly is/was this?
It is not multirequestchoice, it is http://aminet.net/util/sys/ReqCh.lha

About the icon.library issue:
http://eab.abime.net/showpost.php?p=...&postcount=776

Last edited by gulliver; 16 December 2013 at 18:34.
gulliver is offline  
Old 16 December 2013, 18:05   #6
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Quote:
Originally Posted by PeterK View Post
You can not nail pictures on the wall that don't exist.
http://eab.abime.net/showpost.php?p=...&postcount=776
It is certainly true that the picture does not exists alone, by itself. But it is shown as such.

Maybe we can consider it as a drawing on the wall
gulliver is offline  
Old 16 December 2013, 18:18   #7
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,736
Hi gulliver,

yes, of course, I will create a real icon based on the internal default image and then snapshot its position. Btw, this works already without problems on WB v44+, but it seems I made a mistake somewhere in the v39 / v40 support code.

Thanks for adding the ENVARC:sys/def_disk.info file as a workaround for now. Unfortunately, your link above to page 39 can be a bit confusing. Better would be a link to the postcount 776.
PeterK is offline  
Old 16 December 2013, 18:45   #8
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Hi PeterK,
Thank you for your dedication on icon.library. I rectified my post as you suggested.
gulliver is offline  
Old 16 December 2013, 19:12   #9
Leffmann

 
Join Date: Jul 2008
Location: Sweden
Posts: 2,029
Thanks for the update!

A small suggestion: the default configuration for DirWork has the Edit buttons set up as
Run >NIL: E
, either changing them from E to Ed or creating a file link C:E -> C:Ed to save users the trouble.

Last edited by Leffmann; 17 December 2013 at 09:50. Reason: Removed hard return.
Leffmann is offline  
Old 17 December 2013, 00:16   #10
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Quote:
Originally Posted by Leffmann View Post
Thanks for the update!

A small suggestion: the default configuration for DirWork has the Edit buttons set up as
Run >NIL: E
,
either changing them from E to Ed or creating a file link C:E -> C:Ed to save users the trouble.
Thank you for this suggestion. It will be integrated in the next release.
gulliver is offline  
Old 17 December 2013, 01:55   #11
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 1,751
Thanks. I thought the original OS3.1 icon.library was ment.
daxb is offline  
Old 17 December 2013, 02:08   #12
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Quote:
Originally Posted by Nostromo View Post
Hi Gulliver what's up remember me?

Thanks for the update, I will check it out!
Hi Conrad I hope you are doing fine. It is good to see you here
gulliver is offline  
Old 18 December 2013, 02:31   #13
arti040
Piotr

 
Join Date: Jul 2013
Location: Lodz/Poland
Age: 33
Posts: 149
Send a message via Skype™ to arti040
Thanks! In the Xmas break i'll try to test it finally
arti040 is offline  
Old 24 December 2013, 18:50   #14
christianlucio
Registered User
 
Join Date: Apr 2009
Location: Sigmaringen / Germany
Posts: 109
Install over "old" 3.1 installation

I would like to install BetterWb over my "old" 3.1 Installation that I use for many years but would have 2 questions:- is this without risks or should it be really a "clean" 3.1. Installation- what about the new fastfilesystem 44.5: do I have to format the partitions again and copy back all the files?Many thanks in advance.
christianlucio is offline  
Old 29 December 2013, 18:28   #15
arti040
Piotr

 
Join Date: Jul 2013
Location: Lodz/Poland
Age: 33
Posts: 149
Send a message via Skype™ to arti040
Hi,
Few days ago i played with BetterWb and found one "bug". NewIcons4 are not being installed properly - Installer does not display propositions of drawers and disk icons during installation. I don't know, why it is happen. I've tried few Installer versions but w/o success. I think, it can be datatypes or some library related issue. On clean Wb3.1 installation it works like a charm.
arti040 is offline  
Old 01 January 2014, 17:42   #16
Leffmann

 
Join Date: Jul 2008
Location: Sweden
Posts: 2,029
A small bug-report:

PatchWB introduced in 3.2 seems to actually cause the very bug it intends to fix, and programs like f.ex Deluxe Paint IV which defaults to closing the Workbench screen fail to open it again, and the Amiga just gets stuck on a black screen.

I think Thomas Richter still has some interest for Amiga, maybe he'd be willing to look into it.
Leffmann is offline  
Old 01 January 2014, 20:33   #17
gulliver
BoingBagged

 
Join Date: Aug 2007
Location: The South of nowhere
Age: 39
Posts: 1,498
Hi
@christianlucio
I am sorry I am replying so late, but I have been out from my country for about a week, very busy visiting relatives.

I have seen you have received the help you needed in another thread from other forum members.
EAB is indeed a very friendly community!

@arti040
I will check to see what is going on with the NewIcons install script and report back. Maybe it is doing some non standart things to the system, or making wrong assumptions.

Remeber the included PeterK´s icon.library should let you see NewIcons without fuss. The only thing you should tweak is the number of colors your screenmode uses, so that you see them properly.

@Leffmann
Thank you for your report.
I will check it out and see what we can do about it.
gulliver is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
BetterWb 3.0 06-OCT-2013 gulliver News 20 06 November 2013 21:22
BetterWB release 2.9 - 23.08.2013 gulliver News 37 15 September 2013 00:04
BetterWB - release 2.0 gulliver support.Other 32 27 January 2012 23:35
BetterWB - release 1.0 gulliver support.Other 28 20 May 2011 17:42
Never released??? tomcat666 project.aGTW 18 18 January 2010 15:44

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:58.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.19499 seconds with 11 queries