English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 08 December 2013, 18:16   #1
ramparts
Registered User
 
Join Date: Apr 2011
Location: porto/portugal
Posts: 50
Rockge plus Drivers

i am Looking for drivers for the rockgen plus genlock since i plug a video source on mine and my amiga workbench aprears black half screen.

Help would be appreciated.
ramparts is offline  
Old 09 December 2013, 00:51   #2
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,545
i only can find a pdf-manual and a demo disc for the RocGen RG300C..
emufan is offline  
Old 09 December 2013, 00:56   #3
ramparts
Registered User
 
Join Date: Apr 2011
Location: porto/portugal
Posts: 50
thank you for the reply but this is my version of the genlock



ramparts is offline  
Old 09 December 2013, 01:18   #4
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,545
yes i know but there is no download manual/floppy for RocGen Plus.
maybe the website by Stone Oakvalley could give you some help on general use of such device.
on eab fileserver there is a video "#11 Roctec Rockey RG320C Chroma Key Video Tutorial" - they also mention RocGen Plus IIRC.

here is another posting about problem with RocGen Plus.
emufan is offline  
Old 11 December 2013, 19:20   #5
ramparts
Registered User
 
Join Date: Apr 2011
Location: porto/portugal
Posts: 50
i managed to put it work ,but it seems that when genlocking games the screen kepps scrooling always up,i don´t know if this is normal.
Under workbench works ok.
ramparts is offline  
Old 11 December 2013, 19:29   #6
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,545
here they write:
Quote:
Furthermore it required a constant video feed to behave normally.
perhaps weak powersupply. cannot say, sorry.
test some graphics applications, DPaint or Scala - those supporting and were designed for such genlocks.
emufan is offline  
Old 11 December 2013, 20:25   #7
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,115
Quote:
Originally Posted by ramparts View Post
i managed to put it work ,but it seems that when genlocking games the screen kepps scrooling always up,i don´t know if this is normal.
Under workbench works ok.
Yes I think that's normal. The reason is, Kickstart detects the presence of the genlock and if found it sets the ERSY bit in the BPLCON0 custom chip register. That bit enables external synchronisation, so the Amiga video signal is synchronised to the genlock video.

The problem comes when non-system-legal programs (i.e. most games and demos) write to BPLCON0 themselves. They don't set the ERSY bit (or the LACE bit) and so the Amiga output is out of sync with the genlock video.

It would be possible for WHDLoad installer writers to add an option to set ERSY and/or LACE bits to their installers. Then it should be possible to use demos/games whose installers have that option correctly with a genlock. But as far as I know no existing installers have that option. And for booting unmodified games/demos from floppy disk, you're kind of stuck unless you modify the code yourself (which would actually be quite easy to do in many cases.)
mark_k is offline  
Old 11 December 2013, 21:16   #8
ramparts
Registered User
 
Join Date: Apr 2011
Location: porto/portugal
Posts: 50
Thank you for the reply´s
The other post mentionate that too ,no vertical syncro.
Other thing that i found bad is when i put or save an edited animation on dpaint 3 always have the left and top with colour ,just if there was the tool menu and option menu there .
I can´t manage to change color on thar either .
In workbench woks ok ,despite of ,yes,it has to have a constant video signal,when it´s un conected ,or like my camera gets down,when is not saving,the image gets crazy for some seconds,till workbench screen appears again.
ramparts is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drivers BippyM support.Hardware 2 22 May 2011 19:34
Drivers For Hardware THX1138 support.Hardware 13 21 April 2006 21:42
Catweasel drivers ? stainy support.Hardware 6 08 November 2005 02:59
Triceratops drivers Computolio request.Apps 0 19 June 2005 08:06
HELP: BVision drivers Amigamancer request.Apps 15 19 April 2005 16:23

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06724 seconds with 12 queries